Home Forums Weaver Xtreme Theme Read more link not showing after manual Read more tag

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #64091
    kiezels
    Participant

    Hi,

    Any idea why the Read more link is not showing after a manually inserted Read More tag, whereas it is showing after an automated excerpt?

    regards, Anita

    #64096
    scrambler
    Moderator

    Please provide a link to the page containing it, as well as copy paste the text from the post that contains the tag here

    #64100
    kiezels
    Participant

    Hi Scrambler,

    The webpage is https://www.goederedeconcerten.nl/exposities/. The first post has a manual Read More tag, the rest of the posts have an automatic excerpt.

    The text of the post is:

    De Almeerse Simone Hakhoff werkt voornamelijk met acryl op doek. Haar schilderijen zijn een combinatie van abstract en figuratief met een vleugje humor. Kleur is daarbij een belangrijk gegeven. <!–more–>De basis is gelegd en de vormen die ontstaan, werkt zij al dan niet uit tot een verhaal.

    Hope you can help
    regards, Anita

    #64102
    scrambler
    Moderator

    It appears the more tag only adds the “Continue reading” when the post is displayed as Full post.

    When the post is displayed as excerpt the more tag will interrupt the excerpt but not add the continue reading.

    @weaver, is that the intended behavior or a bug?

    #64104
    Weaver
    Keymaster

    I don’t know what I’m missing. I see >> lees verder (continue reading, I assume) on excerpts, and nothing out of place on the full post.

     

    #64105
    scrambler
    Moderator

    @weaver, you are looking at the wrong post. the one with the more tag is the first one. the excerpt cuts at “belangrijk gegeven” And there is no continue reading afterward.

    I have actually tested that on a page with posts showing excerpt. If I cut a post excerpt using the more tag, there is no continue reading, but on a page with post showing full posts there is.

    Below are the two pages on my test site, and the post with the more tag is the one called random post -2 at the top, with the excerpt ending with “sollicitudin non velit.

    No continue reading on excerpt

    https://www.nicolatrwst.com/testnicola/post-page-with-excerpts/

    Continue reading on full  post

    https://www.nicolatrwst.com/testnicola/post-page-with-full-posts/

    #64123
    kiezels
    Participant

    That’s correct @scrambler. When I check the option “Display as full post where normally excerpted” in the Weaver Xtreme options for this post, the continue reading link is displayed. But this is not the normal behaviour. When I activate a default WordPress theme like Twenty Twenty the more tag does work…

    #64126
    Weaver
    Keymaster

    @scrambler

    I seem to have found a very long standing bug. The page with posts full/excerpt override isn’t working. The title only / FI variants are working, just not the excerpt/full.

    I think that may have been there a long time, and I’m having a lot of difficulty fixing it.

    #64127
    scrambler
    Moderator

    I am glad we found something to keep your mind occupied during confinement 🙂

    I hope you are safe and doing well

     

    #64128
    Weaver
    Keymaster

    OK, now I have a handle on the problem. I was really mixed up – didn’t read the problem carefully enough. The problem is with the manually inserted “more” tag. I missed that and was focusing on auto-excerpts.

    But – it does seem to be some issue with how Weaver handles excerpts. If the post is set to show excerpts but the more tag makes it shorter than the excerpt, the continue reading message doesn’t get generated. I don’t know why yet, but now I’m on the correct issue and I can at least reproduce it. It took actually playing with your test site to figure out what the real problem was.

    #64129
    kiezels
    Participant

    Maybe for your digging it helps to know that in Weaver II Pro 2.1.2 (yes, I’m sorry I still have a site with that theme…) the manually inserted more tag does work. However, only when the more tag is inserted BEFORE the default of 40 words for the excerpt. If inserted after 40 words, the continue reading link is inserted at 40 words – maybe this is correct behaviour?

    See example here:

    Test

    Post Test 1: default behaviour, no manually inserted more tag
    Post Test 2: more tag inserted after the word ‘humor’ – so works correctly
    Post Test 3: more tag inserted after the  bold ‘Je wordt er vrolijk van!’ (only visible in full post), but continue reading link is inserted after 40 words…

    #64137
    Weaver
    Keymaster

    I will be releasing a new version of Weaver Xtreme (soon) that fixes this issue.

    I really believe it is a bug in WordPress when it generates the excerpt from a full post. If the <!– more –> tag comes after a short piece of text at the beginning, the result is a failure to properly process the excerpt so that it ends up with a read more link. If the initial text is long enough, then it works. I don’t know exactly why, but I did finally figure out that several other themes seem to have special code to handle the <!– more –> case explicitly. And Weaver Xtreme also had special code before some recent changes to the Block Editor that was removed for Block Editor compatibility. The previous special code was breaking the Block Editor excerpts – and I missed the <!– more –> purpose – which only shows up very rarely.

    So, there is a new, MUCH more elegant fix for the <!– more –> case, even more elegant that some of the solutions I saw in other themes.

    It should be noted that supporting full post vs excerpts is entirely optional. Most of the twenty-something themes default to full posts. Given all the options that Weaver Xtreme has for choosing full vs excerpt – globally, blog page, page-with-posts, and even per post – properly handling all those options is not really simple. But I think it is all now fixed.

    #64138
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #64159
    kiezels
    Participant

    Thanks for sorting this out!
    And you’re welcome for me giving you something to keep you from climbing the walls in these confinement days 😉

    Any idea when the updated theme will come available?

    #64168
    Weaver
    Keymaster

    I just uploaded it, so should propagate shortly.

    #64177
    kiezels
    Participant

    Hi @Weaver, thanks for your quick work. I updated the theme and it works. But…

    …the order of html tags in the code is slightly different from the order in the automated excerpts:
    in the automated excerpts the Read-more-link is positioned just before the closing
    , whereas in the updated theme the Read-more-link (after a manually inserted more tag) is displayed after the closing
    , creating a white line before the read more link.

    See for example: https://www.goederedeconcerten.nl/exposities/ where the first post is with a manual more tag inserted.

    Hope I am not too much of a nuisance…?

Viewing 16 posts - 1 through 16 (of 19 total)
  • You must be logged in to reply to this topic.