Home Forums Weaver Xtreme Theme Problems with PHP 8.1 – Critical Error

Topic Resolution: Resolved
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #71237
    Realbilly
    Participant

    Hello,
    I am using Weavertheme with a child-theme for years without problems. Now we have to upgrade from PHP 7.4 to 8.1 and I changed it on the server for testing, getting a critical error.
    Changing back to 7.4, the error is gone. And I also don´t get the error using the parent-weaver instead my child-theme.
    Now I have no idea how to solve the problem.  🙁
    How can I enclose it?
    Thanks a lot and have sunny autumn sunday!
    Realbilly

    #71248
    Weaver
    Keymaster

    Usually when you get a critical error, there is additional error text included. Can’t provide any help without that info. But since it only happens with your child theme, it is likely you have a PHP 8 incompatibility in your code.

    #71257
    Realbilly
    Participant

    Thank you for the answer.

    I already detected the problem via trial and error: I think the “create”-term isn`t compatible with PHP 8. And so you are right, it was my code.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.