Home Forums Weaver and Plugin Interaction problem with smartslider with actual weaver exteme version 4.0.5

Topic Resolution: Answered

This topic contains 7 replies, has 3 voices, and was last updated by  morticusghost 2 months, 1 week ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #55901
    Answered

    morticusghost
    Participant

    Hallo,

    the slider isn`t shown on the front-page and smart slider gives out following error message in the help log:

    <h3>get_footer() or wp_footer() call is missing from the template!</h3>
    Related page: /?customize_changeset_uuid=db4674a0-4790-4d0c-a34f-e54251d38e1f&customize_theme=weaver-xtreme&customize_messenger_channel=preview-24&customize_autosaved=on

    Make sure that get_footer() exists in the current template of the page or post at the end of the file
    Make sure that wp_footer() exists before the closing </body> tag in the [theme folder]/footer.php
    http://codex.wordpress.org/Function_Reference/wp_footer

    How can this problem be fixed? It occures since the actualisation.

    Thanks.

    #55902

    scrambler
    Moderator

    can you give us a link to the site page that has the slider inserted into it, and where it has been inserted

    #55904

    Weaver
    Keymaster

    There is absolutely no problem with Weaver Xtreme’s use of wp_footer();. If there is a problem, it must be in the plugin. I have seen in the past plugins trying to be too smart for themselves, and that try to “help” the user by trying to search the theme for specific functions like wp_footer() in specific places like “footer.php”. And the fact is, that call is actually there in Weaver Xtreme’s footer.php, but whatever the plugin is doing, it seems to fail to detect that.

    So I would contact the plugin’s support, and ask them how to fix the so-called problem.

    #55931

    morticusghost
    Participant

    Thank you for your answer. I will try to contact the plugin developer.

    #55933

    morticusghost
    Participant

    @scramper: it’s placed at the main site of https://www.morticus.info

    and it was insertet as shortcode in the Images-tool of weaver xtreme “Replace Header Image with HTML”.

    I tried to avoid the problem by using in weaver xtreme a galery (dia-show) as widget in “Active Widges”>”Header Widget Area”. But it doesn’t work either.

    An error-message occurs: “Diese Diashow benötigt JavaScript” (this dia-show needs java script).

    I hope this problem can be fixed in short time.

    #55934

    scrambler
    Moderator

    The slider HTML is there in the page, just not displaying.

    While I try to see if I can find a reason, have you tried inserting the slider with the same shortcode in the content area of a test page, and is it showing up there?

    EDIT, I suspect something is going on with the slider script, as it is in a state where the container is set to have an opacity of zero, which hides the images

     

    #55936

    morticusghost
    Participant

    hello,

    i tried with the content area of the same page and there is placed a container with a opacity of zero as well.

    “PHP Compatibility Checker” finds 0 errors but 42 warnings within the plugin smartslider2:

    7 | WARNING | Use of deprecated PHP4 style class constructor is not supported since PHP 7.

    But if it’s a plugin problem, why doesn’t function other dia-shows either?

    Thanks.

    #55937
    Best Answer

    morticusghost
    Participant

    This reply has been accepted as the best answer.

    problem is solved. I deleted smartslider 2 and installed the new smartslider 3.

    Thank you for your time.

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.