Home Forums Archived Forums Weaver II Theme Problem with rotate pictures

Viewing 16 posts - 1 through 16 (of 69 total)
  • Author
  • #17630

    In this post  the second picture is rotated, when you view the post from a mobilephone (Iphone).

    Is this a WordPress problem and what can I do about it?
    Thank you πŸ™‚ 

    First saying the second picture is not a lot of help as there are many πŸ™‚

    But if on some browsers an image ends up rotated and not in other, it is probably an issue with the image. Some images have a rotation specified in their exif section, and that may not be recognized by all browsers.

    You soulld edit the image with an image editor and physically make it the proper orientation. then you would have to delete the one in the media library and upload the new correct one


    The site is not configured to respond to mobile sites, so if you want the site to look good on phones, that should be the first thing you do. (I guess you must have the disable mobile option checked?)

    That business with the rotated image is something I’ve never seen before. It would have nothing to do with the theme or WordPress. It does not do that on Android devices – just iOS. @scrambler is likely right – it has something to do with the image EXIF metadata.


    There are two pictures in that post (two big pictures) and I mean the second one. 
    Not the small ones on the side or at the bottom πŸ™‚ 

    I have uploaded the picture in the propper orientation, but it rotates when you look at the post from a mobilephone.
    Not from a computer og specific browser. 

    Yes I have checked the – Disable Mobile Support

    My page doesn’t work with that setting. 

    I would like it to be mobile friendly, but haven’t found a solution πŸ™‚

    If you need help with making you page be properly responsive when you activate mobile, we would need to see it with it activated and details about the issues


    If I remove the Disable Mobile Support in Weaver admin mobile the page opens up too big for the screen. 

    So you need to zoom out.

    Also the sidebar and all of the pictures moves under all of the recepies. 

    So none of that looks good πŸ™‚
    It looks like this from a Iphone.

    It looks like you either have selected the option Fixed Width in Main Options > Layout, or added a rule

    div#wrapper {width: 1010px;}

    which makes the width fixed and makes the site non responsive.

    Remove the fixed width option and leave mobile on, then the site will be responsive.

    Of course you may still have some non responsive content in there, but we can deal with that when these two options are set properly.

    Thank your for your answer. 

    I donΒ΄t have the checkbox Theme Width Fixedmarked. 

    But I have changed the theme width to 1010px.
    Do I need to change it back to 940px.?
    It would be very difficult because all of my other settings are changed to be compatible with the setting 1010px.
    I hope it make sense πŸ™‚

    You are not understanding the concept of responsive.

    When you set the site with to 1010px in the admin, it gives the site wrapper a max-width:1010px so that if the browser is big enough it is 1010px wide, but if the browser becomes smaller, the site becomes smaller with it, and all the content inside scales down an reorganizes itself.

    By adding your rule div#wrapper {width: 1010px;}  You force the site to always be 1010px, so when the browser is smaller that that, your content now ends up outside of the browser and is cutoff, forcing people to scroll to see all of it which is very bad on mobile.

    You need to remove the div#wrapper {width: 1010px;}   rule and let the site scale down.

    If when the site scale down some of your content does not behave, we can help you fix it, but we need the site to scale and you need to explain which pieces are not behaving

    Thank you for explaining. 

    I removed the rule.

    If I choose:
    Responsive, hide sidebars 
    Simulate mobile device – Smart phone

    It look like this:   

    I am sure there are many things that need to be fixed but what can i do about
    1. The pictures are to large. 
    2. What about the sidebars are they not relevante viewing from a mobilephone? 
    1. If your pictures are too big, it is likely you have the width set to “width” rather than to “max-width”. If you can’t figure this out, you need to leave the site with “Disable Mobile Support” unchecked, so we can help you further.

    2. If you choose “Responsive, hide sidebars” you are choosing to hide the sidebars on narrow mobile screens.  If you want the sidebars to display on mobile, you need to choose “Responsive, stacked sidebars” – this setting will move the sidebars to below the content when the screen width is too narrow to fit the sidebars beside the content.


    And do not use the Mobile device Simulator, it is irrelevant for Responsive mode.

    When using responsive mode, to test mobile devices, simply reduce the size of your browser and observe how things change.

    As Gillian said, we cannot help you tune the site if you don’t leave it in responsive mode and mobile


    Thank you for your help.

    I can’t leave it in responsive mode, because then my visitors can’t use the page.
    I think this is to dificuelt to solve – there are so many settings that need to be changed. 

    Featured Image Width 600 px

    Theme Width: 1010 px
Viewing 16 posts - 1 through 16 (of 69 total)
  • The forum ‘ Weaver II Theme’ is closed to new topics and replies.