Home Forums Weaver Xtreme Theme problem with menu color

Viewing 12 posts - 65 through 76 (of 76 total)
  • Author
    Posts
  • #73026
    scrambler
    Moderator

    The menu item Theme CSS rule appears to be there for me.

    #73027
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #73028
    Private Reply
    beethoven
    Participant
    This reply has been marked as private.
    #73029
    beethoven
    Participant

    I could access to the database and everything is ok

    #73034
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #73036
    beethoven
    Participant

    I tried again changing the extreme versions, no effect.
    I tried again reinstalling wordpress 6.2.2., no effect.
    I tried again deactivating all non weaver plugins, no effect.
    I tried deactivating all plugins (even weaver plugins), no effect.
    I tried deactivating only the weaver support plugin, no effect.
    I tried changing the PHP version, no effect.
    I verified, optimized, fixed the database, no effect.

    I verified once again, that the only issue is the text color. There is no issue with the hover color or the background color

    One thing may have sense for you : the issue is exactly the same in the secundary menu but not in the header mini menu. Changing the text color of the header mini menu works normally.

    If you think that necessary, yes I can give you access to my hosting account. Tell me when you are back

    It is clearly a hard work for you and I sympathize. I’m becoming crazy myself doing and redoing the same things. But this issue must be resolved, the site cannot stay a long time with and old version of the theme, even if it works temporary

     

    #73071
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #73073
    beethoven
    Participant

    I see that the phpMyAdmin plugin is installed but not activated now. There is something strange for me. when I look at the theme, its is still 6.2.0.1 but on the update side I see : weaver xtreme 6.2.1.4 and  “update to 6.2.1.5”.  I suppose, that comes from your testing.

    #73074
    User
    Participant

    @beethoven

    FYI, there was a Theme auto-update today to Version: 6.2.1.5

    Regards!

    #73077
    beethoven
    Participant

    @User, yes that it was

    #73084
    Weaver
    Keymaster

    @beethoven

    I’ve updated your site with Weaver Xtreme 6.2.1.5.1 which is different than the just release version.

    I did figure out what was going on with your problem, but not why. My only thought is there is some bug in the version of mySQL you are using, and/or the PHP version you are using. But the fact it does not appear on most sites, and how carefully I’ve gone over the relevant code in the theme and theme support plugin, I don’t think I’ll ever know what was going on. Somehow, incorrect data was being stored in the database with ‘>’ changed to ‘>’. I don’t know why.

    BUT, after thinking about it a bit, I figured out a new option to add that stops the problem. There is a new option under the customizer Admin Options -> Admin that will by-pass the caching the theme does with the on-the-fly CSS generated based on options. It was cached to very very slightly speed up site loading for visitors. The database problem was saving the cached CSS.

    So, now your site seems to work just as expected with that cache disabled.

    I’m frustrated I couldn’t find the real problem, but the fix should be all you need.

    This certainly has been the most challenging issue I’ve ever encountered with the theme, and I’m happy to at least find a workaround that works for a tiny performance loss (and it only a server side loss – it does not change how much data is generated to show your site.)

    Let me know if you find other issues. I will release 6.2.1.6 before too long, but you should get an update admin notice when that happens.

    The new version is available at:

    Current Versions

    #73088
    beethoven
    Participant

    Congratulations ! Your workaround works. With the new option selected there is no more issue, with the option not selected the issue is back. In a few days, I’ll see if there is a visible less of perfomance. If so, I tell you. I hope not. I don’t think it’s a bug in the PHP version, I changed the version with no effect. So perhaps it is the mySQL version. If your new option fix the user with the background color issue, it could be interesting to know what versions he uses on what host ? Nevermind many thanks and again congratulations

Viewing 12 posts - 65 through 76 (of 76 total)
  • You must be logged in to reply to this topic.