Home Forums Weaver Xtreme Theme problem with menu color

Viewing 16 posts - 1 through 16 (of 76 total)
  • Author
  • #72903

    On the site https://fncta-midipy.fr the primary menu text color is set to ##FFEFEF and works fine years but  on the frontend it is now a kind of dark blue, very awful on the black background. On backend it is OK. Resaving the setting doesn’t work. Changing the color works on backend but not on frontend (changing the background color works). Deactivating all plugins but weaver plugins : no change. I can’t find any reason ! Could it be related to the theme last updates ? Can you help ?


    #FFEFEF and not ## of course and “works fine for years”


    There is something strange going on, because the menu Color CSS rule is missing

    .menu-primary .wvrx-menu >li >a {
    color: #FFEFEF

    Are you by any chance using an optimization plugin that optimizes CSS and JS (or a plugin with an optimization option). If so please deactivate that as they can break the theme css and js which are already optimized.

    If not try deactivating ALL non weaver plugins and see if that fixes the issue. If it does, reactivate one by one.

    @weaver, there is something strange on his site.
    When I open the developer tools, like on my site, some rules show as coming from a file like
    And clicking on the link in the developer tools goes to the CSS in question

    And others from index which is https://fncta-midipy.fr/
    But when I click on the index CSS link in the developer tools, it is empty!
    On my test site, It does go to the CSS.

    What could cause that? and could it be why he has missing CSS rules?





    Merci @scrambler pour cette réponse rapide. No I have no optimization plugin and as said I allready deactivated all non weave plugins without result. I don’t know if other CSS rules are not working. The rule for the menu bgcolor works but the rule for the menu textcolor do not. How is that possible ? If I go to the site from the backend, everything is ok but as user from the frontend no. How is that possible ?

    I remember now, the same thing happened few weeks ago after à theme update, which one, I do not remember so I had to revert the site before this update. After the next theme update, the issue disappeared. Coincidence ? Now, reverting the site before the last update doesn’t fix the issue. In fact I don’t know exactly since when there is this issue. Most of the time I am logged in and when logged in ther is no issue


    Can you paste the content of the system Info box from the help page here, so we can check all your versions.
    You should have

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version:
    Theme Support Version: 6.2.9
    Xtreme Plus Version: 6.2

    Also, clear all your caches (plugin,  cloudflare…) to make sure nothing is at play here.

    Hopefully @weaver can comment on my question above, as why there is no CSS under Index in the developer tools for your site.


    Cache is cleared, even deactivated. Weaver xtreme Theme support 6.2.9 Xtreme plus 6.2

    Where is the system info box ? Stupid question but I really dont find it


    Here it is
    <h3>Weaver System Info ###</h3>
    — WordPress Configuration —

    Site URL: https://fncta-midipy.fr
    Home URL: https://fncta-midipy.fr
    Multisite: No
    Version: 6.2.2
    Language: fr_FR
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%postname%/
    Show On Front: page
    Page On Front: Accueil (ID# 40193)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, wp_template, wp_template_part, wp_global_styles, wp_navigation, tablepress_table, wpcf7_contact_form, mailpoet_page, slide, atw_slider_post

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version:
    Theme Support Version: 6.2.9
    Xtreme Plus Version: 6.2

    — Server Configuration —

    Operating System: Linux
    PHP Version: 8.0.26
    MySQL Version: 10.5.12
    jQuery Version: 3.6.4
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 256M
    Server Memory Limit: 256M
    Post Max Size: 64M
    Upload Max Filesize: 64M
    Time Limit: 60
    Max Input Vars: 10000
    Display Errors: On (1)

    — WordPress Active Plugins —

    AddToAny Share Buttons: 1.8.6
    Akismet Anti-Spam: 5.1
    Classic Editor: 1.6.3
    Classic Widgets: 0.3
    Contact Form 7: 5.7.6
    Drag and Drop Multiple File Upload – Contact Form 7:
    Login Logo: 0.10.2
    MailPoet: 4.17.0
    Meteor Slides: 1.5.7
    Optimize Database after Deleting Revisions: 5.0.110
    Search Exclude: 2.0.1
    Simple Lightbox: 2.9.3
    Spiffy Calendar: 4.9.4
    Spiffy Calendar Bonus Add-ons: 3.25
    TablePress: 2.1.3
    TablePress Extension: Responsive Tables: 1.8
    TablePress Extension: Turn off Output Caching: 1.0
    Unique Headers: 1.8.2
    Weaver Show Posts: 1.8
    Weaver Show Sliders: 1.7
    Weaver Xtreme Plus: 6.2
    Weaver Xtreme Theme Support: 6.2.9
    WP-DownloadManager: 1.68.8
    WP Edit: 4.0.4
    WP Mail SMTP Pro: 3.8.0
    Yoast Duplicate Post: 4.5
    Yoast SEO: 20.8

    — WordPress Inactive Plugins —

    Broken Link Checker: 2.1.0
    Contact Form 7 Database Lite: 3.0.6
    Enable jQuery Migrate Helper: 1.3.0
    Health Check & Troubleshooting: 1.6.0
    Popup Maker: 1.18.1
    Shortcodes Ultimate: 5.13.0
    Site Kit by Google: 1.101.0
    WP Maintenance: 6.1.3
    WP Super Cache: 1.9.4

    ### End System Info ###


    We are going to need help from @weaver on this

    Private Reply
    This reply has been marked as private.
    Private Reply
    This reply has been marked as private.

    @weaver, any Idea why there is NO CSS when clicking on the Index link in the browser developer Tools Next to CSS Rules?


    Thanks both of you

    1. No it doesn’t happen in the Customizer preview
    2. Yes I tried changing settings both in cutomizer an legacy : no result
    3. I edited the settings.php and changed the Minify line : no result
    4. I emailed you the wxt file
    5.  Not such à rule in the CSS : here it is  (and did not change long ago)

    #header-search .search-field,.header-search .search-field,.menu-search .search-field {
    background-color:#f0f0f0;border:2px solid #c3c0ab;cursor:text;outline:0;width:230px;

    .entry-title {text-align:center;}
    .widget-title {text-align:center;}
    .more-link {text-align:center;}

    .wp-video {text-align: center;margin-left: auto;margin-right: auto;}

    .table.center {margin-left:auto;margin-right:auto;}

    .menu-toggle-button.genericon, .wvrx-menu-button .genericon {vertical-align:middle;}
    .wvrx-menu-button {margin-top:0.10em;}
    .is-menu-mobile .wvrx-menu-container {padding-bottom:0.07em;}

    .atw-show-posts-schema .post-title {font-variant:small-caps;}
    .atw-show-posts-schema .post-area {color:#5E0A0A;line-height:normal;border-bottom: 1px solid #CCC;}
    .atw-show-posts-schema .excerpt-dots {display:none;}
    .atw-show-posts-schema a.more-link {tex-align:left;display:inline;}
    .atw-show-posts-schema .entry-summary p {margin-top:0;margin-bottom:0;display:inline;}
    .atw-show-posts-schema .post-area {margin-bottom:0.3em;}
    .atw-show-posts-schema .post-area {margin-bottom:0.3em;padding-bottom:5px;}


    Well, the issue is gone . But it was theme related. I reverted the whole site to  mai 1 : no issue. I updated all plugins : no issue. I updated the weaver xtreme versionand the issue vas there. I reverted to mai 14, updated plugins and weaver xtreme and no more issue. Very strange. I hope you will find out what happened, two times now and xtreme updates were involved each time. Anyway, thank you very much for your help
    <h2>One minute later : No, the issue is not gone, it is back I’ll try again to revert</h2>


    I tried everything I could but in vain. It is as backend and frontend are not connected ! @weaver, I can give you an admin login if you think that can help. @scrambler could a CSS rule  change the primary menu textcolor until @weaver has the solution ? The menu is now really awful !


    I changed the menu bg color so at least the menu is readable, but, or course, that is not a solution…

    Private Reply
    This reply has been marked as private.
Viewing 16 posts - 1 through 16 (of 76 total)
  • You must be logged in to reply to this topic.