Home Forums Weaver Xtreme Theme Post top menu links. Align to the right.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #64308
    GeorgeW
    Participant

    Hello – hope you’re well!

    I’m trying to align the links at the top of my posts to the right.

    I have tried a few different options, but for some reason they get UNchecked after I save the settings.

    What would be the most reliable way to do this?

    Thanks!

    George

    #64309
    Private Reply
    GeorgeW
    Participant
    This reply has been marked as private.
    #64311
    scrambler
    Moderator

    I don’t see any posts in the link you gave us, please provide a link to the actual page with the posts , and specifics about what link you are speaking of

    for some reason they get UNchecked after I save the settings.

    What exactly have you tried, what options are getting unchecked?

    We can help, but we don’t read minds 🙂

     

    #64313
    Private Reply
    GeorgeW
    Participant
    This reply has been marked as private.
    #64314
    scrambler
    Moderator

    Doing well thanks

    OK, so nothing to do with posts, just the menu, thank you for clarifying.

    Your menu is indeed set to center.

    If when you change the setting in the Admin it does not stick, you may have a configuration issue.

    Review the guide article below to see if any of the things listed is the cause.

    https://guide.weavertheme.com/settings-wont-save-from-customizer/

    Also, have you checked if the issue of settings not sticking happens to other options, or only this one?

     

    #64316
    GeorgeW
    Participant

    Hi, scrambler!

    I’m not using the Customizer. I’m using the Legacy options exclusively.

    I have cleared cache from site and browser.

    I have also deactivated the caching plugin.

    max_input_vars is already set to 10000 (ten thousand).

    I suspect there may be some overlapping between functions like:

    Main Options ==> Header ==> Header Widget Area

    Main Options ==> Menus ==> Primary Menu Bar

    Main Options ==> Full Width ==> Stretch Areas (Expand) ==> Primary Menu Stretch (check)

    The last two of the options above will not save. Other options save fine.

    Hope we’ll be able to figure this one out. 🙂

    Thanks!

    George

    #64317
    scrambler
    Moderator

    The article also applies to legacy options not saving.

    Do make sure all theme and plugins are up to date., and do check using the same option from the customizer.

    But if options are not saving, you have an installation problem.

    Paste the content of the System Info box from the theme help page here, may be @weaver will have more suggestions

    Make sure you test deactivating ALL non weaver plugins to rule out any bad interactions

    #64319
    Private Reply
    GeorgeW
    Participant
    This reply has been marked as private.
    #64321
    scrambler
    Moderator

    Did you really deactivate ALL plugins except Xtreme theme support, because you have quite a bit here>

    If so next you can try a full reload of weaver stuff

    • Save your settings in the save & restore page
    • Download a copy of all your setting for good measure on your computer
    • switch to a different theme
    • Deactivate AND delete the weaver theme and the weaver plugins
    • Then reinstall Weaver Xtreme theme from WordPress and activate
    • reinstall Weaver Xtreme Theme support plugin from WordPress and Activate
    • Everything should be back to normal
    • Try changing options and saving them and see if they stick

     

    #64329
    Private Reply
    GeorgeW
    Participant
    This reply has been marked as private.
    #64331
    scrambler
    Moderator

    Glad you figured it out, this appears to be a BUG  as I can reproduce it


    @weaver
    , there is a weird Bug with the One step layout and the menu alignment
    When using Stretched, it forces the menu alignment option to center. If you try to use left or right, when you save the setting it reverts to center


    @GeorgeW

    To underline menu items, add the rule below to the theme Global Custom CSS rule box

    .menu-primary .wvrx-menu > li > a {text-decoration:underline;}

    #64333
    GeorgeW
    Participant

    Awesome, scrambler – thanks for your help!

    George

Viewing 12 posts - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.