Home Forums Weaver Xtreme Theme php_max_input and weaver-extreme

This topic contains 5 replies, has 3 voices, and was last updated by  scrambler 2 months, 1 week ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #55856

    edwardsmarkf
    Participant

    hello –  i am going through and FINALLY migrating all my weaver-I, weaver-II themes to the new weaver-extreme.  the first few went OK, but now i keep  getting this message:
    <h3>WARNING – Your current settings have NOT been saved!
    Your previous settings are unchanged.</h3>
    Your host seems to be configured to limit how many input form options you are allowed to use with PHP. This is usually controlled by the PHP max_input_vars configuration setting. The current value of 999999999 is too small for your current WordPress and Weaver Xtreme installation. It should be increased to 1000000999 Until you increase the value, you cannot save your Weaver Xtreme settings using the Legacy Interface. The Customizer will still work, as will the options on the Save/Restore tab. Your site is still functional.

    note that i have this set in my php.ini file:  (went from 1k, to 2k, to 10k, and finally to a trillion)
    max_input_vars = 999999999

    any suggestions?

    #55857

    scrambler
    Moderator

    Not being able to save can come from a combination of installation issues.

    Read the article below to review them all, and paste the content of the help page system info box here

    https://guide.weavertheme.com/settings-wont-save-from-customizer/

     

    #55858

    Weaver
    Keymaster

    Do note that simply setting the max_input_vars value in your php.ini file very seldom has any effect at all. The value is typically really controlled by the hosting company in a higher level setting. You will likely have to contact you hosting tech support to get the value raised.

    It is possible there is another issue.

    #55911

    edwardsmarkf
    Participant

    hi bruce –

    I have a phpinfo() script that confirms both the Local Value and the Master Value of max_input_vars is set at 2000.  It appears that no matter how high Iset this value, xTreme theme keeps asking for more.

    If this helps, I am first getting a popup window with the following message:

    *** Your Weaver Xtreme Theme settings are not up to date, probably
    because you are updating from Weaver Xtreme Version 3 to Version 4.
    These settings will now automatically be updated.

    please advise.

    #55912

    edwardsmarkf
    Participant

    for whatever this is worth – when i switched back to the old weaver-ii-pro and then switched again to the xTreme, the problem went away.

    in other words:

    day one:   switched from weaver-ii-pro to xTreme

    day two:   kept seeing the max_max_input error

    day three:  switched BACK from the xTreme to weaver-ii-pro

    day four:   switched again from weaver-ii-pro to xTreme.

    #55916

    scrambler
    Moderator

    What version of the theme and the theme support plugin are you using?

    Make sure that they are both the latest 4.x versions. a 3.x version of the theme with a 4.x version of the theme support plugin would cause problems.

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.