This seems to be a new problem, almost certainly caused by using a newer version of PHP (e.g., 8.x), or turning on PHP errors (maybe the cache plugin).
I believe that Weaver Xtreme Version 6.4.1 will fix the issue, but since I have no way to duplicate your problem, I’m just going by the very useful information your provided.
It has not been updated to the WP repository yet, but it is available for direct download:
Weaver Xtreme Current Versions
I’d appreciate it if you can confirm this fixes the problem.