Home Forums Weaver Xtreme Theme PHP 8.4

Topic Resolution: Answered
Viewing 16 posts - 1 through 16 (of 30 total)
  • Author
    Posts
  • #75802
    Answered
    TheSpiralMom
    Participant

    I just tried updating my PHP to 8.4, but the theme doesn’t seem to support PHP over 7.4. Help

    #75804
    Weaver
    Keymaster

    Weaver Xtreme Version 6.7 (also lower quite a few versions back) is completely compatible with any PHP Version 7 or 8. While this forum site is on 8.2 because of hosting support, my test platform is PHP 8.4 with no issues. Perhaps there is some plugin that has an issue. PHP has remained quite backward compatible for quite a few versions.

    WP is also fairly backwards compatible:

    “WordPress also works with PHP 7.2.24+” although WP warns that if you’re running something that old, there may be vulnerabilities.

     

    #75816
    User
    Moderator

    @thespiralmom

    For what its worth, I’ve just had 2 plugins updated in the last 2 days, saying they are now PHP 8.4 compliant.

    As Weaver suggested, you may want to check that all your plugins are PHP 8.4 capable.

    Regards.

    #75841
    TheSpiralMom
    Participant

    According to tech support from my server, it’s a theme issue

    <b>Fatal error</b>: Uncaught ValueError: Unknown format specifier “C” in /home/cognclc/www/www/wp-includes/nav-menu-template.php:290 Stack trace: #0 /home/cognclc/www/www/wp-includes/nav-menu-template.php(290): sprintf(‘apply_filters(”, Array) #8 /home/cognclc/www/www/wp-includes/plugin.php(517): WP_Hook->do_action(Array) #9 /home/cognclc/www/www/wp-content/themes/weaver-xtreme/header.php(116): do_action(‘weaverx_nav’, ‘top’) #10 /home/cognclc/www/www/wp-includes/template.php(810): require_once(‘/home/cognclc/w…’) #11 /home/cognclc/www/www/wp-includes/template.php(745): load_template(‘/home/cognclc/w…’, true, Array) #12 /home/cognclc/www/www/wp-includes/general-template.php(48): locate_template(Array, true, true, Array) #13 /home/cognclc/www/www/wp-content/themes/weaver-xtreme/includes/lib-layout.php(436): get_header(‘page’) #14 /home/cognclc/www/www/wp-content/themes/weaver-xtreme/page.php(11): weaverx_page_lead(‘page’) #15 /home/cognclc/www/www/wp-includes/template-loader.php(106): include(‘/home/cognclc/w…’) #16 /home/cognclc/www/www/wp-blog-header.php(19): require_once(‘/home/cognclc/w…’) #17 /home/cognclc/www/www/index.php(17): require(‘/home/cognclc/w…’) #18 {main} thrown in <b>/home/cognclc/www/www/wp-includes/nav-menu-template.php</b> on line <b>290</b>

    #75842
    User
    Moderator

    @Weaver would need to comment further on this.

    @thespiralmom my own naive thoughts on this is the “www” x2  in all your settings:  cognclc/www/www/wp-includes.....

    That looks rather non-standard to me, and in my experience, non-standard code tends to have the habit of throwing out unexpected errors here or there.

    Regards.

    #75865
    Weaver
    Keymaster

    I agree. /www/www is not anything one would expect, and would of course cause errors. If there really were a PHP 8 error, we would be hearing a lot about it, and that is not the case.

     

    #75871
    TheSpiralMom
    Participant

    I’m confused, as I didn’t do any coding. Please note, I’m a novice.

    Are you saying that it’s a problem with the directories?

    #75872
    User
    Moderator

    @TheSpiralMom

    At the moment, fron what we see and understand, there are no reported issues with Weaver Xtrene and PHP8.4

    On the other hand, you are experiencing problems.

    Based on the information you supplied, the ‘/www/www/’ is of concern as it is abnormal.

    It appears that your WordPress or Site installation has been placed inside a directory called ‘WWW’…

    That’s not a normal install and so we suspect it is the reason for the apparent PHP8.4 conflict.

    Please see if you can resolve this abnormal install, so that the ‘/www/www/’ paths no longer exist.

    Regards.

    #75879
    Best Answer
    TheSpiralMom
    Participant

    This reply has been accepted as the best answer.

    I created a staging area and tested each plugin. Turns out it was the JetPack plugin, not the theme. Yay!

    Thannk you everyone for your help

    #75884
    Weaver
    Keymaster

    Very odd that JetPack could have any issues with PHP version as it is a significant WP product.

    #75890
    roadside
    Participant

    I’m running into the same issue.  If I deactivate JetPack (with Weaver Xtreme 6.7 activated)  I can upgrade to PHP 8.4 and it works.

    If I deactivate Weaver Xtreme and keep JetPack on, PHP 8.4 works as well.  But if both JetPack and Weaver Xtreme are activated I get an error.

    And I’m not running into this problem on another site I run with a different theme.  8.4 works fine there.

    The debug log shows theme errors.  I don’t have that doubled http://www.www thing like above.

    [26-Aug-2025 20:51:22 UTC] PHP Fatal error: Uncaught ValueError: Unknown format specifier “C” in /home/roadsid5/public_html/wp-includes/nav-menu-template.php:290
    Stack trace:
    #0 /home/roadsid5/public_html/wp-includes/nav-menu-template.php(290): sprintf()
    #1 /home/roadsid5/public_html/wp-content/themes/weaver-xtreme/templates/menu-primary.php(162): wp_nav_menu()
    #2 /home/roadsid5/public_html/wp-includes/template.php(812): require(‘/home/roadsid5/…’)
    #3 /home/roadsid5/public_html/wp-includes/template.php(745): load_template()
    #4 /home/roadsid5/public_html/wp-includes/general-template.php(206): locate_template()
    #5 /home/roadsid5/public_html/wp-content/themes/weaver-xtreme/includes/filters.php(72): get_template_part()
    #6 /home/roadsid5/public_html/wp-includes/class-wp-hook.php(324): weaverx_nav_action()
    #7 /home/roadsid5/public_html/wp-includes/class-wp-hook.php(348): WP_Hook->apply_filters()
    #8 /home/roadsid5/public_html/wp-includes/plugin.php(517): WP_Hook->do_action()
    #9 /home/roadsid5/public_html/wp-content/themes/weaver-xtreme/header.php(147): do_action()
    #10 /home/roadsid5/public_html/wp-includes/template.php(810): require_once(‘/home/roadsid5/…’)
    #11 /home/roadsid5/public_html/wp-includes/template.php(745): load_template()
    #12 /home/roadsid5/public_html/wp-includes/general-template.php(48): locate_template()
    #13 /home/roadsid5/public_html/wp-content/themes/weaver-xtreme/includes/lib-layout.php(436): get_header()
    #14 /home/roadsid5/public_html/wp-content/themes/weaver-xtreme/404.php(18): weaverx_page_lead()
    #15 /home/roadsid5/public_html/wp-includes/template-loader.php(106): include(‘/home/roadsid5/…’)
    #16 /home/roadsid5/public_html/wp-blog-header.php(19): require_once(‘/home/roadsid5/…’)
    #17 /home/roadsid5/public_html/index.php(17): require(‘/home/roadsid5/…’)
    #18 {main}
    thrown in /home/roadsid5/public_html/wp-includes/nav-menu-template.php on line 290

    #75892
    User
    Moderator

    @Roadside

    Thanks for the information.

    May I ask you to please submit a copy of “Your System and Configuration Info”  from the Weaver Xtreme 6.7 Options page?

    This may help in the testing and understanding of what’s going on.

    You may like to set your reply to  Private Reply for your own privacy.

    Regards and thanks!

     

    #75893
    Private Reply
    roadside
    Participant
    This reply has been marked as private.
    #75895
    Weaver
    Keymaster

    The trace you provided seems to show that the error is happening on a 404 page – page does not exist. Do you get the errors on any page, or just an unknown page?

    I visited your link, and don’t see issues. Do you have JetPack on or off at the moment?

    #75899
    Private Reply
    roadside
    Participant
    This reply has been marked as private.
    #75903
    Weaver
    Keymaster

    i can see to test this on your server, one would need full access to your host account to switch PHP versions, plus admin access to your site.

    This seems to be a very hard issue. I simply have not been able to create any issues using PHP 8.4 with Weaver and Jetpack. I have created a test site with that configuration, but there is no issue. I can see your site has an issue before the menu is generated.

    I could try to have a look, but obviously it would take messing with your site. But before we go there, could you generate a alt site called something like test.oldsite.com that is a clone of the original site. Don’t know if your host allows changing PHP version on a per site basis or not. If that were possible, then one could leave your real site on 7.4, and experiment with the clone using PHP 8..6. I would be willing to try to play with it, although I will be unavailable for the next week or so (except perhaps brief discussions here.)

    I’m setting my replies to private since this really isn’t of general interest.

Viewing 16 posts - 1 through 16 (of 30 total)
  • You must be logged in to reply to this topic.