Home Forums Weaver Show Posts & Show Sliders Parallax posts not working on page with posts

Viewing 16 posts - 1 through 16 (of 20 total)
  • Author
  • #64648

    I hope I am not doing something completely idiotic.

    I have created a post filter, two of the posts in the filter show without issues. The other two parallax posts don’t show on the page – I can view them as a singular post but they don’t show on the page I need them.

    I am using Weaver Xtreme.

    Link to the page is here http://dna245.dnaonline.co.za/

    The parallax posts are the last two on the page.

    I have changed sub themes, deleted posts, tried on another test server.


    Do these posts have the same titles?

    If so you should RECREATE them with different titles, as this can cause problems with WordPress permalink.

    If you want to only change the Title, make sure you change the permalinks underneath too, and make sure you go to settings > Permalink and resave them.

    But cleanest way is recreate them to avoid any conflicts

    Also give us the links to the single post pages as we cant get there from the posts as they are not linking to anything

    Finally how are the post set to display, because the first three are in three columns and the last two are on top of each other, which cant be done with a single filter.

    The best would be to have two showposts, one set to three columns for the top three, and one set for a single column for the two parallax


    Thank you for getting back to me.

    I  deleted and  recreated the posts from scratch. The post above is using a flex column widget – Even if I remove that and the 1st post it still doesn’t show the parallax posts underneath.

    Here are the links to the single post pages:




    In the parallax post editing page, did you check display as full posts, if not try that


    Eventually take a snap shot of all the options of the filter you created to display the parallax posts as well as the parallax post themselves options



    Let me know if you would like me to send you admin access. And thank you


    Can you create a page with posts with all default option, only select the category of the parallax posts, and see if they show up there properly (and give us a link)

    Also, try deactivating ALL non weaver plugins, just in case one is interfering


    And you still have all the regular posts and parallax posts in the same show post filter. Please create a New Show post filter that only shows the parallax post and put that in a page by itself


    Have done – Here is a link to only the parallax posts – with  all non weaver plugins deactivated – This is done with a new filter




    The showpost cleary is not working with your posts.

    Can you create a new test page, select the page with posts template for it and give us a link so we can see what happened on a page with posts


    OK, Progress…

    can you post a pic of the Post Display option of your show post filter


    And paste the content of the system info box from the Admin > theme help page



    ### Weaver System Info ###

    — WordPress Configuration —

    Site URL: http://dna245.dnaonline.co.za
    Home URL: http://dna245.dnaonline.co.za
    Multisite: No
    Version: 5.4.1
    Language: en_ZA
    WP_DEBUG: Disabled
    WP Memory Limit: 40M
    Permalink: /%postname%/
    Show On Front: page
    Page On Front: HOME (ID# 18)
    Page For Posts: (ID# 0)
    Current Theme: Weaver Xtreme (4.3.4)
    Post Types: post, page, attachment, revision, nav_menu_item, custom_css, customize_changeset, oembed_cache, user_request, wp_block, atw_slider_post

    — Weaver Xtreme Configuration —

    Weaver Xtreme Version: 4.3.4
    Theme Support Version: 4.0.3
    Xtreme Plus Version: 3.1.1

    — Server Configuration —

    Operating System: Linux
    PHP Version: 7.3.18-1+0~20200515.59+debian9~1.gbp12fa4f
    MySQL Version: 5.5.5
    jQuery Version: 1.12.4-wp
    Server Software: Apache

    — PHP Configuration —

    Local Memory Limit: 256M
    Server Memory Limit: 96M
    Post Max Size: 32M
    Upload Max Filesize: 32M
    Time Limit: 60
    Max Input Vars: 2500
    Display Errors: N/A

    — WordPress Active Plugins —

    Weaver Show Posts: 1.5
    Weaver Show Sliders: 1.4.10
    Weaver Xtreme Plus: 3.1.1
    Weaver Xtreme Theme Support: 4.0.5
    Widget Shortcode: 0.3.5

    — WordPress Inactive Plugins —

    Akismet Anti-Spam: 4.1.6
    Animate It!: 2.3.7
    Classic Editor: 1.5
    Contact Form 7: 5.1.9
    Contact Form 7 Skins: 2.3
    MaxButtons: 7.13.4
    Photo Gallery by Supsystic: 1.14.7
    Popup Builder: 3.67
    Smart Slider 3:

    ### End System Info ###


    This is puzzling..,

    Keeping ALL non weaver plugins disabled, create a new Show post filter, Only set one option, display posts as Full, leave everything else as default,  save settings, and insert that showposts inside a new test page. and give us the link.

    Also, paste here pics of the options found in Main Options > Post Specifics


Viewing 16 posts - 1 through 16 (of 20 total)
  • You must be logged in to reply to this topic.