Home Forums Weaver and Plugin Interaction page specific widgets

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #22927
    songerk
    Participant

    I’ve come across the same issue as Snowman, but with a slight addendum that has made it hard for me to figure out how to use the Dynamic Widgets or other plugins to resolve the problem. On my site, http://tryoncreek.org, my default widget areas are the primary and secondary sidebar. I have only one thing in each and the sidebars both fall on the right side, but I used both instead of just one sidebar widget area so that I could create rounded corners and space between them. 

    For the blog and for blog posts displayed as single pages, I’d like to have a different right sidebar widget appear–one inviting the user to subscribe to the blog. I’ve got it set up on the blog using the per page widget area (http://tryoncreek.org/tryon-creek-blog/), but as described in the thread above, it disappears when posts are displayed individually as pages. I tried using Dynamic Widgets, but as Snowman described, it doesn’t seem to work as long as I keep the per page widget area that I created through Weaver Xtreme. But…if I eliminate that per page widget area, how could I still have that third sidebar widget area with the blog signup on it? Aren’t there only two sidebar widget area options?
    (Maybe I’m going about this wrong: Is there a better way to create that space between sidebar items, and rounded corners, besides “using up” both sidebar widget areas to do so? In that case, I could use the secondary sidebar as my blog & post pages widget area and use Dynamic Widgets to set that up.)
    #17944
    scrambler
    Moderator
    #22928
    scrambler
    Moderator

    two things.

    1) You can create the rounded corners on your widgets without using the two sidebar areas. You just need to do the styling on the widgets instead of the widget are.

    If you can style all widgets you can use Main options > Sidebar & Layout > Individual widget option to give them background, rounded corners and proper margin.

    If you have widgets in other places that should not be styled, you can style only the one in the widget areas with a rule like below in Main Options > Fonts & Custom > Custom CSS Rule box

    #primary-widget-area .widget {background-color:blue;border-radius:10px;margin-bottom:10px;}

    2) If you use Dynamic widgets,I suspect you should not mix it with per page widget. You should just do ALL you selective display of widget using it, which means make the subscribe widget only appear on the pages you need it to also using dynamic widgets.

    #22929
    songerk
    Participant

    scrambler, thank you as always. A question before I move forward more: how do I add white space between widgets in the primary widget area? I’ve combined my two main widgets in that area as you suggested, but it looks like padding and top/bottom margins only move things around within the widget area, keeping the same blue background throughout. I’m going for the look I had created using the two separate widget areas before–each widget appearing in its own background, with rounded corners, separated from the other widgets by a little white space. Let me know if that’s possible! Thanks. ๐Ÿ™‚

    #22930
    scrambler
    Moderator

    You left the styling of the widget area on. You need to remove the background color on the primary widget area.

    You also need to set the padding of the primary widget area to zero as by default it is set to 8 and will waste space

    Then the bottom margin you put on individual widgets will separate the widgets, and the padding on individual widgets will create padding for the content in the widget.

    #22931
    songerk
    Participant

    Ah, thank you! Okay, sidebars are fixed. I’ve deleted my per page widget and have tried both Dynamic Widgets and Display Widgets as plugins…but neither seems to do anything. (I’ve tried clearing my cache.) Right now, I have Dynamic Widgets activated. My blog signup widget is in the Secondary Sidebar; the other two (main) widgets are in the Primary Sidebar. I have Dynamic Widgets set to only display my secondary sidebar on my blog and individual post pages, and to hide the other two sidebars on those pages…but nothing is happening. The secondary sidebar is hidden on all pages. Is it possible this is a Weaver-related problem?

    #22932
    scrambler
    Moderator

    “Is it possible this is a Weaver-related problem? “

    I don’t believe so I have tested Dynamic widgets once with it and it worked fine. I suspect a bad manipulation in the use of dynamic widgets.

    You say ” I have Dynamic Widgets set to only display my secondary sidebar” which does not make sense, dynamic widgets works on widgets not widget areas.

    Just put a text widget with some random text in one of your sidebar widget area. When you open that text widget you should have the dynamic widget options. With these options you should be able to set on what pages the widget shows and on what pages it does not. If you cant get that simple thing to work, you should review what you are doing with the dynamic widget people.

    #22933
    songerk
    Participant

    It sounds like the problem is either me or Dynamic Widgets, but not Weaver. ๐Ÿ™‚ Thanks–I have done what you suggested (I did mean to refer to widgets and not widget areas), and still it’s as if the widget isn’t there at all. I’ll keep trying… Much appreciated.

    #22934
    songerk
    Participant

    One more question: Searching around, on a forum about a different plugin (Display Widgets) I found a reference to “when the website checks for widgets,” or something similar. Is there any possibility that my settings, or weaver, is overriding the settings in Display Widgets? 

    #22935
    scrambler
    Moderator

    @songerk

    OK do I installed Dynamic widgets on my test site.

    Opened one of my text widgets that was in the primary sidebar area
    Clicked on The “Static” link next to Dynamic Widgets at the bottom of the widget
    Clicked Set all options to NO at the top of the Dynamic widget setting page that opened To hide the widget everywhere
    Clicked on the Page section to open it, It shows No as checked below “Show widget on default static pages” (not showing on any pages)
    Checked the blog page in the list below “Except on the page(s)”, so that the widget would only show on that page.
    Saved the settings

    I checked the web site, and the widget only shows on the Blog page I checked, nowhere else

    #22936
    songerk
    Participant

    Oh! I see now what I was doing–I needed to check specific pages under “Pages;” I had only been marking “Yes” or “No” under “Posts page,” etc. It was indeed me. =P Thanks so much for taking the time to do that!!

    #22937
    scrambler
    Moderator

    ๐Ÿ™‚

Viewing 12 posts - 1 through 12 (of 12 total)
  • The forum ‘ Weaver and Plugin Interaction’ is closed to new topics and replies.