Home Forums Weaver Xtreme Theme Open menu in a new tab

Topic Resolution: Resolved
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #63084
    Patti
    Participant

    @weaver

    Website: https://historyswomen.com

    All of the menus open in a new tab now except for one. It’s the one on the lower-left sidebar widget.

    Can’t figure out why it works for the others & not that one.

    Any help would be appreciated!

    Patti

    #63108
    scrambler
    Moderator

    Can you be more specific, which menu item exactly?

    #63131
    Patti
    Participant

    Additional MenuIf you look on my website, on the right-hand side, you’ll see the secondary sidebar that looks like the image on the right here.

    Those “Additional Links” are the ones that aren’t opening in a new tab. All of the other menu links will open in new tabs except for those two & I can’t figure out why and/or how to fix them.

    Can you @scrambler? Or will you please tell me how to fix them?

    Patti

    #63134
    scrambler
    Moderator

    How did you create that widget?

    Is that a Wvr X plus extra menu? if so then it should reference a WordPress custom menu, and  you can set the menu to open in a new tab using the option found when you open the menu Item in Appearance > menu.

    #63142
    Patti
    Participant

    That’s just another menu like all of the other menus on my site. Like the two that are on my left-hand sidebars. In Appearance > Menus, like you said.

    I tried what you’re talking about, at least a half-dozen times & it just won’t work. They won’t open in new tabs!

    #63145
    scrambler
    Moderator

    So if you go to appearance menu, select your menu, open the menu Item, you can see the option to open in a new tab and it is checked?

    #63147
    Patti
    Participant

    Yes it is. That’s why I initially started a new thread on this forum. I can’t seem to get those two links to open in new tabs & it’s frustrating me to no end!

    #63149
    scrambler
    Moderator

    Test creating a new menu and see if it works on the new menu items.

    If so, delete the menu and redo it

     

    #63150
    Weaver
    Keymaster

    I don’t think the Additional Information “menu” in the sidebar is actually originating from the Weaver Xtreme Plus Extra menu shortcode. If it did, it would be wrapped by the class extra-menu-xplus, which it is not.

    So you are using something else to generate that Additional Information menu, I believe.

    #63153
    Patti
    Participant

    I didn’t use anything else to create that menu. However, I created a new one this morning. Added it to my widget & now those links open in new tabs. So something must’ve been wrong with the first widget. Thanks for your help!

    #70496
    alanwbaker
    Participant

    Hi Scrambler,

    In the above post of , you said

    So if you go to appearance menu, select your menu, open the menu Item, you can see the option to open in a new tab and it is checked?

    Is this option only available in Xtreme Plus?

    Alan

    #70497
    scrambler
    Moderator

    NO

    Custom Menus are 100% WordPress, so these options are standard.

    If you do not see the option, you may need to activate it by opening the “screen options” at the top, and checking all the options, including “link target”

     

    #70498
    alanwbaker
    Participant

    Thank you Scrambler. I needed to check the “link target” box.

    Alan

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.