Home Forums Weaver Show Posts & Show Sliders Newly Created Blog Posts Not Showing Up

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #17479


    I’m using Weaver Xtreme with the Weaver Show Posts & Weaver Show Sliders plugins activated.

    I created a new Weaver Slider Post (called Healing Relationships). When I view this post I get a permalink of: http://www.agapetherapeutic.com/atw_slider_post/healing-relationships/

    Then I followed these details from an earlier discussion – see below:

    1- Turning off WordPress Blog page:

    • 1-a Go to settings > reading
    • 1-b Set front page as Static
    • 1-c Make sure NOTHING is selected in the post page drop down list (showing –select–)

    2- Creating a blog page:

    • 2-a  Go To Dashboard > Pages > Add New
    • 2-b Give a title to the page ( I called the page “POSTS”)
    • 2-c In Page attribute box on the right (if it is closed click on the small down arrow to open it), Select “Page with Posts” in the Template Drop Down list  
    • 2-d Click Publish. After you click Publish, if you click Preview, The page should show all your latest posts.

    At this point I have selected –  Add [show_posts] – to add the default filter  [show_posts filter=”default”] to the “POSTS” page

    When I view the “POSTS” page I get a message – no
    posts are found
    The permalink for this newly created page is: http://www.agapetherapeutic.com/posts/

    Now obviously they are not pointing to the same place and so how do I correct that?.

    Thank you for the help.
    Kent Smith.


    Plus one other thing is that I can’t get rid of the Site Title and Tagline on the Healing Relationships post but I can on the “POSTS” page. I need help with that too. Thanks!


    If you want to use the show posts shortcode to display your posts, you create a standard page and put the shortcode in that, you don’t create a page using the “page with posts” template.


    I suspect you may be using the Weaver Slider Posts and the Show Posts shortcode in error.

    There is really no reason to use the Weaver Slider Posts to create and display regular posts.

    Weaver Slider Posts are not regular posts, and this is why they do not show up in a page using the page with posts template. they are only meant to be displayed using the Show post Filter/shortcode.

    Regular Posts should be created using WordPress posts and can be displayed using  a page that uses the Page with posts template, and then filtered and formatted using the options on that page.

    The Show Posts shortcode can display regular WordPress posts, and is usually only needed when you want to display regular Posts in other areas like widgets, or when you need to do some special mix between regular content and Posts.

    The Weaver Slider posts are usually only needed when you want to create sliders of content that you do not want to be mixed up with posts.

    So if you have a specific reason for using Weaver slider posts AND Show posts, please elaborate so we can be sure this is the way to go.

    If not, just create your posts using WordPress Posts, and create your blog page using a page based on the page with posts template.

    The site title and tagline can be removed from all pages by using the hide option fro each of them in Main options > Header ? Site Title / tagline “Hide Area” option drop down list.

    if you need it on some pages but not others, then you can use the per page options for your created pages, but if you need to remove it from Single post pages while keeping it on other pages, then you would need to add some custom CSS. let us wait to have clarified the above before going into that 🙂


    Hi Scrambler,

    Thanks for the help and so I have my first post appearing on the “Blog” page – http://www.agapetherapeutic.com/healing-relationships/

    Next problem though is that the post does not populate the space to the right side edge of the page. I have selected the post to display in one column but it’s obviously not filling the space so I need help to find the setting issue.

    Thanks yet again!


    I am not sure what you mean, The posts content takes the whole space of the site Content area.

    The site width is set at its default 940px, so if your browser is larger it will have empty space on each sides.

    You can change the Site width in Main options > Wrappers areas > Wrapper Area > Theme Width box.

    I suggest you explore each on the option pages and check what these do so you can become familiar will all the formatting options.

    You can put some temporary colors in the various area BG boxes to make sure you understand which is which.

    You can also visit the demo site here: http://demo.weavertheme.com/  Each page explains something about what the theme can do 

    For your posts, go to Main options > Post Specifics and check what is there. For example, right now your Featured Image is set to be above the title and centered, but you have a lot of different choices in the Featured image section of that page.


    Hi Scrambler,

    Still no luck getting the post to cover the right 2/3 of the page. My default page setting is to have a single left sidebar within the content area.

    When I change the background color of the Post Area (get there by: Appearance – Theme Options – Main Options – Post Specifics – Post Area BG: PLUS under Post Specifics – Post Layout I have selected 1 Column) there is the left side bar, the post down the middle with a different color background and then another 1/3 of the full theme width to the right sitting empty.

    For the “BLOG” page itself I have the following options selected:
      For Sidebars & Widgets: Use Default (which is having the single left sidebar on the page)
      Settings for “Page with Posts” Template: I’ve selected “Default Filter” for –  Use a Filter from ATW Show Posts Plugin instead of above post selection options.
    My “Default Filter” consists of selecting
    Hide Post Title & Show Author Avatar

    After trying different things for the last 4 hours nothing has changed. I even deleted the feature image from the post and it made no difference.

    Not sure what else to do. I’m wondering if there is some sort of bug or some other issue? Obviously not pleased that I can’t get things looking as I understand they should look.



    Have you tried increasing the site  /theme width?

    Do the following so we can understand eachother.

    Type   grey  in Main options > General Appearance > Outside BG color box. This will show you the outside of the site. To use that space you need to increase the theme width

    type  blue  in   Main options > General Appearance > Container Area >Container area BG box

    Type   yellow  in Main Options > Content Area > Content Area BG color box  

    based on these color, post back as is and explain what space you are trying to eliminate

    Also make sure to look at it on different browsers, in case you are seeing sometjing I don’t (I am looking with IE 11)


    It sounds like a cache issue to me – the post covers the right two-thirds of the theme width when I view it.

    If you have a cache plugin installed, clear the cache.  Also clear your browser cache.

    Hi Scrambler & Gillian,

    Here is what’s happening…

    I cleared my browser cache (IE, Firefox & Chrome) as well as the page cache of the W3 Cache plugin. When I browse to my site with all three browsers the “BLOG” page looks correct – yaa!

    I then logged into the WP dashboard for the site via all three browsers and did what Scrambler suggested and changed the colors. When I select “Visit Site” via the WP dashboard and then go to the “BLOG” page most of the time I get the correct display but sometimes it’s the original problem. I took a screen shot but I can’t attach it to this message.

    What happens now is that I lose the black WP bar above the site when I view the “BLOG” page but the black bar remains there when I view my other pages. Not sure why but I don’t want to be sidetracked further.

    Thank you both for your help. It appears that the issue has nothing to do with why I contacted the support forum.  


    First thing to do is deactivate ALL non weaver plugin, Including the cache plugin and see if that fixes the problem. if it does, reactivate one by one to find the culprit.

    If not, and if you only have a problem with that page, I would say delete the page and recreate a new one to see if that works.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.