Home Forums Weaver Show Posts & Show Sliders New posts are not showing on Category page

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
  • #67397

    I created a new post as I always have and yet it is not showing up on my category page and is not showing up when searching for its tags.  I have Weaver Show Posts Plugin (V 1.5.1) but have no experience with using it.  Any ideas?  Thank you in advance.


    You need to clarify what you are saying

    You say your post does not show on your category page. Is that the standard WordPress category page, or a page created using the show post plugin?

    We also need links to your site, especially:

    • Your blog page if you have one
    • The single post page of the posts in question
    • The Page containing the weaver show posts
    • The WordPress category page of the category the post belongs to



    This is the Category page:  http://www.hvpi.net/articles-of-interest/

    This is the post that’s not showing up on the above page:  http://www.hvpi.net/hvpi/2021/02/21/social-atoms-in-substance-abuse-treatment/

    The Category page is reached by way of a button (Articles of Interest) on the sidebar of the home page:  http://www.hvpi.net/

    I use the Category page as more of a reference library than a blog (comments are disabled).

    This is all I know…I’m not very savvy about this stuff.


    What you call your category page is actually a regular page with posts based on the “page with posts” template.
    The page ID is #1845.

    So you need to go to the page editing page of that page, and check the page with posts options, post a screenshot, or list all options.

    Next you need to inspect the post editing page of the post that does not show up, to see if there is anything there that would exclude it from the page with posts


    I can’t get Print Screen to work no matter how many hotkeys I try.  The only options on the page are the template (default, blank, iframe, 2 col content, raw, sitemap) and the “page with posts” which is selected.  Other than that there is “parent page” which has nothing selected and “order” which is set at “0”.

    I’ve checked this post that I’m trying to publish properly and compared the options/settings to other successfully published posts.  Everything is the same.  Can there be a setting somewhere that limits the number of posts on the “page with posts”?  It looks like I have 40 posts up on the page (suspicious number?).  Or could the latest WP updates had an effect?


    If you look at the very last “post” showing on the articles of interest page, it seems to be empty or otherwise broken.

    Normally, Page with Posts allows you set number of posts per page, but does not have a limit on total number of posts.

    I did notice something a bit odd – if you look at your articles-of-interest using the category page:


    everything seems to work as expected. Page with posts has been around a very long time and is widely used, but it normally would work just like the category page if you’ve only specified one category to display on the Page with Posts settings. But if you compare the outputs of the Page with Posts version and the /category/articles-of-interest page, the displayed posts don’t correspond exactly: PSYCHODRAMA AND THE TREATMENT OF BULIMIA does not show up on the /category page.

    And you should check that the new article that is not showing up on the Page with Posts page does in fact show up on the /category page.

    It does not seem to be there on the /category view, although it does seem to be correctly tagged to the proper category.

    And all the Page with Post specific settings are on the Page with Posts tab in the Weaver Page settings at the bottom of the Page Editor display.



    ** The Page with posts options are in your page editing page > Weaver Xtreme 4 Option for this page section > Page with posts TAB
    There you have filter boxes to include or exclude post by category, tags, etc… Check what is in these boxes

    ** WordPress can limit the number of posts on a blog page, that setting is in Settings > Reading, check what you have there

    Next, here are two simple test you can make

    1) Create a new basic test page with posts.

    In its page editing page, in the  Page attribute section > Template drop down list, select Page with posts, then PUBLISH.

    That will create a page with post with all default settings that should include ALL posts, check if that page shows your posts and post a link to it

    2) Create a New basic test post

    In its post editing page, only give it a title TEST, some text, and select the category article of interest for it, NOTHING else, Publish, and see if it shows up on your article of interest page, as well as on the new test page, report and give us a link to the post



    I set up the new “page with posts” and it populated properly.  However, when I edited the widget for my primary sidebar (where the link is for accessing the page with posts) the link won’t take me to the new “page with posts”.

    The new page is:  http://www.hvpi.net/hvpi/articles/

    And here’s what the widget now states: 

    It works on my desktop, but other devices go to: http://www.hvpi.net/articles-of-interest/


    The link is good, you must just have a cache issue on the devices that still go to the old one.

    The fact the new page works means one of the settings in your original page with posts is causing the issue, you may want to compare them all to figure it out


    I cleared caches in multiple devices, I trashed the original “page with posts” and yet clicking on the button with the following code takes me to the old http://www.hvpi.net/articles-of-interest/  rather than the new http://www.hvpi.net/hvpi/articles/

    Here’s the code for the button that SHOULD link to the second address: 

    <xxx=”http://www.hvpi.net/hvpi/articles/&#8221; style=”color: #fff !important;”>Articles of Interest

       (I removed ‘a href’ and added xxx so it wouldn’t be converted to a link for you which is what it did last time).



    That last paragraph still turned partially into a link even though I entered it as plain text.  I’m going to try to do it in pieces so you can actually see the code:

    <a href=”http://www


    style=”color: #fff !important;”>Articles of Interest


    Your syntax is incomplete, below is the right link syntax

    <a href="http://www.hvpi.net/hvpi/articles/" style="color: #fff !important;">Articles of Interest </a>

    Be careful with double quotes, when you copy paste, based on the editor used they get converted to asymmetrical quotes that are invalid.

    Type them directly in the final location instead



    I entered your link, but it still loads   ****.net/articles-of-interest     rather than ****.net/articles  and thus will not load the post that I need: http://www.hvpi.net/hvpi/2021/02/21/social-atoms-in-substance-abuse-treatment/




    If I go to your site page Hudson Valley Psychodrama Institute (hvpi.net)

    the link in the box is:

    <a href="http://hvpi.net/articles-of-interest/" style="color: #fff !important;">Articles of Interest</a>

    And not what we discussed

    So whatever or wherever you are editing the link is not the right place, or you have cache issues that need to be cleared


    Okay, I’ve got it up and running (mostly).  It wasn’t a cache issue, it was an address issue.  Anyway, one last bit if you’re still with me.  The button with the link to my page with posts is perfectly displayed on the Primary Sidebar on the home page  http://www.hvpi.net , but the text has moved off the button on the other pages and posts.  What can I do to get the look to be consistent across all pages & posts?


    When I go to all the pages from the main menu, the text in the button is perfectly centered and the same in all

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.