Home Forums Weaver Xtreme Theme Need to Show Comments on old posts with Closed Comments

Topic Resolution: Resolved

This topic contains 11 replies, has 2 voices, and was last updated by  scrambler 3 weeks, 1 day ago.

Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #61689

    dirtybutter
    Participant

    I have an Archive Category with 3k+ posts. https://plushmemories.com/

    Many of the existing comments are as useful today as they were when made. So I want those comments VISIBLE.

    BUT I do NOT want anyone to be able to comment on them any more.

    I DO want comments enabled on newer comments.

    What combination of WP settings will accomplish this, OR how can I use Xtreme to accomplish this?

     

    #61692

    scrambler
    Moderator

    I dont know any way to do that, so it is probably a question for the WordPress forum and / or plugins.

    if there is no way to accomplish it properly, we may be able to trick it by enabling comments, but not displaying the control that allow to create new ones with CSS

    #61693

    scrambler
    Moderator

    The CSS rule to hide the box that contains the comment posting would be

    .single .category-xxxx #respond {display:none;}

    replacing xxxx by the category name

    #61694

    scrambler
    Moderator

    I actually found this that looks like it gives a PHP action that would do the job

    https://spicewp.com/disable-hide-comments-posts-specific-categories/

    If you have the “Plus” plugin, then you can try adding the action in the Actions and fitter box found in the Advanced page

    You may also find some plugins, I read this below

    https://wordpress.org/support/topic/disable-comments-by-categories/

     

    #61695

    dirtybutter
    Participant

    https://forum.weavertheme.com/forums/topic/need-to-show-comments-on-old-posts-with-closed-comments/#post-61693

    This looks ideal scrambler. But I don’t have a clue where to put the CSS.

    You helped me set up the free search service website many years ago. It grew so big I could not handle it and moved to Facebook. We have over 6k members there now and 5 Admins.

    But people still make use of all the info stored in these old blog posts. I appreciate your help in helping other people!

    #61704

    scrambler
    Moderator

    All CSS goes in the Theme Global Custom CSS Rule box

    #61713

    dirtybutter
    Participant

    OK – I had tried that, so I’m doing something wrong or it’s not the right code.

    .single .category-archived-search-requests #respond.comment-respond {display:none !important;}

    #61716

    scrambler
    Moderator

    You rule is missing a space before #respond

    .single .category-archived-search-requests#respond.comment-respond {display:none !important;}

    #61724

    dirtybutter
    Participant

    I tried it with and without the space – didn’t matter. I also tried just the last half of the code (#respond.comment-respond {display:none !important;}), and as expected NO comment box showed on any post.

    https://plushmemories.com/archived-search-requests

    This is a post from the Archived category I am trying to tweak.

    https://plushmemories.com/19878/gund-black-velvet-bear-pink-white-rabbit-jellybean.html

    #61725

    scrambler
    Moderator

    You still have the wrong rule below in your page

    .single .category-archived-search-requests#respond.comment-respond {display:none !important;}

    You need to change it to what I said below and clear all your caches and let me check it out

    .single .category-archived-search-requests #respond {display:none;}

    Also run ALL your custom CSS through a CSS validation site in case you have other syntax errors that break your CSS file

    #61728

    dirtybutter
    Participant

    I’m going to close this request for help. I do appreciate your efforts, but this is just beyond my ability.

    #61730

    scrambler
    Moderator

    Well you have the proper rule now and it appears to be working , the old comments are there but not the box to enter new ones

    You probably were just having some caching issue

Viewing 12 posts - 1 through 12 (of 12 total)

You must be logged in to reply to this topic.