Home Forums Weaver Xtreme Theme Migration blow-up: failed to open stream … template.php

Viewing 16 posts - 1 through 16 (of 29 total)
  • Author
    Posts
  • #71471
    ssm
    Participant

    Migrating from Weaver II Pro to Xtreme. All nominal until Xtreme activated, then site aborts.

    http://wwww.siliconstrat.com/

    <b>Warning</b>: require_once(zip://#template): failed to open stream: operation failed in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>770</b>

    <b>Fatal error</b>: require_once(): Failed opening required ‘zip://#template’ (include_path=’.:/usr/lib/php7.4′) in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>770</b>

    #71473
    scrambler
    Moderator

    Can you copy paste the content of the system info box from the help page here, so @weaver can have a look at the versions and configuration.

    Also, have you tried deactivating ALL non weaver plugins before activating Xtreme, just in case one is causing problems

    #71474
    ssm
    Participant

    Wish I could, but the admin section is DOA as well.

    (I did backup the database before stating, so I can recover … just hoping you know the issue and have a quicker fix).

    #71475
    scrambler
    Moderator

    If activating the Xtreme Theme triggered it, you can try going into your CPanel File manager, and rename the Xtreme Theme folder to Something else like XXXXtreme, and see if the Admin starts with a default theme.

    If it does, gather the system info, check if things still run with the old weaver II pro or a default WP theme.

    #71476
    scrambler
    Moderator

    You may have to do a bit more in the Cpanel file manager to switch theme manually.

    See below

    Change your WordPress theme from the database – Support | one.com

    or

    How to change the WordPress theme manually (a2hosting.com)

     

    #71478
    ssm
    Participant

    Thanks. As FYI:

     

    1. renaming the xtreme folder did not work
    2. editing the database got me back to weaver-pro-ii

    Here is the sysinfo:

    
    ### wp-core ###
    
    version: 6.0.1
    site_language: en_US
    user_language: en_US
    timezone: -08:00
    permalink: /marketing-memos-blog-xxx/%postname%/
    https_status: false
    multisite: false
    user_registration: 0
    blog_public: 1
    default_comment_status: closed
    environment_type: production
    user_count: 408
    dotorg_communication: true
    
    ### wp-paths-sizes ###
    
    wordpress_path: /homepages/37/d146050845/htdocs/ssm-wp
    wordpress_size: 86.70 MB (90908083 bytes)
    uploads_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/uploads
    uploads_size: 123.51 MB (129509514 bytes)
    themes_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes
    themes_size: 30.55 MB (32038888 bytes)
    plugins_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins
    plugins_size: 84.52 MB (88626114 bytes)
    database_size: 532.86 MB (558743552 bytes)
    total_size: 858.14 MB (899826151 bytes)
    
    ### wp-active-theme ###
    
    name: Weaver II Pro (weaver-ii-pro)
    version: 2.2.4
    author: Bruce Wampler
    author_website: http://weavertheme.com/about
    parent_theme: none
    theme_features: core-block-patterns, woocommerce, widgets-block-editor, editor-style, automatic-feed-links, menus, post-formats, post-thumbnails, custom-header, custom-background, infinite-scroll, widgets
    theme_path: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/themes/weaver-ii-pro
    
    ### wp-themes-inactive (13) ###
    
    Alexandria: version: 2.0.11, author: ThemeAlley.com (latest version: 2.5.6)
    Weaver II Child Demo: version: 1.2, author: Bruce Wampler
    Twenty Eleven: version: 1.7, author: the WordPress team (latest version: 4.2)
    Twenty Fourteen: version: 1.0, author: the WordPress team (latest version: 3.5)
    Twenty Nineteen: version: 1.3, author: the WordPress team (latest version: 2.4)
    Twenty Seventeen: version: 1.4, author: the WordPress team (latest version: 3.1)
    Twenty Sixteen: version: 1.4, author: the WordPress team (latest version: 2.8)
    Twenty Thirteen: version: 1.1, author: the WordPress team (latest version: 3.7)
    Twenty Twelve: version: 1.3, author: the WordPress team (latest version: 3.8)
    Twenty Twenty: version: 2.0, author: the WordPress team (latest version: 2.1)
    Twenty Twenty-One: version: 1.6, author: the WordPress team (latest version: 1.7)
    Twenty Twenty-Two: version: 1.2, author: the WordPress team (latest version: 1.3)
    Weaver Xtreme: version: 5.0.7, author: Bruce Wampler
    
    ### wp-plugins-active (18) ###
    
    Advanced Editor Tools (previously TinyMCE Advanced): version: 5.6.0, author: Automattic
    Akismet Anti-Spam: version: 5.0.2, author: Automattic
    All in One SEO: version: 4.2.8, author: All in One SEO Team
    Bounce Handler Mailpoet: version: 1.3.21, author: Tikweb
    Disable Comments: version: 2.4.2, author: WPDeveloper
    MailPoet: version: 4.3.0, author: MailPoet
    MaxButtons: version: 9.5, author: Max Foundry
    MetaSlider: version: 3.28.2, author: MetaSlider
    Ninja Forms: version: 3.6.14, author: Saturday Drive
    Raw HTML: version: 1.6.3, author: Janis Elsts
    Regenerate Thumbnails: version: 3.1.5, author: Alex Mills (Viper007Bond)
    Relevanssi: version: 4.18.2, author: Mikko Saari
    Simp Modal Window: version: 1.6, author: Shahzad Anjum
    Velvet Blues Update URLs: version: 3.2.10, author: VelvetBlues.com
    Weaver Ii Pro Theme Template: author: (undefined), version: 6.0.1
    Weaver II Theme Extras: version: 2.3.1, author: Bruce Wampler
    Weaver II to Weaver Xtreme: version: 1.1, author: Bruce Wampler
    WP Captcha Free: version: 0.9.1, author: iDope
    
    ### wp-plugins-inactive (2) ###
    
    Weaver Themes Shortcode Compatibility: version: 1.0.4, author: Bruce Wampler
    Weaver Xtreme Theme Support: version: 5.0.2, author: wpweaver
    
    ### wp-media ###
    
    image_editor: WP_Image_Editor_GD
    imagick_module_version: Not available
    imagemagick_version: Not available
    imagick_version: Not available
    file_uploads: File uploads is turned off
    post_max_size: 64M
    upload_max_filesize: 64M
    max_effective_size: 64 MB
    max_file_uploads: 20
    gd_version: 2.2.5
    gd_formats: GIF, JPEG, PNG, WebP, BMP, XPM
    ghostscript_version: 9.27
    
    ### wp-server ###
    
    server_architecture: Linux 4.4.302-icpu-088 x86_64
    httpd_software: Apache
    php_version: 7.4.33 64bit
    php_sapi: cgi-fcgi
    max_input_variables: 5000
    time_limit: 50000
    memory_limit: -1
    max_input_time: -1
    upload_max_filesize: 64M
    php_post_max_size: 64M
    curl_version: 7.64.0 OpenSSL/1.1.1n
    suhosin: false
    imagick_availability: false
    pretty_permalinks: true
    htaccess_extra_rules: true
    
    ### wp-database ###
    
    extension: mysqli
    server_version: 5.7.38-log
    client_version: mysqlnd 7.4.33
    max_allowed_packet: 67108864
    max_connections: 3000
    
    ### wp-constants ###
    
    WP_HOME: undefined
    WP_SITEURL: undefined
    WP_CONTENT_DIR: /homepages/37/d146050845/htdocs/ssm-wp/wp-content
    WP_PLUGIN_DIR: /homepages/37/d146050845/htdocs/ssm-wp/wp-content/plugins
    WP_MEMORY_LIMIT: 40M
    WP_MAX_MEMORY_LIMIT: -1
    WP_DEBUG: false
    WP_DEBUG_DISPLAY: true
    WP_DEBUG_LOG: false
    SCRIPT_DEBUG: false
    WP_CACHE: false
    CONCATENATE_SCRIPTS: undefined
    COMPRESS_SCRIPTS: undefined
    COMPRESS_CSS: undefined
    WP_ENVIRONMENT_TYPE: Undefined
    DB_CHARSET: utf8
    DB_COLLATE: undefined
    
    ### wp-filesystem ###
    
    wordpress: writable
    wp-content: writable
    uploads: writable
    plugins: writable
    themes: writable
    
    ### aioseo (1) ###
    
    noindexed: Author Archives, Date Archives, Search Page, Categories (category)
    
    
    #71479
    scrambler
    Moderator

    @weaver, so you see anything in the sysinfo that could explain why his site crashed when activating Xtreme with the error messages mentioned in the first post ?

    #71481
    Weaver
    Keymaster

    The error messages shown in the first post make no sense to me at all. It is as if WP has lost its path settings.

    I don’t know why Weaver II Pro would work any better, but it apparently does.

    I would try to switch to a different them such as one of the WP ones installed such as Twenty Fifteen (or any of them).

    Otherwise, try to down load the latest Weaver Xtreme 6.0.x and Weaver Xtreme Support 6.0.x from the Downloads menu on https://weavertheme.com

     

     

     

    #71482
    ssm
    Participant

    Switching from Weaver Pro II to Twenty Twenty Two produced the same error.

     

    <b>Warning</b>: require_once(zip://#template): failed to open stream: operation failed in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>770</b>

    <b>Fatal error</b>: require_once(): Failed opening required ‘zip://#template’ (include_path=’.:/usr/lib/php7.4′) in <b>/homepages/37/d146050845/htdocs/ssm-wp/wp-includes/template.php</b> on line <b>770</b>

    There has been a critical error on this website. Please check your site admin email inbox for instructions.

    #71483
    scrambler
    Moderator

    Assuming you tried after deactivating ALL  plugins, something may be corrupted in the WordPress Install.

    I would try redoing the latest WordPress Update to see if that helps, and if not ask the Host provider if they have an idea.

    #71484
    ssm
    Participant

    FYI:

    • Deactivating all plugins did not help.
    • Updating to latest WordPress did not help
    • Both these test using updated Twenty Twenty Two theme

    I just tried a “live preview” of the Xtreme theme and it generates the same errors.

     

    #71485
    Weaver
    Keymaster

    I’m trying to understand the issue.

    Does your site work using just Weaver II Pro?

    Are you unable to switch to any other theme when Weaver II Pro is activated?

    Do you have any cache or content serverl (like CloudFlare) installed?

    If you CAN switch to a different theme, then there is no logical reason you couldn’t switch to Weaver Xtreme, so I’m very confused.

    Does your site have any “must use” plugins? These plugins are often installed by the host company, or other plugins. They do NOT show up in the installed plugins list. They can do really complicated behind the scene functions, and can break sites. The only way to see them is from your CPanel (or other host specific file system access tool). They are located in the /wp-content/mu-plugins directory. The only way to deactivate them is to delete them, or rename the /mu-plugins directory to something else.

    And there is recently another user who has been experience similar issues because of a CPanel based site optimizer that eneded up blocking some subdirectories an script files.

    #71486
    Weaver
    Keymaster

    Right now the link in your first post leads to a broken site.

     

    Hmm. We’re having trouble finding that site.

    We can’t connect to the server at wwww.siliconstrat.com.

     

    update: the link provided is wrong – wwww instead of www

    I can see it is live running Weaver II Pro.

    #71487
    ssm
    Participant
    1. It almost works using Weaver Pro II, but the drop-down menus quit working (I experienced the same on a different Weaver Pro II site). Since my other sites migrated to Xtreme, that was my choice going foward.
    2. I am unable to switch to any other theme that I have tried, those being Xtreme, 2022, and one of the other WordPress provided themes.
    3. No caching.
    4. No “must use” plugins (hosted at Ionos). I do hand installs of WP, so nobody got in between be and the site.
    #71488
    Weaver
    Keymaster

    @ssm:

    Now that I can look at the site, I see that most of your menus are broken . Any menu with submenus will not open the submenus.

    I really don’t remember all that much about Weaver II Pro any more, but maybe there was an option for “smart menus”? I don’t remember how the down triangle was generated. It might have been Javascript.

    But now it seems there may be some carry over that is somehow blocking switching to a new theme.

    So if you do have access to the WP Themes admin screen (traditional interfact, not the customizer), then you should be able to try switching to a new theme from that interface. If you still get the message, then try going to your CPanel file access. Then in the /wp-content/themes directory, be sure a default theme exists (like twenty twenty three). Then try renaming the Weaver II Pro directory to some other name. See if that will force WP to switch to the default theme. If than doesn’t work, move the weaver II Pro theme direcotry to some other directory (say the /wp-content root directory). Then you should only have the default them in the /wp-themes/ directory.

    So you site should now load to the default theme (or at least only show one choice from the dashboard themes interface). You should now be able to re-install Weaver Xtreme and switch to it.

    If that doesn’t work, then I suspect that some how your .htaccess directory is corrupted. As long as your WP database entry remains intact, you should be alble to completely remove WP, and do a fresh install using the original wp-config.php file..

    #71489
    Weaver
    Keymaster

    Ok, one more thing. Your site does not seem to be running with WP 6.1. I actually can’t tell which version it is, but it is not 6.1.

    Your site also seems to have some advertising plugins installed.

    To test things out, you really do need to deactivate ALL plugins. Not just some, but ALL. But this may also be related to an unknown mu-plugin.

    I have not tried to use Weaver II Pro on any site recently, so I don’t know what new incompatibility might be there.

Viewing 16 posts - 1 through 16 (of 29 total)
  • You must be logged in to reply to this topic.