Home Forums Weaver Xtreme Theme Menu question

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #63017

    I’m having trouble with the header menu on https://grace.allpurposeguru.com. It’s only supposed to have Home, About, and Contact. My settings in Appearance/Theme look right to me. Is there a Weaver setting I need to look at?


    Your menu should be created using WordPress Custom Menus in Appearance menu.

    Once the menu is created there, you need to assign it to the Weaver menu location of your choice (primary, secondary, header Mini menu) using the Menu settings at the bottom of Appearance > Menu


    Thank you, as always, for your prompt response. Maybe I didn’t make my question clear enough.

    The menu I created in WordPress under “Appearance” is called WPLook MAIN MENU. It has three items set up: Home, Contact me, and About. When I look under Custom Menus in the Customizer, I see the same menu, with the same name and same three items.

    Why, then, does the visible menu on the site also contain “God’s gift wrapping references” and “YOP Poll Archive”? I created “God’s gift wrapping references” as a link from within a post. It was never supposed to be a menu item. I put a poll on a post a long time ago, and no one responded.

    I see the extraneous pages in the WordPress menu builder with check boxes “add to menu.” They are unchecked. So why are they displaying? I even disabled the YOP poll plugin, hoping to get rid of at least that item. It didn’t.

    The settings in both WordPress and the Customizer look correct. The menu doesn’t. How do I get rid of those two unwanted menu items?



    The menu under you header is your weaver primary menu.

    So we need to double check what menu you allocated to be the primary.

    Do the following:

    • Go to Appearance > Menu , where you create the menu (Not the customizer)
    • If the menu you created is named “WPLook MAIN MENU“, select that menu in the dropdown list next to “Select a Menu to Edit”
    • CHeck if the menu items listed under “Menu structure” are the right ones
    • Then check at the bottom of the page under “Menu Settings” if The Check box for “Primary navigation” is checked.

    If all the above checks out, then something may be going on.

    The first thing you can do is recreate the menu under a simple name like TEST, Allocate that to “Primary navigation” and see if that works.

    Another thing to try is CLear all you caches (plugin, browser…)

    Then deactivate ALL non weaver plugins and see if that changes anything



    Thanks! I checked that box, saved, and everything looks right. Amazing what one click can do for good or ill!

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.