Home Forums Weaver Xtreme Theme Menu problem on multilingual site

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #56853
    StarWeaver
    Participant

    Hi everyone,

    I am using Polylang plugin and Weaver Xtreme free version (most recent version) to create a multi-lingual (English & Spanish) site at https://desertsw.trulyalive.net/.

    I successfully installed the Polylang plugin, which allows the site to switch between Spanish & English versions of the web pages — but it is not allowing website users to change the language of the menu.

    According to the Polylang support page https://polylang.pro/doc/my-menu-doesnt-change-with-the-language/ , I need to do the following with Weaver Xtreme (but I don’t know how to do it):

    A frequent issue is a menu which is correct when directly accessing the page but doesn’t switch when clicking on the language switcher. More and more themes are loading the content in Ajax and thus don’t reload the menu and content common to every pages (ex footer, widgets). This Ajax feature is obviously not compatible with multilingual websites. Try disabling the Ajax feature in your theme options or contact the theme support if you don’t find such option.

    Can you tell me the best way to proceed in this instance, in order to fix this problem?

    I very much appreciate your assistance with this. Thank you in advance.

    Best Wishes,

    Mary Anne 🙂

     

     

    #56856
    scrambler
    Moderator

    @weaver will have to look at this one

    #56857
    StarWeaver
    Participant

    Thanks scrambler.

    I will keep Polylang activated so that @weaver will be able to see what’s going on with the menu.

    Site Link: https://desertsw.trulyalive.net/

    #56859
    Weaver
    Keymaster

    I’m not sure of the problem. Weaver Xtreme uses JavaScript strictly for styling the menus, but this is not AJAX, and the menus are not preloaded.

     

    The link you provided gives an error message:

    The page isn’t redirecting properly

    An error occurred during a connection to desertsw.trulyalive.net.

    This problem can sometimes be caused by disabling or refusing to accept cookies.

     

    I don’t know what might be causing that.

    #56861
    StarWeaver
    Participant
    It’s working now. I fixed the problem by to re-saving the Polylang plugin settings after I deactivated it (or it causes redirects like that).
    I just emailed you a screen shot of what’s coming up for me now — it’s working.
    Thanks again.
    #56862
    StarWeaver
    Participant

    Clarification — the site is coming up now — but the menu is not working right (not yet).

    Link: https://desertsw.trulyalive.net/

    Thanks again.

    #65257
    Fanohtar
    Participant

    Hello! I`m making new site now and have the same problem

    Főoldal

    Could you please tell in details, how could you solve the problem?

    Best regards,

    Leonid.

    #65258
    Weaver
    Keymaster

    By inspecting your link, it appears that only the actual content of the page or post is being language switch. The site title, menu items, and footer items are not being changed.

    We are not familiar enough with language tools to know how they actually work. You would have to contact the plugin authors for more help.

    But one thing to try is to change themes – say to one of the standard WP Twenty-something themes and see if everything gets changed or if they have the same issue. Or try other themes.

    #65259
    Fanohtar
    Participant

    Thank you for the answer!

    Actually, I like this theme, because there are a lot of possibilities in making site, what I would like to have.

    I`ll better try to change the plugin.

    #65260
    scrambler
    Moderator

    @Fanohtar

    Weaver was not suggesting to give up on the theme, but to make a test switching temporarily to a different theme to see if the problem persists or not.

    This will give him an indication on whether the issue could be linked to the theme or not.

    Before doing the test to switch to a different theme you should actually test deactivating All plugins except for the weaver one and your multilanguage support one and see if the problem is still there, in case another plugin is interfering.

    If that makes no difference, test switching to a WordPress default theme and see if the problem persists. Switching theme will not make you loose anything, once you switch back to Xtreme everything will come back the way it was. If you want to be extra careful, save your settings beforehand and download a copy locally for safe keeping.

    If the problem disappears on a different theme, report here so weaver knows about it.

    If the problem remains, contact the plugin developer support to ask them if they can identify what the problem is. They are the best place to do that.

     

     

    #65264
    Fanohtar
    Participant

    Oh, I understand now! Thank you 🙂

    I have deactivated the plugins. After deactivating Page Builder SiteOrigin the main page can change the languages and that`s all.

    Changing theme did not help too.

    At the Polylang support page https://polylang.pro/doc/my-menu-doesnt-change-with-the-language/ they say, I need to do the following with Weaver Xtreme (but I don’t know how to do it):

    A frequent issue is a menu which is correct when directly accessing the page but doesn’t switch when clicking on the language switcher. More and more themes are loading the content in Ajax and thus don’t reload the menu and content common to every pages (ex footer, widgets). This Ajax feature is obviously not compatible with multilingual websites. Try disabling the Ajax feature in your theme options or contact the theme support if you don’t find such option.

    #65265
    Weaver
    Keymaster

    Weaver Xtreme does not use Ajax for menus, so that is not the issue. And changing the theme not helping also indicates the issue is elsewhere.

    #65270
    scrambler
    Moderator

    so @Fanohtar you need to ask the plugin developer to have a look at your site and explain why it does not work.

     

    #65277
    Fanohtar
    Participant

    It turns out, that support of this plugin is only for users of Pro version. Of course, I will not buy a Pro version if it does not work. So I will try another plugin.

    Thank you, Weaver and Scrambler!

Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.