Home Forums Weaver Xtreme Theme menu in Header image

Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #69028
    ROBIN
    Participant

    I am wanting to put the menu bar in the header image like you have done on the Forum page.

    I really don’t have much up yet but the site is

    https://daviscountyrealestate.net/

    My inspiration is https://www.ryanivie.com/

     

     

     

    #69029
    scrambler
    Moderator

    Do you still want the menu fixed, as your inspiration does not?

    If you do, then all you need is

    body {margin-top:0 !important;}

     

    #69030
    ROBIN
    Participant

    That works, except (There is always an except, sorry)  Is there a way to align the menu links to the Right and leave the logo far left?

    I keep trying to choose align right in the menu area and it just defaults back to center.  Is that because I have the Logo in the mix?

    #69031
    scrambler
    Moderator

    A few things.

    You used “Align full” for the header alignment, but also checked the Stretch Area option in the Full Width option page. Uncheck the Extend BG and Stretch options in the Full width Option page, they conflict with the new Full alignment option (they will actually be removed in v5)

    Then set your menu alignment to ” Align Full Item right”

    That should do it, if not post back with things in place

    You can also read the article below if you need vertical alignment between logo and menu

    Menu Bar: Advanced Customizations – Weaver Xtreme Guide (weavertheme.com)

     

    #69032
    ROBIN
    Participant

    I have done some trouble shooting:

    As long as I have the Stretched option in the Full-Width area, Menu’s will not save to anything except center.

    I tried unchecking the boxes, but they just rechecked at save.

    I tried other Header options, like center, align full etc and it didn’t help the menu box auto saving to center, so it must be the Stretched option in the Full Width area that is forcing the menu to center.

    I even switched Sub Theme to Full instead of Stretched and it didn’t help.

    Once I changed Theme’s, the menu won’t go over the header with your code, (Sorry about that, I can change back to the stretched Theme if needed)

    Thank you for any help you can provide, I think I may have found a bug.

    #69034
    scrambler
    Moderator

    I suspect you have One step layout option in the Full Width tab interfering

    Make sure One Step layout is set to Traditional.

    Uncheck all extend and stretch boxes, save and it should stick.

    Then do all full width with individual area Align options

    #69037
    ROBIN
    Participant

    Thanks Scrambler.

    That worked, for the menu placement.

    When I changed Sub Themes the menu went back up to the top and isn’t over the header image anymore.

    I tried removing the code and replacing it, but it still isn’t working.

    Thanks for all your help!

    #69038
    scrambler
    Moderator

    Yes it is, but you put a white background color on it 🙂

    Set the menu background to transparent.

    #69051
    ROBIN
    Participant

    Dang it!  Rookie mistake!  Thanks for your help, everything is perfect.

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.