Home Forums Weaver Xtreme Theme menu customization and breadcrumb navigation

Topic Resolution: Answered
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #67528
    Answered
    monere
    Participant

    Hi there!

    I am building a website using the weaver theme and am having problems figuring 2 things out that might be quite easy to figure out, but I don’t.

    First, the menu… the primary menu more specifically, the one under the header. I have 3 items added to that menu for now (will add more soon), and one of those items contains sub-items. For now, the menu looks like this:

    Home
    Blog
    News > USA News
    >UK News

    Now, when I created the NEWS page in wordpress I ticked the option for it to behave as a placeholder, so now, if you click on the news menu item the item does indeed behave like I want to (ie doesn’t do anything), but the problem is that a hashtag symbol gets added to the URL of this page in the browser, and this doesn’t look professional so I want that hashtag removed.

    So, question #1 is this… how do I make the menu item called NEWS unclickable (like it already is at the moment) but also make it not add the hashtag to its URL in the address bar of the browser?

    Issue #2… the homepage of the very same website is using the Page with Posts template, and I’ve set it to display the latest 4 posts from the blog page, but when I do this the navigation links at the bottom of the page also gets displayed, and I don’t want this.

    Now, before you give me the solution I need to say this: I do want to keep that navigation link at the bottom of the page for absolutely ALL other pages, but not for the homepage.

    After inspecting the source code of the page I noticed that the CSS element that I want to disable on the homepage is this:

    .nav-previous

    But if I add this element into the Fonts & Custom > Custom CSS rules section of the theme’s customizer with the display:none rule the navigation gets disabled site-wide and like I said, I want this only disabled on the home page, not on the entire website.

    So, question #2 is… how do I disable the .nav-previous on the homepage only? I’m not really good at CSS (I am unintentionally – but pleasantly – learning it through practice, though, which is cool!) so I don’t know the more intricate and complex rules yet.

    Can someone help with these 2 minor issues? I may have more questions in the future, but now these 2 are the most pressing ones, so do give a tip or 2 if it’s no biggie 🙂

    #67532
    scrambler
    Moderator

    You need to give us a link to your site so we can be sure of the details.

    Setting a page as a placeholder should not change anything in the display of the page name in the menu.

    The way to do that is by using the theme options. In the page editing page > Xtreme 4 Options for this page > Misc Option TAB > Menu Placehoder.

    Navigation for all page with posts can be set in Customizing ▸ Layout > Post Specific > Post Navigation

    If you have several post page and you only want to remove the navigation on one, we need a link to that page to give you custom CSS

    #67534
    Private Reply
    monere
    Participant
    This reply has been marked as private.
    #67536
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    I had misunderstood where you were seeing the # sign. This is what WordPress does, and I have no idea if there is a way around it. Searching google is probably your best bet

    But I admit I cant understand why you care 🙂

    the block editor is not a choice anymore, it is the default WordPress editor, but by installing the Classic editor plugin, you can function the same way as before. You even have a choice to use either on demand on any page or posts and switch between them.

    Regarding navigation, you did not say if you have more than one blog page or not.

    If you have more than one blog page and only want the navigation removed on the home page, and if you have figured out the CSS rule to do that, you can just add the .home selector to your rule that will look something like

    .home .nav-previous {display:none;}

     

    #67539
    monere
    Participant

    oh, dang! It did work with .home . I’m such an idiot 🙁

    And I hate the hashtag because it makes the site look unfinished / unprofessional. This WordPress, I swear…. always making things more and more retarded….

    Anyway, thanks for the fix! You just saved me another day of pulling my hair out

    #67549
    Weaver
    Keymaster

    The # is an HTML “feature”. No choice, really.

    #67554
    monere
    Participant

    that still doesn’t mean I have to like it 🙂

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.