Home Forums Weaver Xtreme Theme Menu area

This topic contains 16 replies, has 2 voices, and was last updated by  merlojh 2 months ago.

Viewing 16 posts - 1 through 16 (of 17 total)
  • Author
    Posts
  • #56639

    merlojh
    Participant

    I know I’ve asked before but how do I get rid of the text to the right of the logo and the gray below the menu? John

    #56640

    merlojh
    Participant
    #56641

    scrambler
    Moderator

    This is the site title and the info bar, use the hide option for each of them.

     

    #56642

    merlojh
    Participant

    I have  hide on both Header area  <u>Site Title/Tagline hide on all devices</u>

    #56643

    scrambler
    Moderator

    Actually it is Main Options > Menus > Primary Menu > Add Site title to the left option

    #56644

    merlojh
    Participant

    I set an background image on home page but do not want it on other pages and also see that on the blog page the header image is still there how do I change that. John

    #56649

    scrambler
    Moderator

    You have that question may times and quite recently.

    The article below explain how to set a background image for a specific page.

    https://guide.weavertheme.com/targeting-specific-pages-or-devices-for-styling-attributes-like-bg-image/

    Depending on what area you are setting the background, doing with a rule using the page id class and the area class

    If you do not want the header image anywhere, hide in in the header area > header image option.

    if you don’t want it in a specific page use the page option. For the blog page, you must make sure you are not using the wordpress blog page, but a weaver page with posts, or else weaver options do not work. read below

    https://guide.weavertheme.com/your-sites-home-page/

    #56663

    merlojh
    Participant

    Trying to get the image full width and height using this not working

    .page-id-11 #content { background-image:url(http://www.singingtreeproject.org/wp-content/uploads/2018/10/page-image.jpg);
    }

    #content {
    background:url(http://www.singingtreeproject.org/wp-content/uploads/2018/10/page-image.jpg) no-repeat center;
    background-size:cover;
    }

    #56664

    merlojh
    Participant

    #content did not work now the image is on the about page?

    #56669

    scrambler
    Moderator

    If you want an image in the page 11, you only need one rule, the first one.

    Right now it is working, in page 11 you do have that image in the content area. now of course the content is empty so you only see a narrow bar.

    When you say you want the image full width and height, do you mean of the whole page? if so, the image should be on the body with

    body.page-id-11 {background-image:url(http://www.singingtreeproject.org/wp-content/uploads/2018/10/page-image.jpg);
    background-size:cover;
    }

    If you want the whole site but not browser it should be on the wrapper with

    .page-id-11 #wrapper {background-image:url(http://www.singingtreeproject.org/wp-content/uploads/2018/10/page-image.jpg);
    background-size:cover;}

    I am adding background-size:cover, assuming you want a single image to cover the whole space, but if you have a motif to repeat, that may need to be change using a repeat option

     

    #56675

    merlojh
    Participant

    Thanks that is what I want just on the home page. On the about page I still have a gray area under the banner and I know you told me how to get rid of it before but I just forget. I also do not quite understand about the blog page? Thanks John

    #56678

    merlojh
    Participant

    I got the page for posts and it looks OK but now I have 2 blog pages do I delete the original one? I still can find the place to remove the gray below the menu?

    John

    #56684

    scrambler
    Moderator

    Hide the info bar in Main options > Menus > Info bar….

    #56698

    merlojh
    Participant

    Do not understand I went to info bar and <small>Info Bar: Hide area on different display devices</small> set this to hide on all devices but I still have a page that says blog and the page I made that says page with posts which is the one I want? How do I get rid of the blog page?

    http://www.singingtreeproject.org/

    John

    #56700

    merlojh
    Participant

    I did figure out how to get rid of the blog page but I still can not get rid of the banner image below the menu on the http://www.singingtreeproject.org/page-with-posts/? John

    #56702

    scrambler
    Moderator

    This looks like the WordPress default blog page and NOT a weaver page with post.

    Did you go to settings > readings, and make sure the front page is set to a static page, and that NOTHING is selected under post page (showing -select-)

    Once that is done, the post page should be created as a regular page and by selecting the page with posts template for it.

    Once updated, you will have access to the page options that allow you to hide the header image on that page

Viewing 16 posts - 1 through 16 (of 17 total)

You must be logged in to reply to this topic.