Home Forums Weaver Xtreme Theme link options gone?

Viewing 16 posts - 1 through 16 (of 17 total)
  • Author
    Posts
  • #65423
    LorSmi
    Participant

    I have a page with audio files listed and each line of text is a link which I have made to open in a separate page. I haven’t done one in awhile and today I tried to add a new audio link however when I click on edit options, nothing comes up. I want this link to open in a separate page like all the others but I can’t figure out how. I would go to text view and just write in the code however that isn’t working either! Nothing changes when I click on the text tab – I still stay on visual.

    #65425
    scrambler
    Moderator

    What editor are you using.

    Since the last few versions of WordPress, WP uses a block editor. To do HTML in there, you need to use an HTML block

    If you want the old editor, you need to install plugin called Classic Editor, then set it up to be the editor by default. You also have the choice when you edit a page to use the classic editor or the block editor.

    Also make sure you have the latest versions of everything, Theme and plugins.

     

    #65426
    LorSmi
    Participant

    I do have Classic Editor and it is the default. Everything is up to date.

    I was able to get it done, but I had to go below the page and check, in Misc Options, this one;

    Disable Visual Editor for this page. Useful if you enter simple HTML or other code.

    But I should be able to do it the old way.

    #65428
    scrambler
    Moderator

    Have you tried to use the weaver page option “allow Raw HTML and script” instead?

    You can also try to deactivate ALL non weaver plugins, to see if one is interfering with the editor

    #65430
    LorSmi
    Participant

    No, I didn’t but that’s just below the option that I did use.

    #65431
    LorSmi
    Participant

    I just realized that I hadn’t needed to update the page since March (due to COVID) and in that time span, I did also upgrade the site from Weaver II to Xtreme so maybe that has something to do with it.

     

    #65456
    Weaver
    Keymaster

    If you are adding a link from either the Classic Editor or a Block Edit paragraph block, highlighting a link should bring up a popup to edit the link. Both include an option to make the link “Open in new tab.” Should also work for an image.

    #65457
    LorSmi
    Participant

    Yes, that was what I  was use to, but its not popping up anymore.

    #65458
    Weaver
    Keymaster

    I get the open in new tab on either editor. You do need to have the Classic Editor plugin to get the latest working version of the classic editor, and click the pencil to edit the link. Then the gear symbol on the right will open a bunch of options, mostly a list of other pages on the site. With the Block Editor, the only option I see is to open in a new tab, and that is a check box / slide on option. If you aren’t seeing them, you may not have the Classic Editor installed.

    #65459
    LorSmi
    Participant

    How can I upload screenshots?

     

    #65461
    scrambler
    Moderator

    You have to store them somewhere online and use the link inside the post on the forum

    #65463
    LorSmi
    Participant
    #65465
    scrambler
    Moderator

    What do you get when you click on the link option icon (gear icon to the right of the link bar)?

    Because this is where I get the option to open in a new tab

    #65470
    LorSmi
    Participant

    It’s not a gear icon – its a remove link option

    No wait – I just tried it again – it does turn into a gear when I click on the pencil but when I click on the gear icon, nothing happens.

    #65472
    scrambler
    Moderator

    After you click on the edit pencil and you see the gear, if you hover your mouse on the gear icon, does the cursor change into a hand and a popup saying link option shows up?

    and when you click on it this is what should open up

    If that does not work, you may want to try and deactivate ALL plugins except for the weaver one and the classic editor one.

    Also you may want to remove the classic editor plugin and reinstall it.

    Last you should ask the Classic editor plugin people

    #65473
    LorSmi
    Participant

    Yes, that pop-up box is what I USE to see, but not anymore. When I click on the gear, nothing happens. I’ll try uninstalling and reinstalling the Classic Editor and if that doesn’t work, I’ll try them.

    Thanks for your help!

Viewing 16 posts - 1 through 16 (of 17 total)
  • You must be logged in to reply to this topic.