Home Forums Weaver Xtreme Theme Language mixture mess in Weaver admin panel

Topic Resolution: Resolved
Viewing 16 posts - 1 through 16 (of 21 total)
  • Author
    Posts
  • #65353
    kiezels
    Participant

    Hi,

    I just updated to the newest version of the theme (4.3.9), but now the language of the Weaver admin panel is a mess: a mixture of English and Dutch (site language). I’m sorry to say, but I am not happy with this. And like you say here https://guide.weavertheme.com/using-weaver-in-your-language/ the admin panel is strictly in English. Now I have difficulty in finding things since I have been working with your theme for quite some years. What happened? And how can I change everyting back to English (apart from setting the site language to English, which I don’t want).

    Hope you can help.

    Kind regards, Anita


    Moderator’s note: one way to solve this particular problem is;

    First, set the SITE language to Netherlands (or whatever langauge).

    Second, set your own personal PROFILE language to English.

    The frontend viewer side will display in NL, the backend admin stuff will be in EN.

    You could even create yourself a couple of logins with different profile languages to see the backend in multiple languages. But the site will only support one language.

     

     

    #65361
    scrambler
    Moderator

    This is strange, @weaver will have to comment on that.

     

    #65362
    scrambler
    Moderator

    If you cannot wait until weaver comments, you can download the previous version from wordpress with the link below

    https://downloads.wordpress.org/theme/weaver-xtreme.4.3.8.zip

    #65365
    Weaver
    Keymaster

    Any translation issues on the Admin side have nothing to do with the theme, but with how the WP translations have worked for the past couple of years. We’ve done absolutely nothing to produce any translations for the admin side, but by some mechanism or other (which I frankly do not really understand), translation files for various themes and plugin appear like magic. I think there are people who do translations, and submit them. Once the number of translated strings pass some threshold I think they are automatically served by WP as part of the normal update process. So, apparently someone has done a partial Dutch translation that is now being automatically provided by WP.

    I don’t know if there is any option to stop that – perhaps a plugin? I’m not sure where the translations get downloaded to your site, but they are probably somewhere and could thus be deleted – but the issue would be to stop theme from being auto-downloaded again.

    I would not have necessarily thought it was an issue, but I could see how it could be confusing to have some translated, and some not translated. You might post on the general WP forum to see if anyone has anything useful to say about this issue.

    It is possible that the contributed translation of for a previous version of Weaver. It is not all that uncommon to tweak the Customizer interface wordings, or add new options, or whatever, and so I would expect a few to not translate every now and then, Translations are done strictly on a match basis – so if the wording in the original version (English) changes, there will not be a matching translation. Same for untranslated parts – no match, no translation.

    I even think there is a translator site where one can see how complete translations are for various themes and plugins. I’ve never actually done anything there, but simply have been very careful to not change any of the viewer side wording so that the translations included with the theme will continue to work.

    #65370
    kiezels
    Participant

    Thanks for your elaborate answer @weaver, I’ll see what I can find. Nobody else here mentioned this issue?

    #65371
    Weaver
    Keymaster

    No other mention of it. I was trying to find an issue on a non-English site a few weeks ago, and had admin access. I did notice that the Customizer had mixed English and German, I think. That was the first time I personally knew about the new-ish auto translation loading with incomplete translations.

    #65372
    Weaver
    Keymaster

    Just found a relevant link. WP thinks that Dutch has been 100% translated, and has a version for Weaver Xtreme 4.3.9.

    Here’s a link:

    https://translate.wordpress.org/projects/wp-themes/weaver-xtreme/language-packs/

    I need to find out how to contact the main editor for the translation, who lists Weaver Xtreme as their favorite. Will try to follow up.

    #65374
    Weaver
    Keymaster

    I’ve sent an email to the Dutch translation editor to let them know about this issue. Obviously, with Weaver 4.4 coming out soon, and then Weaver 5 in a few months, this will be a much bigger problem as a whole bunch of wording has been changed in the Customizer interface, which will result in many more mixed strings.

    But I believer that the translator will want to get things synched up.

    There are apparently a few other full Weaver Xtreme translations available for other languages that will obviously have this issue.

    #65375
    scrambler
    Moderator

    @weaver, did you find out how you can stop the translation from being used?

    #65376
    Weaver
    Keymaster

    I tried pretty hard, but could not find a way to stop that yet.

    #65377
    Weaver
    Keymaster

    I tried pretty hard, but could not find a way to stop that yet.

    #65378
    Weaver
    Keymaster

    I just switched my site to Netherlands as the language, and it only changed the visitor side translations, as well as core WP Admin languages. The Weaver Xtreme admin languages stayed in English.

    So, @kiezels, are you seeing NL language on your Customizer? Just where is the mix of NL + EN?

    If that is the case, then there must be some plugin that is loading the WP translations over the theme’s translations (which are included in with the theme, and have been constant for many years).

    #65379
    ealvarez
    Participant

    I have updated to the latest version of Weaver (4.3.9) and no problems of language for me. All is in French (as it should). I have WordPress 5.4.2.

    #65382
    kiezels
    Participant

    Hi @weaver, I have WP 5.5.1–nl_NL installed, with Weaver 4.3.9.

    The Customizer is correctly and completely in Dutch, in Weaver I have a illogical mixture of English and Dutch. E.g. sometimes ‘inherit’ is in English, sometimes in Dutch ‘overnemen’. See screenshot 1. Even within one dropdown menu the two languages are mixed, see screenshot 2.

     

    Screenshot 1

    Screenshot 2

    #65385
    MMWBAdmin
    Participant

    Hi Weaver,
    you contacted me through Slack and email about this issue. As I contributed quite some translations for this theme the 90% threshold was reached. That probably resulted in the current situation…

    A quick & dirty solution is to rename or remove the language files weaver-xtreme-nl_NL.mo and weaver-xtreme-nl_NL.po in /wp-content/languages/themes/   (only one of them suffices, never know which one)

    Another solution might be that I bring back the percentage of translated strings of text below the 90% threshold. Though I’m not sure the language files will then disappear (whether it’s reversible)

    A more drastic solution from your side would be to ‘disable’ localization as with Weaver Show Sliders and Weaver Show Posts:

    This plugin is not properly prepared for localization (View detailed logs on Slack). If you would like to translate this plugin, please contact the author.

    This would of course affect all language packs.

    As we exchanged I hope there is or will be a solution where the user can opt-in for localization. Perhaps an existing plug-in will come to the rescue.

    #65386
    Weaver
    Keymaster

    OK – I believer I see the specific problem.


    @kiezels
    has been describing an issue with the Weaver Xtreme Theme Support plugin, which is almost certainly not included in the full @MMWBAdmin Weaver Xtreme translation.

    So I don’t think there should be any changes to that translation.

    And the mixture is coming from the way translations are done – a string is passed to the translation function, which then uses that string as an index into the translation table. If it is found, then the translation is provided, otherwise the orignal English string will be used. So, since there is no translation for the Legacy Interface (and that seems fairly unlikely to ever happen), you get the mixture. Some of the legacy strings will happen to match the Customzier strings, but most won’t.

    Over time (very low priority), we could try to be sure the Legacy interface uses the same strings as the Customizer, but there will always be some differences. But getting the dropdown choices to match should not be that hard. But for now, my goal is to have a quite different “fix”.

    Weaver Xtreme 5, probably 3 or 4 months away, will have a new feature that will give the choice of the current “What” interface (Color, Style, etc.) and the legacy “Where” interface (Header, Menus, etc.). This will likely solve most of the issue, which may come up for other languages as well.

    I believe that MMWBAdmin’s suggestion of deleting the WP generated files in /wp-content/languages/themes/ will result in using the translation files included with the theme directly, this will put the Customizer and parts of the legacy interface back to English while leaving the visitor side translated.

    I suppose there also may be filter used by WP core to fetch the translation files that could be provided by the theme to force it to the theme’s translation files. Will look into that.

    But for now, I don’t think there’s much to be done other than manually deleting the WP language files.

    Certainly to not want to pull back on the translation done by MMWBAdmin and that team.

    I guess what I don’t understand is why I wasn’t seeing the WP NL files when I changed to NL on my test site. Maybe it takes WP a while to notice and update the translation files.

Viewing 16 posts - 1 through 16 (of 21 total)
  • You must be logged in to reply to this topic.