Home Forums Weaver Xtreme Theme Issues after applying version 5.0.1

Viewing 16 posts - 1 through 16 (of 17 total)
  • Author
    Posts
  • #69976
    laura
    Participant

    @weaver

    Hi,

    After applying version 5.0.1, I am still having an issue with a weaver site.

    There’s a couple of lines of css code that is appearing above the header section. Is there a way to get rid of that?

    Also, there is the site background image which is showing normally, but there is also a site background color that is supposed to show through it, but it is not.

    Here is a link to the site:
    clientswebdesigns.com/blog

    There is a link a copy of the site before V5 was applied. It is not an exact copy, but it will show you how it should look:
    clientswebdesigns.com/blog13

     

    Thank you so much.

     

     

     

    #69981
    Weaver
    Keymaster

    I’m a bit puzzled. The CSS you see at the top.

    It is coming from some Custom CSS box somewhere, but I can’t figure out where. It is possible it is a setting from several versions ago of Weaver Xtreme. The CSS is actually found in the page source as:

     

    <!-- Add your own CSS snippets between the style tags. -->
      #colophon { padding-top: 15px; padding-bottom: 15px;
     text-align: center; font-style: normal; font-size: 11px; }
     .entry-content {padding-top: 10px;}
    

     

    Note that there is NOT <style>…</style> now being added. And I can’t find anywhere in the theme, theme support, or Weaver Plus that has the phrase about adding the CSS between the <style> brackets. I do seem to remember having that somewhere at some point, but it isn’t found anywhere now. Do you know where that is coming from? Which option?

    There is some chance that V5.0.2 may fix that, but I just don’t know.

    #69982
    laura
    Participant

    It seems to relate to the footer styling.

    #69991
    scrambler
    Moderator

    @weaver, I see the error below in the console, and am wondering if it could be contributing to the issue

    Failed to load resource: the server responded with a status of 404 ()

     


    @laura
    , given there were a few hiccups in the v5 update, you may want to tray the following.

    • Revert back to 4.4.8
    • Update the Xtreme Theme support plugin to its latest version.
    • Redo the v5 update to the latest version.
    • Clear ALL your caches (plugin, cloudflare, browser….)
    • Go in Appearance > Xtreme Admin > main Options and click “Save Settings” to refresh everything.

     

    #69998
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #70003
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
    #70004
    scrambler
    Moderator

    The error was in edge, but is no longer there.

    I still see it in Chrome, and it seems to just be about the favicon

    /favicon.ico:1 Failed to load resource: the server responded with a status of 404 ()

    #70007
    Weaver
    Keymaster

    I can see this, too, and note that there is no favicon shown on any site. This is like an issue with the site not properly have the favicon set with the somewhat new WP built-in options.

    #70024
    Private Reply
    laura
    Participant
    This reply has been marked as private.
    #70062
    Weaver
    Keymaster

    OK, I seem to have found the issues.

    1. The CSS. That was incorrectly placed in the Advanced Options : Head Section box. I believe at one point, it would have been allowed by the Theme to add that CSS there, but HTML standards say that no <style> blocks are allowed in the <head> section, and Weaver Xtreme V5. now enforces that (but not perfectly). What happened is that Weaver Xtreme V5 stripped the <style> … </style> tags that were there, and thus the CSS shows up. I moved those rules to the Custom CSS block where it actually belongs, and that fixed it, plus the custom CSS now works.
    2.  The dim background image is the result of another change in V5 that in the pre-V5.0.4 versions improperly tried to ignore the WP core default background color setting, which has been removed from WP official support. That got fixed in the as yet un-released V 5.0.4 version. I did upload it to your /blog site, and that fixed the issue. (Use of that option seems to date back to older websites. I see your site was actuall converted from Weaver Xtreme II. I also discovered a similar issue with that option on one of the older sites I have which led to the fix just earlier today!)

    At his point, you might want to revisit the Customizer settings as they now include a ‘Where” view that closely follows the organization of the old Legacy interface. Due to improvements in the WP Customizer implementation, it has gotten MUCH faster that it was a couple of years ago, and is quite usable, especially in how it shows the effects of the changes either immediately, or after a fast refresh of the page/post being edited.

     

    #70068
    Private Reply
    laura
    Participant
    This reply has been marked as private.
    #70069
    scrambler
    Moderator

    Weaver said you had put the CSS in Advanced options > Head section.

    Normally when you do that, you have to include the CSS within Style tags, which apparently get stripped with the new release, only leaving the CSS which is invalid in that section.

    If so, go there, cut the CSS and put it in the theme Global Custom CSS Rule box

    #70070
    laura
    Participant

    @scrambler

    Thank you so much. I got it working.

    At first, I got confused – I went to the css in advanced options > head section, but I didn’t see the code there at first because the window was so narrow that it didn’t look like there was anything there except where it says, “<— Add your own css snippets between the style tags—>” but then I grabbed the lower right corner of the section and dragged it down revealing the code. So I cut and pasted it into the Global Custom  CSS Rule Box. So everything is ok now.

    So now I’m just waiting for the release of V5.0.4 to resolve the background color issue.

    #70071
    scrambler
    Moderator

    Below is a post from someone who fixed it until then

    Lost background color upon recent update – Weaver Support Forum (weavertheme.com)

     

    #70072
    Weaver
    Keymaster

    I updated your site to 5.0.4 already.

    #70090
    laura
    Participant

    @weaver

    I had a couple of other sites where I had lost the background color and I was able to get them back by creating a CSS rule in the Global Custom CSS rule box:

    body.custom-background {
    background-color: #087ea8 !important;
    }

    This worked but, should this only be considered a temporary fix until V5.0.4 comes out?

Viewing 16 posts - 1 through 16 (of 17 total)
  • You must be logged in to reply to this topic.