Home Forums Weaver Xtreme Theme Image Issues

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #61918


    I was hoping someone could help me. I have two problems with the images I upload into WordPress:

    1. When I upload a picture with a “transparent background” the background ends up not being transparent at all but black.
    2. Every image I upload has a black border around it and I don’t always want that either

    Is there an easy way to fix this?

    Thank you!



    1- What format are you using. The one that I know works is .png. Also if you have an image Border setup in the theme that will make the image background black.

    2- Where do you see the border, in the media library, or when you use it on the site. If the later, you may have a border setting in the theme options.

    For both issues, post a link to a page showing the image with the problem (black transparency and border) so we can be sure.

    But it looks like you have an image border setup in the theme (Main options > Content Areas > Images > Image Border color and width)



    Thanks for your response. It does sound like an image border setup issue then… Here’s a link to a page that has border outlines in the opt-in form where there shouldn’t be any. (Both jpg and png images turn out the same way)


    And here’s a link to a page with the transparency issue (The profile picture at the beginning is supposed to be a circle with transparent background, but instead looks like a circle in a black background)


    When you say Main options, do you mean within the theme’s customizer? Because there isn’t a “Content area” option there that I can see.

    Thanks again for your help.




    Yes , you have a 1px black border setup.  because these are actually done using a background color and padding, you also get a black background on transparent images.

    The place I gave you for the setting is in the Legacy admin ( Dashboard > Appearance > Weaver Xtreme Admin > Main Options > Content Areas. > Images

    You also have the setting in Customize > Images > GLobal Image settings


    Thanks for your help – when I put a 0, the black border went away but the transparent images still look like they’re on a black square. How can I fix this?

    Is there a way to leave the border for non-transparent images?

    Thanks again.


    can you clear all your caches (plugin, browsers…)

    Because right now I still see the Border settings as active

    Also make sure to remove the content of the Image Background color box

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.