Home Forums Weaver Xtreme Theme Image HTML Replacement Displays Shortcode

Topic Resolution: Resolved

This topic contains 13 replies, has 2 voices, and was last updated by  edtiley 1 week, 5 days ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #59864

    edtiley
    Participant

    Wishing to put a slider on the home page only, I put the shortcode [metaslider id=”2636302″] into the Header Image section in the field labeled Image HTML Replacement and checked the box to display only on the front page.

    Works quite nicely. However, the shortcode is now displayed on every page of the site.

    https://infocusapparel.com

    Have I screwed up somehow or is this a “feature?” <grin>

    How do I suppress this display of the shortcode?

    #59865

    scrambler
    Moderator

    The shortcode appear to be inserted at the top of the body tag before the wrapper…

    I have no idea how you managed to do that as I dont know of a weaver option allowing you to do that 🙂

    Can you think of anything you did while attempting to insert the shortcode in various places?

    #59866

    edtiley
    Participant

    I only inserted the shortcode in one place!

    So it’s a feature!

    #59867

    edtiley
    Participant

    I just did a search on the database and the shortcode was found in only one table (wp_options) in one place.

    #59868

    scrambler
    Moderator

    A shortcode inserted in the header image HTML replacement does not show there (at least for me).

    To be sure, remove the shortcode from the header image HTML replacement and see if it also disappear from the top as text.

    also, paste here the version of the theme as well as weaver plugins you are running

    #59869

    edtiley
    Participant

    Oh dear!

    We has met the enemy and they is us! – Pogo

    I don’t know how better search replace missed it, but I did find a second copy of the shortcode in the advanced options>head section

    Remove it and all is well.

    Bruce’s reputaion for pristine meticulous code remains intact! It’s not a feature.

    Thanks,

    Ed

    #59870

    scrambler
    Moderator

    I will need to double check the head section then, because when I looked it was not in the head but in the body, so there may be a bug after all 🙂

    #59871

    edtiley
    Participant

    LOL

    It’s at least in an area where the shortcode is text and not executed.

    #59872
    Private Reply

    edtiley
    Participant
    This reply has been marked as private.
    #59873

    scrambler
    Moderator

    @weaver, I can confirm that when adding content to the Advanced Options > Head section (either of the two), the content ends up at the top of the Body tag not the head tag.

    Is that normal?

     

    #59874
    Private Reply

    scrambler
    Moderator
    This reply has been marked as private.
    #59875
    Private Reply

    edtiley
    Participant
    This reply has been marked as private.
    #59876
    Private Reply

    scrambler
    Moderator
    This reply has been marked as private.
    #59877
    Private Reply

    edtiley
    Participant
    This reply has been marked as private.
Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.