Home Forums Weaver Xtreme Theme I want to get rid of the primary (left) and secondary (right) sidebars on my product page

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #17567
    Anne
    Participant

    I tried to change settings all over my site to state full width, no sidebar, etc  and there are countless suggestions on various forums but nothing works… Please could you have a look at my website at http://getmarketed.co.za and let me know what to do.

    #21097
    Weaver
    Keymaster

    First, you have some stray CSS you tried to enter somewhere that is showing at the top of the page. I can’t figure out how you’ve done that or where it is.

    But, it sounds like what you need is the Per Page Sidebars & Widgets layout option found on the Per Page Options box found on below the content window on the Page editor for each page. It is not any more difficult than selecting a sidebar arrangement for each page that you want to be different than the site default.

    The only difference is the Home (blog) page. You are using the default WordPress blog page. That page is not editable, nor subject to ANY of the per page options. It will be displayed using the default Weaver site page settings. If you want custom control of the home page, you need to switch it to a Page with Post page template. Then follow the instructions on this FAQ: http://weavertheme.com/controlling-your-home-page/

    #21098
    scrambler
    Moderator

    You really don’t give us much details about what you want or tried.

    if by full width you mean no sidebar, there are global settings for sidebar configuration in Main options > layout & Sidebar, and local settings in each page editing page.

    If you also mean extend background or content to the edge of the browser, read the thread below.

    http://forum.weavertheme.com/discussion/11124/full-width-designs

    Beyond that you need to be a lot more specific and explain exactly what you want to do / change on a specific page

    #21099
    Anne
    Participant

    Hi Weaver and Scrambler

    Sorry I did not supply much info in my question. I have to hand in an assignment at 10 this morning (South African time) and was in a bit of a state. I also realize that due to the time difference, you are probably sleeping now and so I might not get an answer in time. I managed to sort out the sidebar issue by changing the width in the Theme Options>Sidebar & layout. You will also see that I have an awful Products Tags format at the top of the page. We are required to create a tag cloud by inserting a shortcode into the page. I have used the Woocommerce Product Tags widget which I cannot seem to customize. I look forward to your speedy reply.

    #21100
    Anne
    Participant

    Hi again

    As I could not get rid of the Products page title showing in the Products page content, I set the text colour to white “FFFFF. Not ideal I know but even though I checked the Hide page title box, it still appears?? Any suggestions?

    #21101
    scrambler
    Moderator

    If by your product page you mean
    http://getmarketed.co.za/products-2/

    This is does not appear to be a regular weaver page, but an archive page and it appears to be a woocommerce page, I am not sure if woocommerce gives you ways to remove the title.

    If you created that page using a static page, you may be having a WordPress conflict where wordpress shows a different page, this happens when pages have the same name as other things like category, images, posts etc….

    You have to use different (unique) names to avoid this kind of problems, or at least edit the permalink to make it different at the top of the page.

    If this is really the page that should be shown (archive not a created static page) we could hide its title by adding the custom CSS below in Main Options > Fonts & Custom > Custom CSS rule box

    .post-type-archive-product .page-title {display:none;}

    #21102
    Anne
    Participant

    Hi scrambler

    Thanks for your response. Yes, it is a woocommerce page and I renamed the page from Shop to Products. I think it defaults to an archive page (for whatever reason), not my doing and didn’t knowingly create it as a static page. Also not sure why it has the permalink /products-2 and when I try to change it to just /products it changes back and will not accept it. 

    I tried inserting the custom CSS which you suggested but that doe not solve the problem. The only thing that works is changing the text color to “FFFFFF which then gives a blank space on top of the page…

    Regarding using the same Products name in categories, posts, etc I just checked and they are not the same. I have made so many changes that I am afraid I have got myself into a confusing loop…

    #21103
    scrambler
    Moderator

    if the permalink is being renamed it is probably because there is a page with the same permalink in the trash.

    I don’t know anything about woocomerce, but if they give you their own page editing page and the options in that page don’t work, you should probably ask them.

    Try adding !important to the rule I gave you

    .post-type-archive-product .page-title {display:none !important;}

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.