Home Forums Weaver Xtreme Theme I can remove arrows on nav bar but not the space they have created

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #17409
    robfoster
    Participant

    Hi
    I have removed the arrows from my nav bar in Xtreme admin, but i want to remove the space that is created by the arrows which is still there.

    could anyone assist?

    Thanks

    http://www.robfostermusic.co.uk/

    #20144
    scrambler
    Moderator

    I still see the arrows on IE, so what exactly did you do?

    #20145
    scrambler
    Moderator

    Indeed it looks like the right padding of menus with sub menus is increased from the 0.75em default to 1.5em to make a space for the arrow, and is not chnaged back when the arrows are hidden.

    @weaver would have to confirm if it is normal that the padding used to create a space for the arrow is not removed when the hide arrow option is used

    In the mean time, to remove the right padding meant to create the space for the arrow when the hide arrow option is checked use the rule below

    .menu-hover.menu-arrows .has-submenu > a {padding-right:0.75em;}

    If you use the arrow on some menus and not others, add the menu style class

    .menu-primary .menu-hover.menu-arrows .has-submenu > a {padding-right:0.75em;}

    @weaver, I see the rule includes a class .menu-arrows which makes me think this class is only meant to be present on the menu ul tag if the menu has the arrow option on, so could it be a bug that when checking the hide arrow option, that class should be removed from the menu ul tag but is not ?

    #20146
    robfoster
    Participant

    thats done it !

    #20147
    Weaver
    Keymaster

    If I remember right, the problem has to do with the arrow stuff really being handled by the Mobile Menu script, and removing any of the menu-arrows classes would then break the mobile menu.

    But adding the new rule you found may be a workable alternative. I will check that out.

    #20148
    Peter
    Participant

    Hi, same problem, submenu arrow turned off but space is still there. Is the above solution still the way to solve this? Tried it but didn’t seem to remove the space?
    http://myamiko.net/kkkkk/

    #20149
    webdzign
    Participant

    Peter, When I first tried it, it didn’t work, either. But when I added an “important” statement it worked.

    .menu-primary .menu-hover.menu-arrows .has-submenu > a {padding-right:0.75em !important;}

    Thanks, Scrambler!
    Hope this helps.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.