Home Forums Weaver Xtreme Theme How to show featured image thumbnail in the sidebar?

Topic Resolution: Answered

This topic contains 29 replies, has 3 voices, and was last updated by  scrambler 4 hours, 4 minutes ago.

Viewing 14 posts - 17 through 30 (of 30 total)
  • Author
    Posts
  • #55736

    scrambler
    Moderator

    Your title text still looks big 🙂

    #55737

    GeorgeW
    Participant

    Noted, and fixed. 🙂

    Thanks!

    George

    #57505
    Private Reply

    GeorgeW
    Participant
    This reply has been marked as private.
    #57506

    scrambler
    Moderator

    Your rules were meant for a filter named default

    The new site uses a filter named title-featured-image, so you need to change all your rules to reflect that

    .atw-show-posts-filter-title-featured-image article > span {display:flex;flex:0 0 25%;order:1;margin:0 3% 0 0;}
    .atw-show-posts-filter-title-featured-image .featured-image {float:left;width:24%;margin:0 3% 0 0;}
    .atw-show-posts-filter-title-featured-image .entry-header {float:right;width:73%;}
    .atw-show-posts-filter-title-featured-image .entry-header .post-title {font-size:0.8em;}

    Once that is corrected, then we can check it there are other issues

    #57507
    Private Reply

    GeorgeW
    Participant
    This reply has been marked as private.
    #57679
    Private Reply

    GeorgeW
    Participant
    This reply has been marked as private.
    #57685

    scrambler
    Moderator

    The site with the wrong style does not have any active custom CSS to fix the sizes.

    The problem comes from the fact that I don’t see a class with the filter name in the show post HTML which means your rules don’t apply.

    So something is going on that makes the show post output be incorrect. Check if you don’t have some bad character in the name of the filter in the creation page, and if you inserted it with a shortcode, check there too.

    You may want to redo the Show post filter with a specific name to see if that fixes it

    Adding a border can be done by adding the rule below, replacing name by the filter name
    .atw-show-posts-filter-name .post {border-bottom:1px solid black;}
    If you want some space under the image add padding to the rule
    .atw-show-posts-filter-name .post {border-bottom:1px solid black;padding-bottom:10px;}
    #57693

    GeorgeW
    Participant

    Note: I have posted a reply twice, but it didn’t come through. Maybe because I posted code. Let’s try again.

    Hi, scrambler!

    Thanks for the border tip, it works great!

    I just created a new filter called “new.” I’m adding it in the sidebar via the Weaver Show Posts widget and select the filter from the provided drop-don menu (so, I’m not typing anything). This was exactly what I was doing before.

    Under:

    Apperance ==> Weaver Xtreme Admin ==> Main Options ==> Fonts & Custom ==> Custom CSS Rules

    …I have entered and saved the CSS for both filters as follows:

    https://imgur.com/a/OzzXoWV

    The issue persists.

    Any other possible reason why the CSS code doesn’t get applied?

    Thanks!

    George

     

    #57697

    scrambler
    Moderator

    The class with the filter name on the show post container is still missing so rule wont be applied

    Are both site on WP 5.01?

    Any plugins difference.

    Clear all your caches

    #57719

    GeorgeW
    Participant

    Hi, scrambler!

    Both sites are on WP 5.01.

    Plugins are identical.

    Cache has been cleared. Issue persists. Same if I visit the website from my smartphone.

    🙂

    George

    #57720
    Private Reply

    GeorgeW
    Participant
    This reply has been marked as private.
    #57722

    scrambler
    Moderator

    I created a new filter called test and it works, the HTML has the right class so the edited rules work

    No idea what happened with yours, I deleted the new filter.

    Let me see if it happens again

     

    #57724

    GeorgeW
    Participant

    scrambler…

    Your “test” filter was still in the website, and yes it did work.

    After doing some detective work, I realized the reason the initial default filter wasn’t working was because the option “Display posts as:” was blank, instead of showing “Title + Featured Image.” No idea how this hapenned, since I cloned another website that had this setting correct, and then built this new website on that (didn’t mess with the filters at all). Oh, well!

    Anyway, in the future I should be able to handle this.

    Thanks for all the help – I appreciate it!

    George

    #57725

    scrambler
    Moderator

    Thanks for reporting the finding, this is an interesting quirk in @weaver code 🙂

    But given it does not correspond to a normal usage probably not worth chasing.

Viewing 14 posts - 17 through 30 (of 30 total)

You must be logged in to reply to this topic.