Home Forums Weaver Xtreme Theme How to fix a preview image so it shows up in excerpts of posts?

Viewing 16 posts - 1 through 16 (of 27 total)
  • Author
    Posts
  • #71074
    douglerner
    Participant

    This is my personal blog at https://lerner.net. As you can see most of the posts have preview images. And they usually show up in the excerpts.

    But the one I just posted: https://lerner.net/a-summers-day-visit-to-asakusa/ doesn’t show the preview image in the excerpts. It does in the post though. I suspect because it’s too large.

    Is there some setting I can change to make sure the preview is shrunk enough to show up in the excerpts? Or if the image needs to be resized, what does it need to be? Or is it something else?

    I know people have been telling me to upgrade from my now obsolete (but still working) Weaver Pro theme. But for the life of me I can’t find a theme that includes something as basic as header images. My site has a header image and I would like to keep it.

    Thanks.

    p.s. I’m posting here because it says you are still supporting this theme.

    #71075
    scrambler
    Moderator

    First Make sure your Blog page is not the default WordPress blog page, but a weaver page with posts, as none of the theme options work on the default WP blog page.

    You blog page should be created by creating a page, and selecting the Template “page with posts”

    Then in WP Settings > Reading:

    • “home page display” should be set as a Static page
    • The Blog page you created above should be selected in the Homepage Dropdown list
    • and Nothing should be selected in the “Post Page” Dropdown list (showing –select–)

    If that is correct, check the Post editing page of the post with the missing featured image, and in “Weaver Xtreme Options for this page” > Post Blog / Archive options TAB > Post Blog / Archive View: Featured image set to “Default Bog FI”

    #71076
    douglerner
    Participant

    Thanks for your reply.

    All the blog posts were created the same way, using what I think is the standard New Post feature at the top of the WP site. Does that mean it’s created in a way that’s incompatible with Weaver features? Going back years now, that’s the only way I’ve created new blog posts.

    And the Home Page display is not set to static page, it’s set to be “latest posts.”

    Isn’t that what I want? To always automatically show the latest posts?

    All the other blog posts except this one are showing the preview image in excerpts. And even this one is showing the preview in the post itself.

     

     

    #71077
    Weaver
    Keymaster

    You seem to have set the featured image of that last post to display as a header replacement. Note how it shows up in the header when you open the post.

    #71078
    douglerner
    Participant

    Hmm… You appear to be right. But… where is that set? I don’t even see a setting for replacing the header with a featured image. I didn’t even know that was possible. 🙂

    #71079
    scrambler
    Moderator

    Two things

    1. I was not talking about the way the Blog posts were created, but how the Blog PAGE is created.
      If the Blog Page is the default WordPress, then none of the theme settings will work on it. I told you how to check that, did you?
    2. For your last question, I told you how to check if the Featured Image for a specific post is set properly, it was the last paragraph of my post

    “check the Post editing page of the post with the missing featured image, and in “Weaver Xtreme Options for this page” > Post Blog / Archive options TAB > Post Blog / Archive View: Featured image set to “Default Bog FI””

    #71080
    Private Reply
    douglerner
    Participant
    This reply has been marked as private.
    #71081
    scrambler
    Moderator

    OH, my bad for missing that you are on weaver II Pro. This theme has been obsolete for many many years now, and I have no recollection of the specific options for each post….

    That said, if there is an option “Show featured image for this post” and it is unchecked, then it is worth trying to check that. You should also try creating a new post with a featured image, and see what happens, in case the issue is with the last post.

    But you should really consider upgrading to Weaver Xtreme which is the current theme, if nothing else for security reasons….

    Below is the conversion process.

    Converting a Weaver II (Pro) or Aspen site to Weaver Xtreme – Weaver Xtreme Guide (weavertheme.com)

     

    #71082
    douglerner
    Participant

    I’ll take a look. On the main site it does say Weaver II is at least being supported and pointed me to this forum, which is why I posted here. But I’ll take a look. Thanks.

    #71083
    scrambler
    Moderator

    We cross posted, so re check my last post for some update

    #71084
    douglerner
    Participant

    I did try checking that item just in case, even though it’s not checked for previous posts. But it didn’t seem to make a difference. Right now it’s the only post with a preview image set where it’s not showing up in excerpts.

     

    #71085
    scrambler
    Moderator

    So if you create a new post that new post shows the featured image?

    If so Have you tried recreating the problematic post with a different featured image?

    #71086
    douglerner
    Participant

    Even if I temporarily replace the featured image with, say, the featured image I was using in a previous blog post it all looks normal, both on the blog post page itself and on the home page in excerpts.

    I think it must have something to do with the size of the featured image. But I don’t know what limitations there are on that.

     

    #71087
    scrambler
    Moderator

    The size should not be an issue as it is changed any way for the post.

    But there may be something wrong with the image format. You can try loading it in an image editor and saving a new copy as Jpeg

    #71088
    douglerner
    Participant

    I believe it was the size of the image. I tried what you said but it didn’t make a difference. It was already JPEG.

    Then I scaled the copy I uploaded to just 400 wide and saved it and now, as you can see at https://lerner.net it shows up fine in the home page excerpts. It also shows up normally in the post itself at https://lerner.net/a-summers-day-visit-to-asakusa/ except for a minor thing: the “sharing” text for the sharing icons is to the right of the image instead of above the sharing icons.

    So I guess the size does make a difference.

     

    #71089
    scrambler
    Moderator

    Strange.

    You still need to upgrade 🙂

Viewing 16 posts - 1 through 16 (of 27 total)
  • You must be logged in to reply to this topic.