Home Forums Weaver Xtreme Theme How do I make a sticky menu that matches my Art Store Fronts shop?

Viewing 16 posts - 17 through 32 (of 51 total)
  • Author
    Posts
  • #66229
    MaryAhern
    Participant

    I deleted the Weaver II Theme Extras from my plugins.

    I reactivated all my other plugins.

    I think I added the text to the Primary menu Background color box.

    See screenshot: https://1drv.ms/u/s!AtqjCG3cfn5yiE5Jxk4pzfwet2Z4?e=PaQVFQ

    I removed the custom CSS you gave me. (My logo is now to the left of the menu too)

    I haven’t yet don’t the suggestions in the second post since I figured you’d want to see this first.

    Thanks!, …mary

     

    #66232
    scrambler
    Moderator

    No I did not say the menu bar custom CSS, I said the menu bar Background color box.

    Remove what you put in the menu bar CSS box as it is invalid, and go to

    Customizing ▸ Colors > Menus > Primary menu bar BG color > Click select color

    • Select the white
    • Scroll the transparency bat all the way to the left, that should display: rgba(255,255,255,0) Inside the color box.

    If the box closes, you can click again on select color to see that it is indeed there.

    Given you are using the customizer and in case there is a problem with setting not saving properly, next do the following.

    go to

    Customizing ▸ Layout > Menus

    and under Fixed Top Primary menu, verfify if it says “Fixed to top on Scroll”

    If it does not, then select it in the drop down list, and publish.

    Then exit the customizer

    Then go back in

    Customizing ▸ Layout > Menus

    and check if “Fixed to Top on scroll” is still selected and post back to confirm every steps result.

    Please follow all these steps exactly so we can see if there is a problem with some options not saving.

    #66233
    MaryAhern
    Participant

    I removed the incorrect placement of the Transparent White on the Primary menu.

    I added the rgba white to the menu bar via customizer.

    Verified that “Fixed to top on Scroll” was selected. Exited customizer then checked again and it had been and still is the selection.

    Also looked at the settings in the Weaver Xtreme Admin & they show up there as well.

    …mary

     

    #66234
    scrambler
    Moderator

    Well, the bad CSS is still there, and the background color is not in.

    Are you using a cache program like a plugin or service like cloudflare?

    If so can you clear the cache and deactivate the cache plugin / option?

     

    #66237
    MaryAhern
    Participant

    I cleared the cache and deactivated the W3 Total Cache plugin.

    I checked and the correct settings seem to be in place.

    Check these screenshots:

    https://1drv.ms/u/s!AtqjCG3cfn5yiE_xymPhd2dhYddl?e=dbhuaa

    https://1drv.ms/u/s!AtqjCG3cfn5yiFCjaZJ5EIfWeXl8?e=LMz30L

    …mary

     

    #66240
    scrambler
    Moderator

    Thank you, the BG color is now active, so keep the cache deactivated.

    Instead of checking the fixed on scroll setting in the legacy admin, can you check it in the customizer and see if it shows up there too? in

    Customizing ▸ Layout > Menus

    and check if “Fixed to Top on scroll” is still selected and post back

    #66241
    scrambler
    Moderator

    If the fixed setting is also good In the Customizer, then go ahead and do the delete reinstall procedure below

    • Save your settings and download a copy locally for good measure from the Save / Restore page
    • Switch to a different theme
    • Delete all weaver themes an plugins.
    • Reinstall the Xtreme Theme and the Xtreme Theme support Plugin form WordPress and activate
    • All settings should automatically be back
    • Check if the Fixed to top on scroll is still selected in the primary menu options.
    • Check if the menu is fixed.
    • Download a fresh copy of the Plus plugin from your weaver account and reinstall and activate that
    • report back
    #66244
    MaryAhern
    Participant

    Saved my settings & downloaded them to my cptr.

    Switched to a different theme. Deleted all the weaver themes and plugins.

    Reinstalled Xtreme Them & support plugin & activated. All settings came back.

    Checked both the customizer & the legacy and the Fixed To Top on Scroll is still selected

    The menu is still not fixed.

    Downloaded a fresh copy of the Plus plugin. Reinstalled, activated it.

    The menu is not Fixed to the top on scroll on my desktop, Chrome, Firefox or Safari. Not on my iPad either.

    ..sigh..

    #66246
    scrambler
    Moderator

    This is driving me insane….


    @weaver
    , may be you can help on this, in case I am overlooking something.

    Site is https://maryahernartist.com/

    System info are in post #66224 earlier in the thread

    For some odd reason, we cannot get the Fixed to top on scroll option to work. It shows as selected, but it has no effects.

    • Other settings alike BG color, add logo to menu are working, but fixed to top on scroll is not
    • She deactivated her cache plugin.
    • She tried deactivating all plugins.
    • She tried deleting all weaver stuff and reinstalling…
    • I am not seeing anything in the console, may be you can think of what could be the culprit

    If you see anything or can think of something, it will be appreciated 🙂

    #66247
    scrambler
    Moderator

    @MaryAhern.

    • Are you by any chance using a child theme?
    • Have you by any chance installed a script that is calling its own javascript version?
    #66250
    MaryAhern
    Participant

    To my knowledge I haven’t used a “child theme” since I don’t know what that is.

    I don’t write code so I haven’t written any script.
    I had deactivated all the plugins which may have done some of what you’re asking but that didn’t correct the situation either.

    …mary

    #66251
    scrambler
    Moderator

    Let us wait to see if @weaver has an idea of else to do.

    In the mean time, can you try to set the menu too simply “fix on top”

    #66253
    MaryAhern
    Participant

    I changed the setting to “Fix on Top” and now it’s scrolling. At least it is on my iPad.

    I’ll do further testing soon.

    …mary

    #66255
    scrambler
    Moderator

    No point in more testing, we cant do what you want with just fix on top, as that just fixes the menu at the top all the time.

    It makes the issue even more crazy, as Fix on top works, but Fixed to top on scroll does not.

    It does make me feel like you have a javascript issue on that site, and if so, it could brake a lot more than just that.

    @MaryAhern, are you 100% sure you do not have an optimization plugin or option  that is active (there is one on jetpack I belive can you check Jetpack options for it?). If you have one, do deactivate it

    Can you switch back to fix to top on scroll.


    @weaver
    , how can Fixed to top setting work, but not Fixed to top on scroll??
    Can you see if there is a JavaScript issue.

    #66256
    Weaver
    Keymaster

    What I see now is the primary menu fixed to top (and that is how it is set!), and the secondary menu set to scroll-fixed, but there is no secondary menu.

    The fixed top settings can be seen in a bit of Weaver added javascript on line 166 of the HTML output.

    #66257
    scrambler
    Moderator

    @weaver, this is the last test she did, but the problem is that when she sets the primary menu to Fixed to top on Scroll, it does nothing, the option does not work.

    I believe the Fixed to top is just CSS, but Fixed to top on scroll involves Javascript, so if that does not work it would point to JavaScript not working, but I don’t know how to check that other than by looking at the browser console, and that does not show any errors.

    The only thing I can think of is js optimization, I have already asked her to check and to deactivate plugins without success. Can you see if one is running?

    EDIT, it looks like she put it back to “Fixed to top on scroll” Can you see if the option is active (although not working)?

Viewing 16 posts - 17 through 32 (of 51 total)
  • You must be logged in to reply to this topic.