Home Forums Weaver Xtreme Theme How can I stop WordPress from automatically adding code to my text?

This topic contains 18 replies, has 4 voices, and was last updated by  miamax 1 month, 3 weeks ago.

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #59717

    miamax
    Participant

    Wordpress is automatically adding code to the text I paste from Word (Home & Office 2016).

     

    What I paste:

    Plastic bubble wands can be used to blow bubbles that will glow under a blacklight. You get 11 assorted wands and a tray.

     

    When I publish, WordPress has added paragraph and tags:

    Plastic bubble wands can be used to blow bubbles that will glow under a blacklight. You get 11 assorted wands and a tray.

     

    How can I stop WordPress from doing this? I am using Weaver Xtreme Theme.

     

    Thanks for your help.

     

    #59718

    miamax
    Participant

    oops…

     

    What I paste:

    
    
    Plastic bubble wands can be used to blow bubbles that will glow under a blacklight. You get 11 assorted wands and a tray.
    
    
    

     

     

    How WordPress changes the code:

    
    
    

    Plastic bubble wands can be used to blow bubbles that will glow under a blacklight. You get 11 assorted wands and a tray.

    #59719

    miamax
    Participant

    Rats…

     

    I don’t know how to show you the code. Please highlight the above and choose “View Selection Source” to see the code.

    Thanks so much!

     

    #59722

    ealvarez
    Participant

    What about exporting first as .txt? Secondly, importing in WordPress.

    #59724

    scrambler
    Moderator

    I dont know what editor you are using (block or classic), but there is normally a tool you can select to paste as text.

    Trying to paste formatting from a text application is likely to fail with WordPress. You will need to do the styling using the WordPress editor.

    If you are inputing HTML, then you need to use an HTML block, or if using the Classic editor, Use the TEXT mode (not visual), and check the Page option “Allow Raw HTML and Script”, that will stop any WordPress formatting

    #59725

    Weaver
    Keymaster
    #59739

    miamax
    Participant

    I managed to paste as text, which went well.

     

    It turns out that it’s when I click “Update” that WordPress adds that extra code.

     

    #59740

    miamax
    Participant

    Well, I got it to work, and I’m pretty sure that it’s because I didn’t have a tag to close the link just above the problem area.

     

    It is annoying, however, that WordPress filled in that tag (which is great) but then added more tags around the next word.

    #59741

    scrambler
    Moderator

    If your HTML is bad, then you cant complain WordPress or the browsers tries to fix it (and they will) 🙂

    #59755

    miamax
    Participant

    I spoke too soon. I did make it sound like it was my error, I apologize for not checking that before posting on this board.

     

    However, after making sure that all tags were closed, I “pasted as text” and then published. The same thing happened. WordPress added more tags, which highlighted the first words that came before the link, making it look like that was a link (which it was not).

     

    My solution was to give up and remove the first words before the link. I made the first words the link, instead of having the link come later in the sentence.

     

    So it’s still a problem without an apparent solution, but I worked around it.

     

    Thanks for all your help, everyone!

     

    #59756

    scrambler
    Moderator

    Are you pasting HTML?

    If so, Are you using an HTML block (if using the block editor), or are you using TEXT mode of the classic editor AND checking “allow Raw HTML and Script” in the page options?

    #59757

    miamax
    Participant

    I’m pasting HTML using the Code Editor.

     

    I don’t see an “allow Raw HTML” option.

     

     

    #59758

    scrambler
    Moderator

    1) You are not answering my question about what editor you are using (Block editor or Classic Editor)
    By “Code editor”, do you mean you are using the Classic Editor in TEXT mode?

    2) When you are in your page editing page, there is a section Weaver XTreme 4 Options for this page

    In there there is a TAB called “Misc Options”

    In there is the “Allow Raw HTML and script” option

    #59763

    miamax
    Participant

    Wordpress image

    #59764

    miamax
    Participant

    I tried to attach an image but it didn’t work.

    I’m in Document (as opposed to Block) and Code Editor (as opposed to Visual Editor).

    There is indeed a section Weaver XTreme 4 Options for this page, and “Misc Options” and “Allow Raw HTML and script” which I checked. It did not work. WordPress added more tags, which highlighted the first words that came before the link, making it look like that was a link (which it was not).

    #59765

    miamax
    Participant

    Here’s the page, please scroll all the way to the bottom and look at the text under the image of the bubble wands.

     

    https://dwellinthegarden.com/glow-in-the-dark-party/

     

     

Viewing 16 posts - 1 through 16 (of 19 total)

You must be logged in to reply to this topic.