Home Forums Weaver Xtreme Theme Horizontal Menu (under the header) Shifts to the Right and Then Back

Topic Resolution: Resolved
Viewing 16 posts - 33 through 48 (of 57 total)
  • Author
    Posts
  • #71682
    scrambler
    Moderator

    May be there is something wrong with my Edge….

    You have two errors in your custom CSS breaking the file

    1- You are missing a closing  } on the rule below

    #content .page {background-color:#ffffff; padding:5px;

    should be

    #content .page {background-color:#ffffff; padding:5px;}

    2- There is a line of PHP code in the middle of it that should be removed

    .add_filter( ‘jetpack_enable_opengraph’, ‘__return_false’, 99 );

    After that, the CSS should work

     

    #71683
    scrambler
    Moderator

    Actually the last one needs !important

    .wvrx-menu .sub-menu a {padding-left: 2em !important;}

    #71684
    miamax
    Participant

    Okay, I made those changes.

    I deleted the plugin “Simple Custom CSS and JS,” but before I did, I saw that I had this code there. Is this something I need to add to Global Custom or can I ignore it?

     

    .widget_nav_menu li {padding-top: 4px;}

    #nav-above {display:none;}
    #nav-below {display:none;}
    .nav-next {display:none;}
    .nav-previous {display:none;}

    remove_filter( ‘authenticate’,
    ‘wp_authenticate_email_password’, 20 );

    function no_wordpress_errors(){
    return ‘Something is wrong!’;
    }
    add_filter( ‘login_errors’, ‘no_wordpress_errors’ );

     

    #71685
    miamax
    Participant

    I think I do need that code because now there is a border around the content area. Do you see that?

    #71686
    miamax
    Participant

    And I do want to hide newer and older posts navigation at the top and bottom of each page.

    #71687
    scrambler
    Moderator

    .widget_nav_menu li {padding-top: 4px;}

    You can keep if you need the spacing

    ————————————————————————————————————-

    #nav-above {display:none;}
    #nav-below {display:none;}
    .nav-next {display:none;}
    .nav-previous {display:none;}

    You dont as there are theme options to hide post navigation the proper way.

    Review the “post specifics” options in the Customizer in “where” mode

    ————————————————————————————————————–

    remove_filter( ‘authenticate’,
    ‘wp_authenticate_email_password’, 20 );

    function no_wordpress_errors(){
    return ‘Something is wrong!’;
    }
    add_filter( ‘login_errors’, ‘no_wordpress_errors’ );

    Is PHP code and has nothing to do in a CSS location

    If you know what that code does and you actually need it, you may be able to use the Theme “Actions and filter” box to put it in (in Xtreme Admin Advanced options).

    BUT bad PHP code can break your site and you are on your own with it….

    #71690
    miamax
    Participant

    All the boxes to “hide” were already checked and I still see the navigation to newer and older posts.

     

    #71691
    scrambler
    Moderator

    Do you have the Plus plugin?

    If so there are options to hide the top and bottom links on both blog pages and single post pages

    If you do not have the Plus Plugin, then you can use the CSS to hide them

     

    #71692
    miamax
    Participant

    Okay, that code works to hide the navigation.

    I have this code in Post Specifics  -> Post Area (CSS Rules) but it no longer seems to be hiding the border around the post:

     

    {border:none;padding: 0;}

     

    #71693
    scrambler
    Moderator

    Give me a link to the page with the bordered post as I cant find one

    And the border around post is a theme option that can be deactivated with the corresponding check box

     

    #71694
    miamax
    Participant
    #71695
    scrambler
    Moderator

    I don’t see any border there.

    #71696
    miamax
    Participant

    Where is the border around a post turned off? I only see boxes to check to turn it on.

    #71697
    scrambler
    Moderator

    There is a check box to turn it on, if not checked, it is off, unless it has been manually added with a Custom CSS rule.

    BUT, I see no border around the post in the page you gave me…..

    Clear ALL your caches

    #71698
    miamax
    Participant

    Maybe it’s a quirk in Firefox.

    Everything seems to be okay now, yes? Is my site okay or is it broken?

    #71699
    scrambler
    Moderator

    I do not see a border in Firefox or Chrome

    The site is still broken on Edge on my desktop (showing phone view), BUT is working on Edge on my laptop

    So not sure what to make of that as I cleared all cookies on my desktop to be sure…

Viewing 16 posts - 33 through 48 (of 57 total)
  • You must be logged in to reply to this topic.