Home Forums Weaver Xtreme Theme Homepage changes not saving

Topic Resolution: Resolved
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #20061
    lwr
    Participant
    Hello, regarding site http://www.noashatall.org ;
    I’ve talked to techs from my hosting, Dreamhost, they are stumped and so I have been directed by them to ask for help from Weaver Xtreme 3.1.2 developers. 
    I am using the PBSandwich plugin and have also been discussing the problem with them. They’ve accessed the site, explored it, and say their plugin is working fine but suggest cache-clearing (which I always do religiously via Comet Cache plugin) and clearing from my hosting site, which has been confirmed as not a problem by their techs. The possibility of js from videos has been suggested but I want those videos to be there, so if that’s the issue it needs to be fixed anyway.
    The homepage that shows up has actually been deleted from the site and replaced by a new page, but still shows up as the old page. I can see the new version when I’m signed as admin but when I sign out I see what the world sees, which is the old deleted page. You can see what it’s supposed to look like:
    The Dreamhost tech I last spoke with says that viewing in Switch to Mobile mode (link at top of page sidebar) shows the new and correct page, which looks like http://www.noashatall.org/homepage-2-2/.
    This site is extremely important to a lot of people counting on it for updated information, much of a timely nature. I would appreciate an ASAP assist and THANK YOU. –Leslie Riggins
    #33283
    Gillian
    Moderator

    You should not be using any switch-to-mobile plugin.  Weaver Xtreme is full responsive and will adjust to display properly on mobile devices.  Start by de-activating any mobile view plugin you have installed, and then view your site on a tablet or phone (or reduce your browser size) to see what I mean.  If something doesn’t look like you want it to when viewed on a mobile device, give us detailed information on which elements you have a problem with, and how you want them to look. 

    #38562
    lwr
    Participant

    Thanks, Gillian, but unfortunately that didn’t solve the problem. I am mystified.

    DELETED HOMEPAGE STILL SHOWS UP AS THE SITE’S HOMEPAGE. STILL NEED SOLUTIONS FROM THE CROWD.

    #38586
    scrambler
    Moderator

    If the old page is still showing, this strongly points to a cache problem.

    Clear then deactivate ALL cache plugins and see if then the latest page shows up. If you are using a caching service like Cloudflare, Clear that TOO.

    If then the latest page shows up, you need to solve the issue with the cache plugin developer or use a different one.

    As a rule of thumb, unless the cache has a development mode that will automatically clear its cache anytime a change is made to the site, you should clear your cache manually when making any changes.

    If you have a doubt on which plugin to deactivate, deactivate ALL non weaver plugins. If the problem goes away, reactivate one by one testing in between to find the culprit

     

     

     

     

    #38613
    lwr
    Participant

    I had Comet Cache. I just cleared it, deactivated it, and logged out to check the homepage. Still the deleted version. Then I deleted Comet Cache. I installed Cache Enabler and activated it. I cleared it, signed out, and still, I see the old deleted page. DELETED HOMEPAGE STILL SHOWS UP AS THE SITE’S HOMEPAGE. STILL NEED SOLUTIONS FROM THE CROWD.

    #38616
    lwr
    Participant

    I’ve moved noashatall.org to a VPS. I always clear the cache like a maniac. I’ve removed any switch-to-mobile plugin. I’ve replaced HTML video code on the new homepage with shortcode from a Huge-IT video gallery, using PBSandwich page editor. I’ve had PBSandwich people go through my site to see if anything’s gone awry with their plugin.

    I had Comet Cache. I just cleared it, deactivated it, and logged out to check the homepage. Still the deleted version. Then I deleted Comet Cache. I installed Cache Enabler and activated it. I cleared it, signed out, and still, I see the old deleted page.

    Still, the phantom old and deleted homepage is what shows up for noashatall.org.

    Again, here’s a copy of the new homepage, titled “homepage-2”: http://www.noashatall.org/homepage-2-2/

    I added the existing sidebar to another page to see if at least the sidebar shows up properly, and it does: http://www.noashatall.org/references-resources/

    DELETED HOMEPAGE STILL SHOWS UP AS THE SITE’S HOMEPAGE. STILL NEED SOLUTIONS FROM THE CROWD.

    #38620
    Weaver
    Keymaster

    @lwr: The link your provides shows site failure – an issue with Wordfence it seems.

    #38622
    lwr
    Participant

    thank you; I’ll check it out.

    #38654
    lwr
    Participant

    I just got this message from Dreamhost: ”

    I did check into your issue, and it is your .htaccess file that was
    causing the old site to load.  I had disabled the .htaccess file by
    renaming it to htaccess.disabled and the new page with the error is now
    showing.

    The new error page appears to be caused by the file wordfence-waf.php.
    You may want to check into the wordfence plugin to ensure that is
    installed and updated properly.”

    So it looks like you both found the issue. My confusion now comes from the fact that I don’t have the Wordfence plugin installed on noashatall.org. I’ve got it on some of my other sites with Dreamhost; could that actually affect another site? I remain hopeful but perplexed. And closer to a solution, so encouraged.

    #38696
    lwr
    Participant

    so the .htaccess file problem is not a theme issue, then? Your answer will help me rule that out. Thanks.

     

    #38698
    Weaver
    Keymaster

    I think you really need to start with a fresh .htaccess file if you copied it from an old version.

    The theme has NOTHING to do with .htaccess. That is all setup by WordPress core plus plugins like WordFence.

    So if you copied an old .htaccess, then it almost certainly will confuse your new site.

    Delete .htaccess completely. Then from Dashboard : Settings : Permalinks, save the permalinks to create a new, valid .htaccess.

     

    Do be sure to pick a good permalink settings – the “Post Name” setting gives the most standard links.

    #38700
    lwr
    Participant

    Thank you so much. After I read all that about the .htaccess I assumed so. I greatly appreciate your time and effort. Simultaneously a tech from Dreamhost was helping from his end to do exactly what you suggested and it is now fixed. I originally contacted you because I had been advised that it might be a theme issue.

    I want you to know that I’ve been using Weaver theme for years, because it’s simply the best. I’ve tried others, thinking to get a new look for a site, but I always come back to Weaver. I am a loyal and grateful fan.

    #38711
    Weaver
    Keymaster

    Thank for the follow up. This is a new one on me, but is now a new answer in the answer box. We do tell people to refresh the permalinks, but if there was junk left over from WordFence, who knows what was going on.

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.