Home Forums Weaver Xtreme Theme Hide menu bar on posts

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #17676
    weaverfan
    Participant

    it’s about the homepage http://www.hanauhornets.de

    Admin: 001

    Password: 246810

    I am using posts on the pages „Aktuelles“ and „Terminkalender“ (plugin: „The Events Calendar“). There is no option to hide the menu bar on this pages, as I can do it on normal pages (I am using the fixes browser top for the main menu). How can I do this? I haven`t found a solution so far.

    #21603
    Weaver
    Keymaster

    I don’t understand you question. Both of those are pages (not the default blog page or archive-like pages).

    The “Hide Menus” Per Page option (from the Page Editor) should hide the primary and secondary menus for those pages. Am I missing something else?

    #21604
    weaverfan
    Participant

    That `s right – they are pages, but the different News on the page “Aktuelles” are created as posts. Also the Event Calendar: To use it, you have to create the event on a site, which looks similar to a post site – and they do not have the option to hide menu bars.  We ticked the box on the pages “Aktuelles” and “Terminkalender” which says: Hide menu, but nothing changed, because the content of the page are posts.

    #21605
    Weaver
    Keymaster

    The home page, Aktuelles – doesn’t have a menu – it is not being displayed. The menu on that page is your top fixed extra menu.

    I think there is some misunderstanding about how these pages are working for you. How exactly, did you create the event calendar.

    There area generally two ways that is done –

    1. The calendar plugin (The Events Calendar, it seems) will create a page to use to display itself.
    or
    2. You create a page and add a shortcode to display the calendar.

    Either way, there should not be a difference in how you hide the Primary/Secondary menu.

    I can see from the Terminkalender page’s HTML that it IS being generated by a standard Weaver Xtreme page: (same thing for Aktuelles)

    <body class=”tribe-filter-live tribe-bar-is-disabled not-logged-in weaverx-theme-body weaverx-page-page weaverx-sb-one-column events-gridview events-archive tribe-theme-weaver-xtreme page-template-page-php singular”>

    That means your Pages include a page called Terminkalendar, and you should be able to set the Hide Menus option on the Per Page options for that page.

    But the content being displayed is on pages, even if it happened to be a post somewhere.

    #21606
    weaverfan
    Participant

    Aktuelles:

    Today in the morning I watched the homepage and on the page Aktuelles the menu bar wasn`t shown anymore. The reason, I wasn´t signed in to the administration area. When I am signed in, the page shows the fixed menu and a menu below the header. This must be a bug in WordPress or the theme. Hopefully it is going to be fixed sometime. So this is okay.
    Terminkalender:
    I created the page “Terminkalender” and ticked the box: Hide menu!
    In the calendar plugin I gave in the URL-Slug, so that the calendar is shown on the page (I didn`t have to use a shortcode).
    But as you can see, it doesn`t work, and the main menu bar isn`t hidden. Any solutions for this?
    #21607
    Weaver
    Keymaster

    There is something else going.

    There should be no difference on which menus are displayed depending if you are logged in or not. I don’t know how that could be happening. Maybe do the old disable plugins one at a time until the issue resolves.

    If the calendar can be displayed using a shortcode, I would suggest trying that instead of its page slug – there must be something (maybe the same thing with the home page).

    #21608
    weaverfan
    Participant

    They do not offer a shortcode, I have already looked  for it.

    Nothing really works, I have no explanation for this. I tried to create a new page – it is the same there.
    I do it the way, you suggested with the plugins – nothing helps.
    When I remove the calendar, the page looks fine – the menu bar is hidden. So there must be a problem with the plugin or the plugin and the theme?? Bad thing!
    #21609
    Weaver
    Keymaster

    I think you should contact the plugin’s authors/team and tell them their plugin is ignoring the theme’s page template options.

    It is possible that they are creating their own page by calling the theme’s header.php and footer.php while generating the content all by themselves. This is not a particularly good practice! They really really need a shortcode that can create that page content. I would guess that if the plugin is at all well designed, it should take a programmer just 5 or 10 lines of code to implement a shortcode. In my long experience with WP, there is absolutely no excuse for a plugin like that – that simply generates content for a page – to not have a shortcode available.

    From what we’ve seen, I would also guess that the plugin’s page will not conform to sidebar layout – at the very least on per page options, but likely for any page.

    #21610
    weaverfan
    Participant

    That’ s what I thought too – I have already contacted them – let`s see what they respond! 

    Thanks  for thinking along with me about my request.
    #21611
    weaverfan
    Participant

    It seems it is nevertheless a post problem. When you go to “Aktuelles” in order to read one of the whole articles (posts) and the full post is shown, there is still the main menu below the header.

    After writing the posts, I created a filter called “news” and put it via shortcode into the page “Aktuelles”. It is also the same, when I am logged out.
    #21612
    weaverfan
    Participant

    The full content of a post is displayed on a single page view. I think I have to give this single page the order to hide the menu bar. But where I can I do this? There is no opportunity to do so where I write my post.

    #21613
    Weaver
    Keymaster

    The single page has no options to hide the menu bar.

    If you know the specific post id, you could create custom CSS rules from the Custom & Fonts tab to hide the menu, but if the plugin is generating the posts, that might not be easy.

    #21614
    scrambler
    Moderator

    If you need help, give us a link to the single post page and which menu to hide and we can give you the CSS logic

    #21615
    weaverfan
    Participant

    Yes, help would be great! At the moment there are 5 single post pages – but there are about 2 new posts per week. Here are the links to the posts we have got now:

    #21616
    scrambler
    Moderator

    You are not saying which menu bar you want to hide.

    If all of them on all single posts pages use

    .single-post .menu-primary {display:none;}

    If top
    .single-post #primary-x1-x {display:none;}

    If bottom
    .single-post #nav-primary {display:none;}

    If only certain posts, replace
    .single-post
    by
    .single-post.postid-xxxx

    #21617
    weaverfan
    Participant

    Really great thing! So glad to have an answer to this – works well!

Viewing 16 posts - 1 through 16 (of 16 total)
  • You must be logged in to reply to this topic.