Home Forums Weaver Xtreme Theme Help! Production site main menu messed up!

Topic Resolution: Answered

This topic contains 27 replies, has 3 voices, and was last updated by  Inga 2 months ago.

Viewing 12 posts - 17 through 28 (of 28 total)
  • Author
    Posts
  • #56672

    scrambler
    Moderator

    Do review the plugins and test deactivating them (all non weaver ones).

    If not the issue and if it becomes confirmed that the setting backup file breaks the site, the first thing to do would be to regenerate the setting file from the source, in case it got corrupted.

    If a fresh setting file still breaks the site when restored, then @weaver would have to have a look

    #56676

    Inga
    Participant

    I deactivated all but the Weaver plugins on the icopia.com site to see if it makes a difference. It doesn’t. (i.e. menu is still squished.)
    (On the production site, I get 100’s of spam comments a day, as well as dozens security attacks without protective plugins such as Wordfence, Akismet etc.)

    Additionally, the menu is working correctly on the sandbox site with the same plugins as the production site.

    #56677

    Inga
    Participant

    Right now I’m more interested in restoring proper functionality, rather than worrying about how the menus got messed up. It is true that menus worked before uploading a backup of settings from another working site.
    That is, site had Weaver Xtreme Plus installed, and everything was working, except that I had tweaked settings on another site and wanted t import these settings. That “import” of a backup file wrecked the menus – as I found by doing the same thing on another site.

    I don’t have time to worry about what’s wrong with the backup file. I just need working menus!

    I’m at the point of looking for another flexible theme, but my preference is to get Weaver Xtreme working correctly. But I am wondering if Weaver Xtreme is more compatible with other WordPress themes than Weaver II was .

    Can you help me get my menus working? They were working correctly before with the same plugins and settings as I currently have. I just don’t know how to get them working again .. 

    #56679

    Inga
    Participant

    @scrambler and @weaver: I created fresh backups from the http://ssnet.org/sandbox/ that looks and functions like it’s supposed to. I uploaded to another site with Weaver Xtreme Plus running, and the .wxt file broke the menus, and the wxb file didn’t help.

    Unfortunately the sandbox site is a subsite of the main site, http://ssnet.org/ and it has the same plugins, etc. I tried to set up the best testing environment, and it worked great until I tried to use the backup files elsewhere.

    What I can still do is to tweak another site a bit and create a backup, and see what that will do. I’m hesitant to turn off the plugins on my main setup because they are part of my WP safety net against various kinds of attacks. I try to stick with tried and tested current plugins so that the likelihood of them creating a problem are low.
    I may yet turn off the plugins briefly to create more backups. In the meantime, I’ve been limping along and trying to make the site function better without the main menu. What really bothers me is that the Mobile menu is not working – the hamburger shows but does nothing.

    #56680

    Maureen
    Participant

    One last shot in the dark. On the WordPress Appearance section in the left sidebar, go to the Menu link,  then Manage Locations tab. Undo the locations of the menu so that the locations have —select a menu — instead of the actual menu name. Save. Then go back and put the correct menus with the corresponding locations. Save.

    I don’t know if this will even work, but what the heck!!! It’s worth a try.

    #56681

    Inga
    Participant

    Yup. Anything is worth a try. Will do. 🙂

    [Edit] Made no difference. I created a new menu too, but it displays just as squished.
    I figure I look at the spacing first. If that’s not fixed, the dropdowns are not likely fixed either.

    #56685

    scrambler
    Moderator

    Have you tried recreating the Setting file that you say breaks things?

    It really takes a minute to deactivate ALL non weaver plugins and see if the problem goes away. If it does, you reactivate one by one and test in between to find which one.

    You also did not answer my question, Do you have an optimization plugin ?

    #56686

    Inga
    Participant

    I do not have an optimization plugin such as you describe. LS Cache can do that, but I thought I had not activated that feature. I double-checked, and I had JS-minify on, and I just turned it off. It didn’t make an immediate difference on the site, but I’m assuming the difference would be made in generating the backup file?

    On the sandbox site that generated the backup file, these “Optimize” settings were not turned on, and “Exclude JS Query” was turned on – probably unnecessarily because it is only needed if there’s problems with JS-minify.

    Turning off all non-weaver plugins is a bit more complicated than you suggest. I have to turn off the plugins on the site as well as as network-wide plugins. 🙁

    Thank you for your patience!!

     

    #56687

    Inga
    Participant

    Whew! I deactivated all plugins, and the menus are working fine!!
    I *thought* I had the same plugins on the Sandbox site, but I must have missed something. Will test now.
    Again, thank you for your patience!!

    #56688

    Inga
    Participant

    It is definitely the Litespeed plugin that’s creating the problem. But the Weaver II Pro theme worked fine with caching more than I do now.
    Currently I have the plugin deactivated, even though the test site works with it activated. Will have to check if there’s a difference in settings.

    Thanks so much for sticking with me on this one.

    I may ask later to find out what kind of scripts to exclude from caching, because this plugin is extremely configurable and works rather well. I definitely want to use it!

    #56693
    Best Answer

    scrambler
    Moderator

    This reply has been accepted as the best answer.

    JS minify would definitely break the scripts.

    Weaver run several scripts at very critical time, and already does its own minification, any JS optimization running on top of that will most likely break the scripts.

    #56699

    Inga
    Participant

    Okay, thanks. I need to remember that. I *thought* I had not implemented that feature. As it turns out, both sites ran LSCache, but one site worked and the other didn’t. It was an easy fix to export settings from one to the other. Now both sites function well.

    You might want to check out the LSCache plugin. It’s a free WordPress plugin, but without a Litespeed server, you wouldn’t  have as many personalized options – kind of like the difference between a free theme and a “Plus” theme. There’s great support for the plugin as well.

    My site was running on a regular Apache server, and the processor ran close to max capacity because of the way it handles php requests, and WordPress makes a lot of them. After installing a Litespeed, the server looks like it’s idling most of the time, and everything is a bit faster.

    Thank you for sticking with me and insisting on checking for a minify JS option.

Viewing 12 posts - 17 through 28 (of 28 total)

You must be logged in to reply to this topic.