Home Forums Weaver Xtreme Theme Header spacing

Viewing 16 posts - 1 through 16 (of 17 total)
  • Author
    Posts
  • #70641
    Patti
    Participant

    I have searched the guide and the forum (too much to search through) but cannot find the answer that I need.

    Site: https://familytymes.org/wp/

    I want to remove the spacing on the left side of the header. That little bit where the hands are I want to meet the left side of the theme layout. I keep changing the settings in the Weaver Xtreme layout but cannot seem to get rid of that spacing. Any help would be appreciated!

    #70642
    scrambler
    Moderator

    Add the rule below to the theme Custom CSS rule box

    .custom-logo-link {margin-left:0;}

     

    #70645
    Patti
    Participant

    Thanks @scrambler! That did the trick!

    Next question is: How do I get rid of the white space below the header image and above the main menu bar? I want the image of the pinkie finger to “touch” the main menu bar. Not hover over it. I tried using the same CSS as you suggested above, just changing the word “left” (no quotes), to “bottom” (no quotes) but that did not work.

    #70646
    scrambler
    Moderator

    Change the rule I gave you to

    .custom-logo-link {margin-left:0;line-height:0;}

    #70647
    Patti
    Participant

    Perfect @scrambler!

    Now how can I get the sidebars a tad wider so that my signup box isn’t so squished? I have the spacing set to 0 in everyplace it can be set on the left & right margins. But it looks awful that way. I’d rather have about 5 px worth of space between the sides of the template and the sidebars. But if I change the settings to reflect that then my signup box is squished even more.

    #70648
    scrambler
    Moderator

    You can set the sidebar width % globally in Main options > Sidebar and Layout > Sidebar and layout section

    You can also override that value on any specific page in the Page editing page Weaver options > Layout TAB

    #70654
    Patti
    Participant

    Thanks again @scrambler. I was able to adjust the width of the sidebars so now everything looks great!

    I have another issue that’s really bugging me: On the main menu bar, under the header, you will see the “Terms & Conditions” (no quotes) page. I do not have that listed as a menu item in the admin panel. I added it & then deleted it in an effort to get rid of it. It did not work as you can see.

    Plus all of those menu items are supposed to open in new tabs & they don’t. What am I doing wrong? What do I need to do (besides checking the box in the menu screen) to make them open in new tabs?

    I have designed more than a dozen sites using your Weaver Xtreme theme. I have never had this many problems with any of them.

    #70655
    scrambler
    Moderator

    Did you create your menu using WordPress Custom Menu in Appearance > menus?

    If not, do that, and do not forget to assign the created and saved menu to the Primary menu using the option at the bottom of that page.

    if you did that and the menu item is gone from the custom Menu, AND you have assigned it to the primary menu bar, but still showing up then you probably have a cache issue. Clear all your caches, service, plugin, browser…

    For menu item to open in a new tab, in appearance > menu, with the menu selected, open the menu item and check “Open link in new tab”

    If you don’t see that option, open screen option at the top and check “link target”

    #70657
    Patti
    Participant

    @scrambler,

    I feel like a dummy! Totally missed assigning the main menu to the proper position. Once I did that everything resolved itself! Thanks!

    Next issue: Why is the title “Additional Links” centered on the left sidebar when the other two titles aren’t centered there? I didn’t do anything different when setting up the three widgets. So I don’t understand why that title is center justified & not left justified like the first two?

    #70658
    scrambler
    Moderator

    The widgets are done differently, but the centering appears to come from a custom CSS rule you added in the theme Global Custom CSS Rule box

    .widget-title {text-align:center;margin-bottom:5px;}

    Remove the align property in there

    .widget-title {margin-bottom:5px;}

    Or delete the rule all together if you do not want the margin either

    #70713
    Patti
    Participant

    @scrambler,

    Where do I change the settings so the spacing is the same for both sidebars? You can see at https://familytymes.org/wp/ that the left sidebar text spacing is different than the right sidebar. I cannot find the place to change the spacing for them.

    Next question: If you look at one of the “Category” pages: https://familytymes.org/wp/category/holidays-family-traditions/ you will see that there are two headings (one smaller than the other). Where do I find the place where I can remove the smaller heading? I have searched the Online Forum & the Online Guide to no avail.

    Next question: Looking on the same page: Is there a way to have those articles open in a new tab? I would love to know the answer to this, as I could use it on many other, of my Weaver Xtreme (& Weaver Xtreme Plus) theme sites!

    #70714
    scrambler
    Moderator

    You added a custom CSS rule in the theme Global custom CSS Rule box that affects the left sidebar only

    #primary-widget-area li a {line-height:25px;}

    If you want both like the left, add the right sidebar in the selector

    #secondary-widget-area li a, #primary-widget-area li a {line-height:25px;}

    If you want both like the right , delete the rule

     

    #70718
    Patti
    Participant

    Thanks @scrambler! I added the additional CSS so that both sidebars have equal spacing now.

    Any suggestions on my other two questions?

    1. If you look at one of the “Category” pages: https://familytymes.org/wp/category/holidays-family-traditions/ you will see that there are two headings (one smaller than the other). Where do I find the place where I can remove the smaller heading? I have searched the Online Forum & the Online Guide to no avail.
    2. Looking on the same page: Is there a way to have those articles open in a new tab? I would love to know the answer to this, as I could use it on many other, of my Weaver Xtreme (& Weaver Xtreme Plus) theme sites!
    #70719
    scrambler
    Moderator

    1) The big one is the category title, and the second one in the category meta info line (not sure where that comes from)

    Eventually you can hide the small one by adding the rule below to the theme Global Custom CSS rule box

    .category-archive-meta {display:none;}

    2) Archive pages are formatted by WordPress, there is no settings for them, so I don’t see any way to change that, except with a child theme and changing the template PHP. There may be a plugin for customizing archive pages

    #70722
    Patti
    Participant

    @scrambler That custom CSS didn’t work. I can still see the smaller category title when I publish the CSS.

    I now have another problem: I continue to get an error in the Customize > HTML Injection > Site <head> Section. The error says, “1 Invalid Setting” & nothing else. I tried adding just my description & received the error. Tried adding my description & keywords. Same error. Erased everything & published it. Same error. Makes no sense to get an error when there’s nothing in those boxes! Suggestions? I’m a tad frustrated with it at this point.

    #70724
    scrambler
    Moderator

    If the rule did not work, you either did something wrong, or your CSS file is broken because of some syntax errors.

    I do not see the rule in your site CSS files right now, do you have the rule in place in the Theme Global Custom CSS Rule Box?

    If not, please put it in and post back so I can see why it would not work, and if you have other rules in the Custom CSS Rule box, run them all through an online CSS validation to check for errors.

    The W3C CSS Validation Service

    EDIT:

    The rule is not working because you forgot to close a curly bracket on the Custom CSS rule in yellow below 🙂You also have a double semi column in blue (although that does not break the CSS file)

    /* Global Custom CSS Rules */
    .is-desktop #infobar{margin-left:25%;width:60%;}
    #primary-widget-area li a {line-height:25px;}
    #secondary-widget-area li a, #primary-widget-area li a {line-height:25px;}

    .error404 .search-form {display:none;}
    #site-generator {display:none;}

    .category-title-label {display:none;}
    h1.archive-title {text-align:center;color:#75120A;}
    h1.page-title {text-align:center;color:#75120A;

    .content-3-col-right, .content-3-col-left {width:40%;}

    .page-title {text-align:center;padding-bottom:.5em;;max-width:60%;margin-left:auto;margin-right:auto;margin-top:1em;color:#336B85;}

    .search .post-title {font-size:50%;}

     

    As for your other question:

    • What exactly are you trying to add in the head section box?
    • When and where do you get the error?
    • After you delete everything in the box did you click Publish?

    Eventually go to the box in the Legacy admin located in Appearance > Weaver Xtreme Admin > Advanced Options > Head Section, and make sure boxes are empty there and click Save Settings

Viewing 16 posts - 1 through 16 (of 17 total)
  • You must be logged in to reply to this topic.