Home Forums Weaver Xtreme Theme Header not going full width of the browser

Topic Resolution: Answered
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #65082
    Answered
    GR8FL
    Participant

    Just updated to WordPress to 5.5 and now header is not correct. Doesn’t go full width of the browser.

    Theme: Version: 4.3.8.

    I restored live site, but left it on the clone site. https://hattie-test.littledropup.com/

    #65083
    scrambler
    Moderator

    It appears the settings in Main options > Full width are not working and or saving any more.


    @weaver
    , this appears to be a bug, may be introduced with the recent update. For example if I select Stretch for header image and save, the options doe not stick


    @GR8FL

    In the mean time, Go to main Options > Full width, and check it the stretch option for the header image is still there or if it has disappeared.

    If still there, try to clear it and save.

    Then go to Main options > Header > Header Image > Align Header Image and select “Align Full”

     

    #65085
    GR8FL
    Participant

    I replied to this post, but don’t see my response.

    #65086
    GR8FL
    Participant

    trying again.

    I did go to main Options > Full width, and checked the stretch option for the header image. The one step layout is traditional. This seemed to clear up the issue.

    I also went to Main options > Header > Header Image > Align Header Image and selected “Align Full” (it was center). It also has class wvrx-fullwidth. Doing this did not change anything.

    I am concerned about live site, because even though I rolled back WP from 5.5 to 5.4.2, I got 80 severe scan issues from Wordfence.

    I just did a scan on the staging site, and there are no errors.

    #65088
    scrambler
    Moderator

    FYI, you must not use both the Full width page option (stretch) and the align Alignfull option they will cause conflict.

    It looks like you only have the full width page option right now which is OK, but double check.

    Now I assume this means you had no problem saving the full width page option, which is strange, because I cannot save any option in that page. @weaver, let me know if you are seeing any issue with the full width option page.

    #65093
    GR8FL
    Participant

    Now I am confused. Just turn on stretch, but leave it as center (not align full) for header image? I just made that change.

    As an aside, this site and full header was developed a long time ago. Should it be redone?

    But what about class wvrx-fullwidth?

    Take away these lines in the CSS?

    #header-image {background:url(https://hattie-test.littledropup.com/wp-content/uploads/1600x250-5-4.jpg) center;overflow:hidden !important;}
    
    #branding #header-image img {max-width:960px;}

    Instead use an image that is large and let WordPress scale it down?

    I have another site that was made later than this one which I updated WP 5.5 with this updated theme and had no problems.

    #65095
    scrambler
    Moderator

    1) There should only be ONE option turning the header image full width, these are either

    • Align: alignfull
    • the class wvrx-fullwidth
    • Main option > Full Width > Stretch.

    Right now you have two, you need to get rid of one

    2) The reason the header was developed this way was to prevent it from becoming too high on large browsers

    When you just have an image and full width, it will keep scaling when the browser gets bigger and that can make the header image very high on large browser.

    By doing it the way it is done, the image scales below 960px, but above that it only reveals more of the background on each side but the height remains fixed.

    #65098
    GR8FL
    Participant

    Full Width > Header Image Stretch is checked.

    Header > Header Image > Align Center

    and I removed wvrx-fullwidth

    Is this correct?
    ———————————-

    I wish there was consistency with my websites, but they were all developed at different times.

    I have another that has nothing checked in Full Width > One-Step Site Layout and has Header Image Stretch checked. And in Header Image > Align Left.

    #65101
    Best Answer
    scrambler
    Moderator

    This reply has been accepted as the best answer.

    Yes that is correct.

    As for the other website, I cant comment as I don’t know what they do.

    What you need to do is keep a log of the modification you make, what they accomplish, and the reason you make them 🙂

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.