Home Forums Weaver Show Posts & Show Sliders Header Image replacement with Weaver Show Slider not working

Topic Resolution: Answered

This topic contains 18 replies, has 2 voices, and was last updated by  scrambler 3 months, 2 weeks ago.

Viewing 16 posts - 1 through 16 (of 19 total)
  • Author
    Posts
  • #56162
    Answered

    Rinaldo
    Participant

    Hi, I created a slider and inserted it in the per Page X plus Header Image Replacement HTML  insertion area.

    I also put the slider [show_slider name=activity] in the content area to demonstrate that the slider works.

    Please help.

    https://ambienteguesthouseknysna.co.za/activities/

    #56168

    scrambler
    Moderator

    Your site return a certificate error, site not secure.

    Please fix that first.

    In the mean time, have to tried to just type some text in the header image replacement HTML, and does that show up?

    #56171

    Rinaldo
    Participant

    No, it does not!?

    #56173

    scrambler
    Moderator

    Sorry but when going to your site on edge I get

    This site is not secure
    This might mean that someone’s trying to fool you or steal any info you send to the server. You should close this site immediately.

    On Chrome I get

    Your connection is not private
    Attackers might be trying to steal your information from ambienteguesthouseknysna.co.za (for example, passwords, messages, or credit cards). Learn more
    NET::ERR_CERT_AUTHORITY_INVALID

    On Firefox

    Your connection is not secure

    The owner of ambienteguesthouseknysna.co.za has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

    Learn more…

     

     

    #56178

    Rinaldo
    Participant

    Hi, would you please check whether you still get a warning?

    #56184

    scrambler
    Moderator

    It is working now, and it does not show anything is the header image replacement except some CSS (below)

    #header{background-image:url(//ambienteguesthouseknysna.co.za/files/2018/08/Ambiente-Guest-House_Knysna.jpg);}
    .is-phone #header{background-image:none;}

    So two questions.

    Where did you put that CSS

    Didi you try to just put text in the header image replacement HTML

    #56187

    Rinaldo
    Participant

    Yes, and the text does NOT show. I tried the same on the Front Page and I am getting the Header image and the slider, but nothing on this standard page.

    I cant find the code you me mention above. I have ticked

    Inline CSS – (Xtreme-Plus Option).

    I have ticked both boxes below, Show BG Header just doesnt copy:

    <small>Show On Home Page Only</small>: <input id=”header_image_html_home_only” checked=”checked” name=”weaverx_settings[header_image_html_home_only]” type=”checkbox” /> <small>Check to use the Image HTML Replacement only on your Front/Home page.</small>
    <small>Also show BG Header Image</small>:

    May be that is related?

     

    #56190

    scrambler
    Moderator

    Ok, if you have inline CSS that would explain the CSS I saw. (not sure why you would use that option which is mostly use to diagnose problems)

    Now if this is the only page where the per page header replacement HTML does not work, try recreating the Page as that page may have gotten corrupted. Start by creating a new page and adding the HTML replacement, then add the rest of the page content one step at a time and test in between to see if at one point the problem comes back.

    You should also try deactivating ALL non weaver plugins, to see if that fixes the issue.

    #56191

    Rinaldo
    Participant

    It works only on the front page and there the slider is on top of the header image. I assume it works because both, HTML and Header image should show as indicated above. The slider works in the content section of the page! So I dont believe it is a 3rd party plugin, but I will try.

     

    #56192

    scrambler
    Moderator

    What options do you have in main options > Header > Header image.

    In hide header image

    In Header image rendering

    In Image HTML replacement

    In Show on home page only

    In Also show BG header image

    #56193

    Rinaldo
    Participant

    In

    Header Image Rendering:

    I have Responsive BG Image. In Height 300px.

    When I change that to As img in …, the Header image disappears. All BG options work.

    In Image HTML replacement:

    [widget_area area='check' area_style="" class="alt-class-name" style="background:rgba(255,255,255,0.5);width:12.3em;position:fixed;top:11.0em;left:2.9em !important;z-index:998;"]

    In Show on home page only Ticked

    In Also show BG header image Ticked

     

    #56199

    scrambler
    Moderator

    If you have ticked “In Show on home page only Ticked

    Then whatever is in the header image replacement will only show on the home page, so that is probably why it does not work on other pages.

    You may want to explain what it is exactly that you are trying to achieve overall

    #56203

    Rinaldo
    Participant

    Hi, I created a slider and inserted it in the per Page X plus Header Image Replacement HTML  insertion area.

    I also put the slider [show_slider name=activity] also in the content area to demonstrate that the slider works.

    Please help.

    https://ambienteguesthouseknysna.co.za/activities/

    I am talking about above page. This is NOT the front page. I want to replace the header image on above page with a slider.

    #56205

    scrambler
    Moderator

    May be I am not following what you are saying, but you said you checked the option in main option > Header > Header Image > Show on home page only.

    This means the header image (or its replacement) will only show on the front page and not on any other page.

    If you are trying to replace the header image by the slider on a page that is not the home page, then you need to Uncheck that option

    #56206

    Rinaldo
    Participant

    I am sorry, its this option: Check to use the Image HTML Replacement only on your Front/Home page.

    I see only a Hide on Front Page option.
    #56207
    Best Answer

    scrambler
    Moderator

    This reply has been accepted as the best answer.

    I am not following.

    This option (main option > Header > Header Image > Show on home page only) does not hide on front page, this option only shows the header image replacement HTML on the front page.

    If that option is checked, the header image replacement HTML will only be displayed on the front page and not on the other pages

    So given you have the option checked, and given the activities page is NOT the front page, the header image replacement HTML will NOT be displayed on the activities page.

    Uncheck that option…

Viewing 16 posts - 1 through 16 (of 19 total)

You must be logged in to reply to this topic.