Home Forums Weaver Xtreme Theme Header Broken Weaver Extreme Version: 6.2.1.3

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #72775
    IBNu2WP
    Participant

    I read the latest post about Version: 6.2.1.3, and had my host restore the website to a backup of 5/12 so that I could manually update the theme as it had auto-updated.  I also updated the Weaver Xtreme Plus plugin.  Cleared the cache and a couple of things are broken.  On Andyonlakewylie.com the header no longer fills the header the area to site width. I’ve tried to fix it and I’m afraid I don’t know how. I built this site several Weaver Theme Versions ago, and now find myself lost as to how to fix it. Any thoughts.

    The Feature listings near the bottom of the page went full-width on me, so I think that is a plugin issue that I need to open a support ticket with that developer. Seems that setting for full-width vs site width is also missing. But that’s not a Weaver problem.

    Thanks for your assistance.

    #72776
    Weaver
    Keymaster

    I’m not sure what you were expecting, but you have the theme width set to 1350 px. That is making most of the site fit within that size, including the header and header image.

    The listing blocks on the bottom seem to ignore the theme width and set their own width to expand beyond the 1350 px.

    If you set the Wide or Full width option for the wrapper, I think that will fix everything. Set the Wrapper area to Align Wide or Align Full. Same for the header image, I think.

    But this site is just displaying what you have defined, and I’m pretty sure how it displays has nothing to do with the theme update to 6.2.1.3.

    #72777
    IBNu2WP
    Participant

    “If you set the Wide or Full width option for the wrapper, I think that will fix everything. Set the Wrapper area to Align Wide or Align Full. Same for the header image, I think.”

    That’s the setting I can’t locate.  I remember Scrambler having me adjust a similar setting before, but I can’t find that box.  Guess I’m getting dense in my old age.

    I’m looking under “Wrapper Areas”.

    As to the header image, it filled the entire header area and the menu wasn’t wrapping.  I don’t know what broke.

    Thanks for your patience.

     

    #72778
    IBNu2WP
    Participant

    For the time being, I did reduce the site width.  I need to figure out how to widen the menu.

    I’ve contacted the plugin developer about the listings outside the site width.

    Still need to find that setting you referenced, ( see comments above )

    Thanks.

    #72779
    User
    Participant

    @IBNu2WP

    I believe you can change your Menu width here:

    Weaver Xtreme Admin > Main Options > Sidebar Layout > Left Sidebar Width = Width %

    Regards!

     

    #72797
    scrambler
    Moderator

    If any area needs to be expanded wider than the site width, look in the Align area option of that element.

    There you will find the alignfull and alignwide options

     

    #73796
    IBNu2WP
    Participant

    I still don’t have this corrected as you see that the header image does not fill the header area; and the primary menu doesn’t extend to the wrapper border.

    Now using Extreme Version 6.4.  I would really like to get this resolved.  I have tried all solutions suggested, more than once.

    Thanks.

    #73801
    scrambler
    Moderator

    A number of things.

    First your overall site is aligned left which is weird, regardless of width, you normally want a centered setting.

    This is found in the wrapper Areas > Wrapper > Align Area > set to center if using a limited width, or use alignfull if you want full browser width.

    Regarding the header.

    I see several custom CSS rules affecting the width. Once I remove these CSS rules, the header and menu are full width, within the 10px right and left padding you have set on the wrapper.

    The rules I see are:

    @media (max-width: 575px) {

        body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {

            width:100%;

            max-width: 539px;

            box-sizing: border-box

        }

    }

     

    @media (min-width: 576px) {

        body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {

            /* width:540px; */

        }

    }

     

    @media (min-width: 768px) {

        body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {

            /* width:720px; */

        }

    }

     

    @media (min-width: 992px) {

        body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {

            /* width:960px; */

        }

    }

     

    @media (min-width: 1200px) {

        body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {

            /* width:1140px; */

        }

    }

    Did you add these custom CSS on your site either in the theme Global Custom CSS rule box, or the WordPress custom CSS.

    If you did, you need to explain what you were trying to accomplish, because they are affecting your header.

     

    #73802
    IBNu2WP
    Participant

    Ah ha!  Thank you.  I fixed the Left Align, not sure how that got there.  But with your guidance, I found the Home Junction Plugin ‘Membership’ seems to have this CSS code.  When I deactivate the plugin, everything aligns correctly.

    Since you have much more knowledge than I, is there a custom CSS Code that could override the Header using !important from what you are seeing?

    #73803
    scrambler
    Moderator

    Do you know what that rule is meant to do?

    What desirable effect are you losing?

    #73809
    IBNu2WP
    Participant

    It is the core plugin for the Real Estate Listing from MLS.  Disabling the plugin, it disables all of the featured listings throughout the website, which as you can imagine is the purpose of the website. Now that I know what it is and what was causing the header issue, I guess I live it. I’m not sure that I want to try to mess with the plugin code itself, as does get updated.  I don’t know how to override it for just the header image and menu.

    #73810
    scrambler
    Moderator

    I would first try to see if there is any option in the plugin that talks about controlling the width of header and footer where you could deactivate these.

    Next I would check if the plugin gives you direct access to the CSS.

    You may also want to ask the plugin developer why they are changing the theme styling with these rules and if there is an easy way to remove it….

    If not, the CSS below placed in the theme Global Custom CSS Rule box should restore the width

    @media (min-width: 576px) {
    body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {
    width:100% !important;
    }
    }
    
    @media (min-width: 768px) {
    body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {
    width:100% !important;
    }
    }
    
    @media (min-width: 992px) {
    body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {
    width:100% !important;
    }
    }
    
    @media (min-width: 1200px) {
    body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper,body:not(.hji-search-result-page)>.market-compliance {
    width:100% !important;
    }
    }
    body:not(.hji-search-result-page) #footer,body:not(.hji-search-result-page) #header,body:not(.hji-search-result-page) .alignwide,body:not(.hji-search-result-page) .hji-main-content-wrapper {
    padding: 0 !important;
    }
    

     

    #73811
    IBNu2WP
    Participant

    You nailed it! I wasn’t expecting that! You have always exceeded my expects for the past 12 years!  Thank you from the bottom of my heart.

    Everything fell right into place.  Thank you!!!

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.