Home Forums Weaver Xtreme Theme Have Lost Line Space Under Lists

Topic Resolution: Resolved

This topic contains 4 replies, has 2 voices, and was last updated by  hkp 2 weeks, 5 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #61249

    hkp
    Participant

    Hi Folks,
    I wonder if you can help.

    Some time during the early WP 5.1+ updates, something was updated which changed how LISTS are formatted.

    Whether this is due to WP core code or W-Xtreme default settings I do not know.

    The result is that there is now no line space between a LIST and the text or object underneath it.

    I solved this problem on new posts by changing the last list < li > to < li style=”margin-bottom: 15px;” >

    However today, I was editing some old posts and I found that the current default no line space setting is giving pretty ugly results on occasion.

    Is there any way I can insert a line in my W-Xtreme child style.css to achieve a global fix and restore a line space under all lists?

    Sample of problem is: https://www.hiskingdomprophecy.com/3-things-being-released-after-john-paul-jacksons-passing/

     

    Regards and thanks,
    Angus

    #61250

    scrambler
    Moderator

    Not sure if that is a change, but to add space under ordered and unordered list add the rule below to the theme global custom CSS Rule box

    ul, ol {margin-bottom:15px;}

     

    #61251

    hkp
    Participant

    Thank you @scrambler

    That partially fixed it.  After a lot of testing and different options, it seems to be browser related.

    After adding your fix, Tor, Opera, Firefox & Duckduckgo now render a space under a LIST correctly.

    However, Chrome & Brave do not.

    Manually changing the UL call in a post from < ul > to < ul  style=”margin-bottom: 15px;” > works on all browsers, but sadly  ‘ul, ol {margin-bottom:15px;}‘ does not at this time.

    Thank for your help.

    Regards, Angus

    #61253

    scrambler
    Moderator

    That does not make sense.

    Try to add important, and if it still does not work on chrome, post back with the rule in place.

    ul, ol {margin-bottom:15px !important;}

    #61266

    hkp
    Participant

    Thank you @scrambler

    I have done more testing using: ul, ol {margin-bottom:15px !important;}  and I have now left that setting in style.css as the default.

    Chrome & Brave now render a space under a LIST correctly, but NOT when I am logged into WordPress!  As soon as I log into WP on these browsers, I lose all spaces after lists – but only on my own screen.

    Firefox, Opera, Explorer and Tor all render correctly at all times, whether or not I am logged into WordPress.

    So I guess you can mark this as resolved, since all our users can now see the pages rendered as intended.  Only me as editing ADMIN has an issue, and I can accept that.  🙂

    Regards and thanks, Angus

     

     

     

     

     

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.