Home Forums Weaver Xtreme Theme Google Mobility Issues

This topic contains 6 replies, has 3 voices, and was last updated by  Weaver 1 week ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #57961

    IBNu2WP
    Participant

    I am trying to resolve all of the Google Mobility issues that have hit my Search Console.  I know that the Weaver Theme is the best mobile friendly theme available which is why I selected it years ago.  Currently working with Weaver Xtreme 4.2.2, Weaver Themes Shortcode Compatibility 1.04; Weaver Xtreme Plus 3.1.1; Weaver Xtreme Theme Support 4.0.2 and WordPress 4.9.9.

    Trying to resolve: New Mobile Usability issues detected for site https://www.lakewylietax.com 

    Top new issues found, ordered by number of affected pages:
    Text too small to read

    Viewport not set

    So, I went into settings Appearance -> Fonts & Custom -> Fonts.

    Base Font Size is set to 16px (was 15px)

    Small Tablets was blank but changed to default 16px

    Phone was also blank but changed to 18px.

    So I am viewing the homepage on a Samsung S7 in Portrait.  Notice that the font size in the opening paragraph hasn’t changed – still small.  But if you look at the li bullets, the font size increased.  Now, use the mobile menu and go to Tax Tips & Blog.  Whether you are looking at the excerpt page or the blog page, the text is still small and doesn’t seem to adjust.

    Another step I took was to disable all plugins, and no change.  So, it is something that I’ve done and can’t find it.  This site is also on Cloudflare, so I made sure that it wasn’t minify any of the minification settings.

    Lastly, I don’t understand the last complaint of Google – Viewport.  Wouldn’t this be something that the theme would automatically handle?

    #57963

    scrambler
    Moderator

    FYI, latest Theme Support plugin version is 4.0.3, so you need to update.

    You appear to have Custom CSS rules that are overriding the font size like below

    @media only screen  and (max-width:767px){
    h2{
    font-size: 15px;
    line-height: 1.1em;
    }
    p{
      font-size: 13px;
    line-height: 1.2em;
    }

    .
    .
    .
    .

    #57984

    IBNu2WP
    Participant

    Well, that @media rule would certainly do that….. but where is the CSS?  This site was originally on Weaver Pro II and converted to Xtreme.  Here is all of the custom CSS from the Fonts & Custom Tab and I don’t have any Per page CSS entered:

    .page-id-10 .wp-caption-text {
    padding: 0em 1em 3em 1em;
    }

    .content-2-col-left {width:58%;}
    .content-2-col-right {width:39%;
    float: right;}

    .is-mobile .content-2-col-left {width:100%;}
    .is-mobile .content-2-col-right {width:100%;}

    ul {
    padding-bottom: .7em;
    }

    .postid-809 ul {padding-bottom: 0px;}

    .icons {
    float: right;
    margin-right: 10px;
    position: relative;
    margin-top: 6px;
    }

    a.more-link {
    padding-bottom: 1.0em !important;
    }
    .id {
    margin-top: -20px;
    margin-bottom: 1em;
    text-align: center;
    color: #E28C30;
    }
    #recent-posts-3 li {
    padding-bottom: 8px;
    }
    .id a {color: #E28C30;}
    .high ul {list-style-position:inside;}
    .high ul li {text-indent:1.5em;}
    .high {padding-bottom: 1em;}
    .wp-caption {margin-bottom: 0px !important;}

    time {font-size: smaller;}

    .wp-caption-text {
    font-size: 0.7em !important;
    }

    .greencheck {
    background:transparent url(https://www.lakewylietax.com/wp-content/uploads/2014/11/check-mark.png) no-repeat scroll 0 0;
    list-style-type:none;
    padding-left: 20px;
    }
    .about .wp-caption-text {
    font-weight: bold;
    color: #0a4336;
    }
    .BlockContent li {padding-bottom: 8px;
    text-decoration: underline;
    }

    #nav-primary, #nav-secondary {
    BORDER-TOP: 3px solid #0a4336;
    }

    .page-id-24 .entry-utility {
    display: none;
    }
    .page-id-24 article {
    margin-top: 5px;
    }
    .page-id-24 #content h1.page-title:not(.archive-title) {
    margin-top: 15px;
    }
    .page-id-24 a {font-style: italic;}

    #tax img {
    margin-top: 40px;
    }

    .page-id-28 #content li {
    background:transparent url(https://www.lakewylietax.com/wp-content/uploads/2014/11/check-mark.png) no-repeat scroll 0 0;
    list-style-type:none;
    padding-left: 40px;
    padding-bottom: 15px;
    background-position: 0px -10px;
    }

    blockquote.easy_testimonial div.testimonial_body {
    padding-top: 10px;
    margin-left: 20px !important;
    }
    .testimonial_body > p:first-child:before, .testimonial_body > p:first-of-type:before {color: #14846B !important;}
    .testimonial_body > p:first-child:before, .testimonial_body > p:first-of-type:after {color: #14846B !important;}

    blockquote .easy_testimonial p .testimonial_author {
    color: black !important;
    position: relative !important;
    top: auto !important;
    width: 200px !important;
    margin-left: 10px !important;
    }

    .style-avatar-left-blue-orange blockquote.easy_testimonial p.testimonial_author {
    margin-left: 15px !important;
    width: 95%;
    }

    .testimonial-position {font-size: small !important;}
    cite {
    border-width: 0;
    display: block;
    margin-left: 1em;
    margin-top: .5em;
    }

    .easy_testimonial cite span {
    font-size: medium;
    }

    blockquote.easy_testimonial p {
    margin-top: 20px !important;
    color: black !important;
    line-height: 1.2em !important;
    font-size: large !important;
    }

    blockquote.easy_testimonial .wp-post-image {
    display: none;
    }

    blockquote.easy_testimonial {
    border: 1px solid lightgray;
    border-radius: 15px;
    box-shadow: 2px 2px 2px #888888;
    min-height: 150px !important;
    }
    .single-testimonial .navigation {display: none !important;}
    .single-testimonial .entry-title {display: none !important;}
    .single-testimonial .entry-meta {display: none !important;}
    .single-testimonial .entry-utility {display: none !important;}
    .frontbut {
    margin-top: -30px;
    border-radius: 15px;
    background-color: #0A4336;
    color: white;
    height: 50px;
    font-weight: bold;
    border: 1px solid #0A4336;
    box-shadow: 4px 4px 4px #888888;
    }
    #site-info {width:95%}
    #footright {
    float: right;
    text-align: right;
    position:relative;
    width: 28%;
    }

    #footright img {
    float:left;
    }

    #foot {
    margin-top: 5px;
    }

    #57986

    scrambler
    Moderator

    It appears to come from a plugin called easy testimonial pro.

    They have very broad rules in there screwing up things.

    Check if there is a way to change settings there, or else you will need to add your own custom CSS rule to override the plugin ones

    #58013

    IBNu2WP
    Participant

    I don’t know how you found it, I searched for hours.  But you nailed it.  Works perfectly now.

    One last thing, what is the viewport that Google is complaining about?

    #58015

    scrambler
    Moderator

    using the Browser developer tool, you see the rule, then you see the rule comes from a file located in the plugin directory

    I have no Idea what the Google warning “Viewport not set” means, @weaver may know more

    #58019

    Weaver
    Keymaster

    Weaver Xtreme does set the viewport, so I don’t know why that would get flagged.

    It is one of the very first lines in the HTML:

     

    <meta name='viewport' content='width=device-width,initial-scale=1.0' />
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.