Home Forums Weaver Xtreme Theme Full width settings

Topic Resolution: Resolved
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #63052
    Mira
    Participant

    Hi,

     

    I am trying to get our site to a full width layout. There are many places where I can play with the full width settings, but none seem to take effect. So far all I have managed is a grad area left and right of the header.

    I would like the whole header area and the picture to display full width and also the text in the content area of the page to start on the left side (there was a left sidebar before, I removed the content, but the text of the page stayed “stuck ” in the middle, as if there still was a sidebar)

    Thank you so much,

    Kind regards,

    mira

    #63053
    scrambler
    Moderator

    You need to be a bit more precise.

    Do you want everything including the content to stretch the full width of the browser, or do you want the header to stretch full with, but the content area to be limited to the them width (set at 1100px right now)

    Right now, your theme is et to extend background instead of stretch content. The setting is in Main options > Full Width > One Step layout.

    If everything should be stretched, you can use “stretched expand to full width”

    If you want different full width behavior per area, Chose Traditional in that box.

    Then for each area that should be full width, go to the area Align Option and select “Align Full”.

    About your sidebar comment, removing the content will not remove the space, you need to change the sidebar layout for that page and select No sidebar, You can do that globally for all pages of a specific type in main options > Sidebar & layout, or you can use the layout option in any specific page editing page.

     

    #63054
    Mira
    Participant

    Hi,

    the full width settings seem to not work properly. Half of the header picture is grey (the right half, under the menu).

    This happens in the “stretched expand to full width” as well as in the traditional and align full option.

    #63055
    scrambler
    Moderator

    Please always include the site link so we don’t have to dig it up in another thread 🙂

    You have not answered my question about what parts you want full width.

    What full width settings choice do you have active right now?

    #63056
    scrambler
    Moderator

    If you want everything stretched, please set the One step Layout to Traditional

    Make sure that no check boxes are checked in Main options > Full Width

    Then set the theme width to 10,000 px and post back with a link if not stretched

    #63063
    Mira
    Participant

    Hi,

    yes, sorry for not having given you the info about the site.https://www.psychosomatik.com/de/behandlungen/krankheitsbilder/

    So, Tried your last suggestion, but anytime I set any of the full width options, the header picture appears half grey (the right hand side is a grey area, as if the picture is half covered by some kind of solid grey overlay.

    Also, I did not know, If I wanted everything stretched. Now that I have seen it, I do not want it. I would like to just have the header cover the whole width, and the text to start where the left sidebar used to sit .

    The site looks crazy with these stretched settings, so I am switching back to what it used to be. Maybe I can supply a screenshot of the problem with the greyed out header.?

     

    Kind regards,

    Mira

    #63066
    scrambler
    Moderator

    Please set the header area align option to align full and post back

    You content is shifted because you probably still have the wrong sidebar layout for it.

    Please go to its page editing page > Weaver Xtreme options for this page > Layout > Sidebar Layout, and select Sidebar on right instead of sidebar on right and left

    #63113
    Mira
    Participant

    Hi,

    sorry for not having gotten back sooner.

    So, I tried setting header area align full and also tried header image align full. Both options: same problem: half of the image is grey, as if the backgound color from the menu above the image covered the picture.

    This seems to happen, no matter where I try to deal with the full width settings. (customiser, backend or on the page itself)

     

    The text problem was fixed by your advise, thank you very much!

    Kind regards,

    Mira

    #63115
    scrambler
    Moderator

    You need to listen to what I am saying :)…

    In order for me to see what may be going on, I need you to set the header area to alignfull and leave it this way so I can see what is happening.

    #63116
    Mira
    Participant

    Sorry, didn’t hear the part about leaving it on.

    You can see it now.

    #63117
    scrambler
    Moderator

    Looking closer, I also see your header is a slider placed in a widget in the header widget area.

    It appears you used a two column text widget which does not allow the content to be more than 50%

    Put the slider in a regular text widget, not two column

     

    #63118
    Mira
    Participant

    That is it! You are a genius! Thank you so much!

    I have taken over this site from somebody else who is not available for help any more. This is why I don´t know how things are built (yet).

    Thank you for your patience with me!

     

     

    #63120
    Mira
    Participant

    Hi again.

    Could you possibly also find out why the header in the arabic version is broken? https://www.psychosomatik.com/?lang=ar

    and what is the grey area under the header in the Russian version ? https://www.psychosomatik.com/?lang=ru

     

    thank you so much,

    kind regards,

    Mira

Viewing 13 posts - 1 through 13 (of 13 total)
  • You must be logged in to reply to this topic.