Home Forums Weaver Xtreme Theme Full Width problem with Xtreme 4.4.2

Topic Resolution: Resolved
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #66373
    thesurge
    Participant

    I updated one site to 4.4.2 today but have rolled back to 4.4.1 until I have time to look into this issue and make the necessary changes.

    It seems like the ‘wvrx-fullwidth’ class is being ignored by the latest version of xtreme. The site in question has a number of full width sections that rely on wvrx-fullwidth, after the update all of these areas lost the full width appearance.

    Not sure if the same happens with ‘wvrx-expand-full’ as it is not in use on this particular website.

    Also, the site is still using WP5.5.3, so not related to the WP5.6 update.

    #66379
    scrambler
    Moderator

    4.4.2 was done to fix a problem caused by WP5.6, but may have broken something when still on 5.3.

    With 4.4.2 and WP5.6, I am not having a problem with the wvrx-fullwidth either coming from using extend BG in the Full width option page, or added on custom HTML content


    @weaver
    will have to check if 4.4.2 and WP5.3 causes a problem with wvrx-fullwidth class, in the mean time, please elaborate on your specific case and provide a link to the page explaining where to look.

    #66383
    Weaver
    Keymaster

    Is your use of .wvrx-fullwidth as a specifically added class, or via full width alignment options?

    #66407
    thesurge
    Participant

    wvrx-fullwidth is used in the ‘Add Classes’ boxes for some areas, such as ‘Post Header’,  ‘Post Footer’, ‘Pre Footer’.

    Also used directly in HTML for some page content sections, for example:

    div class=”highlight-box-x wvrx-fullwidth”
    SOME CONTENT HERE…
    /div

    Just to confirm, site is still on WP 5.5.3 and Weaver 4.2.1 was fine, Weaver 4.2.2 lost all full width appearance for these areas.

    #66411
    scrambler
    Moderator

    I tested both an HTML div with the wvrx-fullwidth class AND a wvrx-fullwidth class added to the post footer area, and with WP 5.6 and XTreme 4.4.2.1 they work fine.

    May be @weaver can check these on WP 5.3 and Xtreme 4.4.2.1

    #66413
    thesurge
    Participant

    I will have time to look at the website in question more closely next week, so will update to WP5.6 and move xtreme to the latest version again. Hopefully everything will work as expected but if not I should have the time to sort things out.

    #66414
    Weaver
    Keymaster

    Themes are not supposed to support more than 2 versions backward WP compatibility (meaning 5.4 now). I won’t force this yet by changing the min WP version tag for now, but I won’t try to fix things for 5.3. I have tested the fixes with 5.5, and they seem to still work.

    #66416
    Weaver
    Keymaster

    I am unable to duplicate that problem in 4.4.3 which will be released shortly.

    #66418
    thesurge
    Participant

    Please note I didn’t say the site was using WP 5.3, it is 5.5.3

    #66419
    scrambler
    Moderator

    @thesurge, probably my bad 🙂

    From what weaver is saying you should be good with 4.4.3 coming up

    #66446
    thesurge
    Participant

    @scrambler @Weaver, I can confirm that the 4.4.3 update is working correctly. Thanks for you help.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.