Home Forums Weaver Xtreme Theme ftp error messages

Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #62992
    develec
    Participant

    Hello All

    I get multiple ftp warning messages (usually 11) like the ones below on the Weaver Xtreme Admin Page at the top of the page. All FTP functions appear to work – update themes, plugins, WordPress etc. Any idea what the problem could be? The problem doesn’t appear to affect the website when it is being browsed. The problem occurs on a few websites on more than one server.

    The problem seems to go away if I switch the theme to 2020.

    Weaver Xtreme Plus is installed but disabling it doesn’t have any effect and it doesn’t seem to be plug-in related. The web server is Apache running under Centos 7 and uses vsftp. Everything is up-to-date.

    Hope someone can help.

    Kind regards

    Jeff

    <b>Warning</b>: ftp_mkdir() expects parameter 1 to be resource, null given in <b>/srv/nz/co/bigplumbingsupplies/www/wwwroot/wp-admin/includes/class-wp-filesystem-ftpext.php</b> on line <b>539</b>

    <b>Warning</b>: ftp_fput() expects parameter 1 to be resource, null given in <b>/srv/nz/co/bigplumbingsupplies/www/wwwroot/wp-admin/includes/class-wp-filesystem-ftpext.php</b> on line <b>208</b>

    <b>Warning</b>: ftp_chmod() expects parameter 1 to be resource, null given in <b>/srv/nz/co/bigplumbingsupplies/www/wwwroot/wp-admin/includes/class-wp-filesystem-ftpext.php</b> on line <b>280</b>

     

    #62994
    Weaver
    Keymaster

    Have you been using Weaver Xtreme for a while?

    Did these error messages just begin happening? Did the theme work previously?

    What changed?

    I am very pessimistic about this issue. The messages are coming from deep within the WordPress core. Normally, Weaver Xtreme does not use or need to use the ftp versions for file handling (involves saving settings and generated CSS). It has been many years since we’ve seen actual ftp issues.

    So, this does seem to be a host configuration issue. The host may be properly configured, but either not using more modern file access methods, or is using some alternative file access system that does require ftp. It may be a security configuration for the host.

    It does seem unlikely that there will be any kind of way to change Weaver Xtreme to work with this particular WP installation.

    #63026
    Private Reply
    develec
    Participant
    This reply has been marked as private.
    #63038
    Private Reply
    Weaver
    Keymaster
    This reply has been marked as private.
Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.