Home Forums Weaver for bbPress Forum Posting Issues

This topic contains 17 replies, has 5 voices, and was last updated by  Inga 1 week ago.

Viewing 16 posts - 1 through 16 (of 18 total)
  • Author
    Posts
  • #48963

    Weaver
    Keymaster

    The quotation button is already include on the 2nd line in about the middle!

    Include the “quotation” option in the styling bar, so it’s not necessary to choose both “indent” and “italicize” (which currently don’t work).

    And indent works fine for me.

    This is indented using the indent button.

     

     

    #48966

    Inga
    Participant

    @weaver <duh!>I had forgotten about the second formatting bar – maybe because I always have them visible in my editor. 😉

    Just for fun, I’ll try indenting your bold line with italics:
    <p style=”padding-left: 30px;”>This is indented using the indent button.</p>

    Edit: I see that didn’t work too well. 😉 No big deal since the “quote” button works.

    #48967

    Inga
    Participant

    Quoting previous topic or reply content with references is really not supported by bbPress in any simple way, nor have I found any plugins to do that. I really can’t think of any easy way to do that.

    Interesting that the “quote” button works a bit differently than in WP. bbPress doesn’t include the italics, which I added manually.

    I was just on a site that did what I requested, and it’s convenient, but not a deal breaker. Thanks for checking out the moderation plugin!

    #48968

    Inga
    Participant

    Question: Is there a choice to set the amount of time that a comment can be “edited” ?

    I was going to edit a comment above which may not be clear: You bolded and indented a line. I copied that line, adding italics, and that broke it and showed bare code. So it’s just that italics and indent don’t work together.

    #48969

    Weaver
    Keymaster

    You can set the edit window time limit.

    I wonder why you’re having problems with the editor. I can consistently get quote and indent to work.

    The quotation, of course, can be styled. I think the quotation styling while in the editor is default tinyMCE or even HTML, while what is displayed on the actual post is by the theme (Weaver Xtreme – gray bg, bar on the left, italic text.)

    What about the quotation author?

    Author needs to be wrapped with cite tags via Text view.

    Like the example above.

    #48978

    Inga
    Participant

    @weaver Your reply explains something about how quotations appear. Thanks.

    As for how things work for me – it’s easy enough to see what I did, because the HTML shows. 😉 I did not insert any HTML of my own. Just used several options from the style bars. 🙂

     

    #48992

    Gillian
    Moderator

    I tried to post this message numerous times this morning but the Forum kept gobbling it up – some hours later I’m now trying again …

    @weaver

    I like the Weaver Xtreme formatting of blockquotes – gray bg, bar on the left, italic text – except for the uneven spacing of the gray bg above and below the text, which I don’t like the aesthetics of. I change this on my sites with this CSS:

    blockquote {padding: 0.8em 1.5em 0 1.2em;}

    I was wondering why the default formatting has the uneven spacing?
    <p style=”padding-left: 60px;”>
    Also, just testing @inga’s combination of indent and italics to see if it works for me.
    Nope – doesn’t work, Now trying applying indent first, then italics
    Conclusion – The combination of indent and italics is a fail 🙁 and so is bold and indent 🙁</p>

    #48993

    Inga
    Participant

    @gillian I was wondering why I got email saying you posted and then didn’t see the post on the forum. Something clearly wrong …

    I do agree with you on the styling of block quotes.

    You also wrote:
    <p style=”padding-left: 30px;”>Conclusion – The combination of indent and italics is a fail 🙁 and so is bold and indent 🙁</p>
    Glad to have you confirm what I experienced. 😉 [email protected] did do bold and indent, and it worked. I copied and pasted your quote above, *then* indented it, and it was a fail!

    Now I’ll try copying something from your post, bold it and then try to indent:
    <p style=”padding-left: 30px;”>I like the Weaver Xtreme formatting of blockquotes – gray bg, bar on the left, italic text – except for the uneven spacing of the gray bg above and below the text, which I don’t like the aesthetics of.</p>
    Didn’t work either. Let me indent and *then* apply bolding:
    <p style=”padding-left: 30px;”>I was wondering why I got email saying you posted and then didn’t see the post on the forum. Something clearly wrong …</p>
    It always looks like it works in the editor, then reverts to HTML code after “submitting.”

    It’s always the “indent” that shows up as HTML, not the rest of the styling. So it looks like we cannot indent styled text? That’s a bit weird …

    #48995

    Gillian
    Moderator

    @weaver, @Inga, @scrambler

    I know that at least inga, scrambler and I (not sure about weaver) have experienced the odd occasion where a response we are trying to post disappears into the ether. Today I think I might have figured out what triggers this to happen. I think it happens when one writes a response (and successfully posts it), but then one edits and re-edits the post too many times in succession (as decided by the Forum). That’s what occurred with the post I tried to make this morning. It seems to me that the Forum has some setting to guard against a post being edited too often, too fast. The silly thing is that the fact I have posted still shows up in the thread index, but you can’t actually view the post.

    The next problem is that, having struck this issue, it can become impossible to post the comment at all. This morning I tried every which way to post on this thread (after my initial post disappeared), even starting from scratch many times, and leaving it about 15 mins between attempts. Then I had to go out, so left it some hours – when I came home I tried again and this time it worked.

    Hopefully there may be a way to tweak some setting so those of us who tend to edit our posts don’t get them kicked out of a thread.

    #48998

    Gillian
    Moderator

    As a Moderator, I just trashed an unwanted post of mine and then saw that my missing posts have now appeared, apparently treated as “Spam”.  It seems that too many edits, similar to re-posts of same/very similar content, triggers the spam filter. Can the filter be relaxed a bit?

    #49000

    Inga
    Participant

    Sounds like something that is necessary. Otherwise, there should be clear instructions to posters re how many times they are allowed to edit. (IOW, edit before you “Submit.”) The problem, as I see it, is that the editing window post looks quite different from the final post. So after seeing the final post, we want to “fix it.”

    Interesting too that I got all your posts, @gillian, via email. 😉

    #49003

    scrambler
    Moderator

    ” It seems that too many edits, similar to re-posts of same/very similar content, triggers the spam filter. Can the filter be relaxed a bit?”

    @weaver, If that is indeed what is happening, then I agree, Editing a post should not trigger the Spam filter. I constantly edit my posts 🙂

    #49026

    Weaver
    Keymaster

    It is so hard for me to figure out anything about either of these issues as I absolutely cannot reproduce them.

    bbPress has some settings for the editing window (I upped from 10 minutes to 30 minutes), and seconds between posts (now can post every 5 seconds). If it is Akismet spam filter, there are no settings available to tweak, and I don’t know of any way to test what it is doing. And I don’t think any of these practices should trigger Wordfence. Maybe Cloudflare?

    And, I’ll try the intent/italic thing.

    This sentence will first be changed to Italics by highlighting it, and then I will try to indent it, and I will make it more than one line wide and include a emoticon  here just to see.

    My problem is stopping the indenting.

    The next sentence is done by an unformatted copy / paste (text only paste):

    This sentence will first be changed to Italics by highlighting it, and then I will try to indent it, and I will make it more than one line wide and include a emoticon  here just to see. [now will indent, then italic].

    Ok, now I will Submit this.

    #49027

    bruce
    Moderator

    Ok, so let met try the indent / italic thing from by Moderator account to see if Keymaster’s get special treatment.
    <p style=”padding-left: 30px;”>This sentence will first be changed to Italics by highlighting it, and then I will try to indent it, and I will make it more than one line wide and include a emoticon  here just to see.</p>
    So now what?
    <p style=”padding-left: 30px;”>Indent and bold.</p>
    And post.

    #49028

    bruce
    Moderator

    Okay – mystery solved. The input of mortals is being filtered for allowed HTML. The indent uses <p> which is being escaped by the content filter to &lt; and &gt; (and smart quoted).

    That may be an issue with my Weaver for bbPress plugin – I think it has a content filter.

    #49030

    Inga
    Participant

    @weaver Aha! So you got special treatment. That’s why you couldn’t reproduce what was happening to us. 😉

    Nice to make some progress on solving mysteries!

Viewing 16 posts - 1 through 16 (of 18 total)

You must be logged in to reply to this topic.