Home Forums Weaver Xtreme Theme Footer Widgets wrapping but space is available

Topic Resolution: Answered

This topic contains 12 replies, has 2 voices, and was last updated by  dskirk 1 month, 1 week ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #59742
    Answered

    dskirk
    Participant

    Hi, again. This problem is similar to the one I had yesterday. I set footer to 4 columns and added a fourth widget, but one widget (the widest) wraps but there is space available. I’ve fiddled with HTML to no avail to fix this. Any tips are very very welcome. Site is https://davidkirk.org/cicerony/   Thanks much,

    david

    #59743

    scrambler
    Moderator

    I think you are having cache issues, because I see 4 widgets wide by side.

    If you are using a cache plugin, make sure to clear it after doing changes. Also clear your browser’s caches.

    #59744

    dskirk
    Participant

    I hope this doesn’t appear twice. I submitted a response, but maybe I had timed out.

    I do see 4 widgets in IE11, but 3 across and one wrap in Firefox, Chrome and Opera. And there is no cache plugin. And all the browsers immediately showed the new content and I think that eliminates the issue of a browser cache problem. I even installed a fourth browser (portable Chrome) and it also immediately showed the 3. I think I’m fighting more than a cache issue. Any tips on what I might be encountering that causes this? Thanks much,

    david

    #59745

    scrambler
    Moderator

    I see 4 side by side on Edge, Chrome and Firefox.

    It only goes to two lines of two when the browser is reduce to mobile size.

    So if you don’t have a cache plugin or use something like CLoudflare that has its own cache, not sure what may be going on.

    Have you tried different computers?

    #59746

    dskirk
    Participant

    I just tried my wife’s computer. Same thing.

    #59747

    scrambler
    Moderator

    Do you know how to use the Browser developer tool?

    If so, Open it (F12), right click on the first footer widget and select Inspect elements.

    scroll up to the HTML tag call aside, it should look like below with the id=”custom_html-18″

    <aside class="widget_text widget widget_custom_html font-alegreya-sans per-row-4-m smart-rm begin-of-row widget-1 widget-first widget-odd" id="custom_html-18">

    Does it have the per-row-4-m class as highlighted in yellow above or 3-m?

    #59748

    dskirk
    Participant

    I added this CSS code:

    img {
    box-sizing: border-box;
    height: auto;
    margin: 0;
    max-width: 30% !important;
    padding: 0;
    }

    And now it shows properly on all my browsers. I hope it still looks okay from your view. Puzzling to me. Thanks for your time in reviewing this.

    david

     

    #59749

    scrambler
    Moderator

    Also, Are you using any CSS / JS optimizer plugins, or plugin with an optimizer option?

    #59750

    scrambler
    Moderator

    Please check the code as I explained above so we can be sure if it is a problem with the option not being active, or some HTML in the widget causing it for you

    #59751
    Best Answer

    scrambler
    Moderator

    This reply has been accepted as the best answer.

    As far as I can tell your rule is making no difference on the footer content, so you may want to try and remove it and see what happens now…

    If you do leave it in, you need to specialize it, because it does affect the size of your other images in the content area above it. Also only the max width would be relevant as the other properties are already being applied

    To limit its effect to the footer widget area, the rule would be

    #footer-widget-area img {
    max-width: 30% !important;
    }

    #59752

    dskirk
    Participant

    Oops! That fixed one problem, but created others. So, not fixed. Sorry.

    #59753

    scrambler
    Moderator

    We may have cross posted, please reread my last few posts…

    #59754

    dskirk
    Participant

    THANKS. Your CSS worked. Mine created lots of problems. Thanks so much. I sincerely appreciate your patience as I stumbled through this.

    david

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.