Home Forums Weaver II Theme Filling the row with images. Too much space

This topic contains 54 replies, has 4 voices, and was last updated by  michalk 2 years, 11 months ago.

Viewing 16 posts - 33 through 48 (of 55 total)
  • Author
    Posts
  • #26307

    michalk
    Participant

    The margin rules property to removes are in yellow below. I suspect the rule itself is in Main options > FOnts & Custom Custom CSS rule box

    #content {border:1px solid #C3D4E6;padding-left:10px !important; padding-right:10px !important;margin-left:10px !important; margin-right:10px !important;}”
    I had that in main options>content area>content area. Took out what you yellowed and it’s perfect now
    #26308

    michalk
    Participant

    I noticed some of your pages use divs with the 2 column class from weaver II.

    These are different in Xtreme, so you will need to edit that content. Two main differences, the class are different, and the columns divs must be inside a div container.”
    Don’t know which page you’re talking about – I think they were just caused by the Featured images which I now solved everywhere – but if you see one still please let me know
    #26309

    michalk
    Participant

    Now I’m going back to where this whole thread began…

    I created a page called BLOG POSTS http://experiencedmoms.com/blog-posts/  (in the top menu) 
    I wanted the 21 images from the different blog posts lined up 3×7 each with a link to that post only
    1 – Even though I chose Settings for “Page with Posts” Template > Title + featured image – only the image shows (if I choose title only nothing shows though two days ago when all my styling was missing the titles actually showed with the image – so I know it’s there somewhere, just don’t know how to get it to show (full blog works on my home page)

    2- I would like those images to be large so three fill the page across – I’m not getting that

    #26310

    michalk
    Participant

    Header image – Weaver ii offered a choice of 10 different header images – Now I’m forced into this one (or provide my own). Where are the other ones? I want my old one back

    #26311

    scrambler
    Moderator

    0)If you want the space between content and sidebar back, use the margin option I mentioned in my previous post.

    1) I am at a lost of what can cause your titles to be missing completely. The only ways I know to get rid of the title is to use the Hide title option on each post, but if your blog page using the same posts shows them that should not be the issue (do double check). The other way would be to use some CSS to hide them , but they would be in the page html and just hidden, and they are not even in the page.

    I would try a couple of things:

    a- Create a new test page, select the page with posts template, click publish. See if the titles are there.
    If they are just select Display Post as: Title + Featured image in the page editing page option, and see if they are still there.

    If that test works, you may have some corruption in your original page, and just redo it.

    b- If the above does not work, try to deactivate ALL non weaver plugins to see if that makes a difference.

    2) I am seeing 3 images across, but the size of the featured image is defined in Main Options > Post Specific > Featured image sections. You have a lot of options for size and position there, for full posts, excerpt posts and single post page.

    3) header image, these are indeed not there for some reason, but you can pick it up in the weaver II folder on your host server, or you can temporarily actiavte weaver II, and copy it from the browser (right click > Save image as).

    #26312

    michalk
    Participant

    Now I finally know what’s going on with the post titles. Let me first tell you that the actual titles are not what you see on the posts or blogs going down. They’re the first <H1> of the post. I actually don’t want the titles ever showing cause a post with a title like “Chore List” Shows on the Post “Teaching Responsibility: Age Appropriate Chore List for Children” – That’s what I wanted. In my custom CSS I had the line “.post .entry-header {display:none;}” – (I think that’s what did it). Then tha CSS stopped working so on the posts suddenly the title was there (though it wasn’t in blogposts page?) so  I went to each blog and checked “hide Post title”. So no titles for anything. I unchecked one and that tile is on the post, the blog posts and the home page blog. I don’t know wy it was only on the post before.


    So it does work. I think the CSS line stopped working so I then checked each post. But I don’t want that. I don’t want that TITLE anywhere. I want my <H1> from each post with the image. Looks like I’m back to trying to set up my own page















    #26313

    scrambler
    Moderator
    I am not quite following why you cant just make the post title be the titles you want.
    Whatever text you are putting in your h1, why could you not use that text as the actual post title??
    Anyway if you are not going to use post titles, and still want to create a page with the featured image and a custom title, another way to do that would be using manual excerpts.
    So the question is, aside from that page you are trying to create, are you displaying the posts as exerpts anywhere else?
    If you are not, then you can put the custom titles in the manual excerpt of each post (if you don’t see a manual excerpt box in the post editing pages, activate the option in Screen options at the top). Then you can display post as excerpts, and that will show the featured image and your custom title.
    We may need to add some custom CSS to format it properly

    scrambler
    Moderator
    If you are already using excerpted posts in some pages we have some other possibility.
    In the post content, you could put all the content of the post (below the h1) Inside a div with a class, this would allow us to hide the posts content on the page you are trying to create.
    Each post content would look like
    <h1>Your custom Title</h1>
    <div class=”mypostcontent”>The content for the posts</div>
    Then we will be able to hide ALL posts content (excluding the h1) with  CSS

    michalk
    Participant

    I like the manual excerpts for the heading. I don’t think I’ll ever want to use the excerpts. But maybe I should leave that option for whenever. How would the CSS go if I want that way? 

    I’m stopping for now till tomorrow
    thanks

    scrambler
    Moderator

    if you decide to use a div with a class, the rule to hide them will be

    .page-id-xxxx .mypostcontent {display:none;}

    replacing xxx by the page ID#

    #26317

    michalk
    Participant

    I’m trying the second way and it’s not working 

    I did exactly this:
    <h1>Your custom Title</h1>
    <div class=”mypostcontent”>The content for the posts</div>
    Then I added in the Custom CSS rules :
    .page-id-971 .mypostcontent {display:none;}

    (I also tried .post-id… cause it’s really a post id)

    Unless you have a different suggestion… since I changed to Weaver Xtreme, I think my Custom CSS Rules box doesn’t work. Look back a few posts here and you’ll see I said “ In my custom CSS I had the line “.post .entry-header {display:none;}” – (I think that’s what did it). Then the CSS stopped working so on the posts suddenly the title was there (though it wasn’t in blogposts page?) so  I went to each blog and checked “hide Post title”.

    I really don’t know what all the CSS I have there is from so I don’t know if there’s other stuff that doesn’t work from here but those don’t
    I think that’s why I can’t use that way to just have my heading there

    scrambler
    Moderator
    Please provide a link to the page 971 with the custom CSS rule in so we can what the problem is.
    If your custom CSS rule do not work, you probably have some syntax error in your custom CSS that breaks your CSS file. Run all custom CSS through a CSS validator.
    Eventually paste the content of your CSS box here.
    #26319

    michalk
    Participant

    This is the post http://experiencedmoms.com/cloth-diapers/   

    Here’s all my Custom CSS  (I’ve tried post-id and page-id. I leave a space after 971 or take it out (what exactly should it be?) 
    .featuredproducts .title .corner-right
    {
    width:657px;
    }
    #sidebar .title
    {
    border:none;
    }
    #sidebar .title .corner-right
    {
    width:251px;

    }
    .corner-right h2{
    width:100%;
    margin-bottom:8px;
    display:block;
    height:7px;
    font-family:Tahoma, Arial, Helvetica, sans-serif;
    font-size: 12px;
    font-weight: bold;
    color:#FFF;
    }
    #productbox
    {
    float:left;
    list-style:none;
    padding:5px;
    margin:2px 2px 2px 2px;
    border: 5px solid #cccccc;
    width:100%;
    }
    #productbox td
    {
    width:140px;
    padding:5px;
    text-align:center;
    background-color: #FFFFFF;
    margin:0 6px 5px 0;
    border: solid 3px #0B6121;
    padding:2px;
    }
    .featured h1
    {
    margin:0px;
    padding:8px 8px 8px 0;
    background-color: #FFF;
    font: normal 22px/22px Georgia;
    }
     
    Too many characters so continued in next post
    #26320

    michalk
    Participant

    Continuing custom ID

    .postbody { line-height: 145%; font-size : 12px; background-color: #E8F0F7; }
    a.postlink:link { line-height: 145%; text-decoration: none; color : #006699 }
    a.postlink:visited { text-decoration: none; color : #006699; }
    a.postlink:hover { text-decoration: underline; color : #444444}

    .postbodyguide { line-height: 145%; font-size : 12px;  }

    .postbodybold { line-height: 145%; font-size : 12px; font-weight : bold; }

    .postbodyitalic { line-height: 145%; font-size : 12px; font-weight : bold; font-style:italic; }

    .content-2-col-left {width:47%;}
    .content-2-col-right {width:47%;}
    .post-id-971 .mypostcontent {display:none;}


    scrambler
    Moderator
    I said page not post id
    .page-id-971 .mypostcontent {display:none;}
    NOT
    .post-id-971 .mypostcontent {display:none;}
    But that is for a regular page that has an ID like the page with posts you wanted to create
    the page you linked to is a single post page, for that the class is    .postid-xxx
    For that single post page the rule would have to be
    .postid-971 .mypostcontent {display:none;}

    You can find these classes by inspecting your page using your brpwser developer tools

    michalk
    Participant

    I put .postid-971 .mypostcontent {display:none;} in my custom CSS – 971 is the post that has the code <div class=”mypostcontent”>


    still no change
Viewing 16 posts - 33 through 48 (of 55 total)

You must be logged in to reply to this topic.